Bug 47325 - : Existing Base reports won't open in LibreOffice 3.5
Summary: : Existing Base reports won't open in LibreOffice 3.5
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other All
: high major
Assignee: Lionel Elie Mamane
URL:
Whiteboard: BSA target:3.6.0.0.beta1 target:3.7.0...
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-03-14 16:00 UTC by frofa
Modified: 2013-06-30 01:37 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
*very* tentative patch (1.39 KB, patch)
2012-06-05 08:58 UTC, Lionel Elie Mamane
Details

Note You need to log in before you can comment on or make changes to this bug.
Description frofa 2012-03-14 16:00:39 UTC
Problem description:

I have many (painstakingly designed) reports originally done in Oo 3.3 using the ('old style') report wizard (which I used because, after much trial and error, I could not get the result I wanted with the Oracle Report Builder v 1.2.1). All my saved reports run fine in LO 3.45, but NOT in LO 3.5.

In LO 3.5 when I click on a particular report to run it, the expected window saying "Connecting to data source.... Importing data...." opens for a brief instant, then disappears, leaving just the window with the report template layout showing...but no report is ever generated. Note: All the queries my reports are based on run perfectly (in LO 3.5) so it doesn't seem to be a database connection problem. As a further test, I set up a new report (again using the 'old-style' wizard) but this time using LO 3.45, and it runs fine, but it still does not run in 3.5. Other people have reported this problem on Windows (see http://en.libreofficeforum.org/node/2589)

Steps to reproduce:

1. Create & save a report (based on some query) using the 'old style' wizard using OO 3.3 or an earlier version of LO (not 3.5). You'll need to disable the Report Builder extension to use the 'old style' wizard.

2. Open the file in LO 3.5 and try to run the report.

Current behavior: See problem description above.

Expected behavior: See problem description above.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0) Gecko/20100101 Firefox/11.0
Comment 1 Ian~G 2012-03-24 05:42:06 UTC
same here on linux (ubuntu 11.10) with reports created on openoffice 3.2.1 under linux (ubuntu 10.04 lts)

also same on libreoffice 3.5.1

also existing reports did not run on libreoffice 3.4.5

i also agree your views on report-builder. it is very klunky - once you have figured out where the wizard templates live and have edited the errors out of them, the wizard works very well for rapid report creation.

in terms of upgrading, this is a show-stopper for me as an office front-end to our MySQL database is essential to running our uk charity and my carefully crafted reports won't run on libreoffice.

it is also not possible to re-create them. ie create new ones, due to bug 47473.

we will not be able to upgrade ubuntu 10.04 lts to 12.04 lts until these problems are fixed as deploying openoffice 3.3 under unity is rather painful.
Comment 2 frofa 2012-04-16 01:40:44 UTC
After much trial-and-error sleuthing, I may have hit upon a solution to this apparent problem (reported here by me several weeks ago). It involves adding a 'missing' hidden form control (see steps below). I'll be interested to know if this actually helps anyone with problems running legacy database reports under LO.

1. Open your legacy report for EDITING in the usual way (right-click and choose 'Edit').

2. Now open the FORM NAVIGATOR (button).

3. Under the 'Report source' item you should see these controls - CommandType, QueryName, Command, GroupFieldNames, FieldNames, RecordFieldNames. If there is NOT an item named 'Sorting', you must add it. I found it 'missing' in my legacy reports (created in OO), and when I added it, the reports run properly! (Perhaps this 'Sorting' hidden control has been added at some stage of LO development?)

4. To add the 'Sorting' item, just do these steps:
  - Right-Click on the enclosing item 'ReportSource'
  - Under the NEW item pop-up menu select 'HiddenControl', and a new control will be created in the end of the list of existing controls (probably under the item 'RecordFieldNames').
  - Now, change the name of this new control to 'Sorting'.
  - To do this, right-click on the new item, and choose PROPERTIES from the pop-up menu.
  - In the resulting window/pane, change the (Hidden Control) name to 'Sorting' (type exactly - no quotes, and with a capital 'S') and close the window.
  - You should now see an item called 'Sorting' at the end of your list of hidden control for your report source item.
  - Close the Form Navigator window and SAVE the report.

5. Your legacy report should now run/open as it used to under OpenOffice.
Comment 3 Ian~G 2012-04-18 08:47:43 UTC
Hi Fred,

Cool. Works here on 3.5.2 and linux ubuntu 12.04.

This easier than re-creating all my legacy reports.

I found a workaround to enable the creation of new reports using the wizard. See bug 47473. 

Seems like a fair swap!

Regards, Ian
Comment 5 frofa 2012-05-11 18:31:26 UTC
Also (on my Mac installation anyway) the bugs reported above do NOT affect LO 3.46...
Comment 6 Ian~G 2012-05-12 08:16:20 UTC
just re-checked and legacy reports DO RUN in lo 3.4.5 under ubuntu 11.10

however, you can't create new ones with the wizard due to some fields in some queries not being listed at all and failure of grouping / sorting on the ones that do list.

thanks for the additional info. nice to know there's more than two of us actually using databases.
Comment 7 sasha.libreoffice 2012-06-05 04:39:19 UTC
@ Lionel
Greetings
What do You think about this bug? (Attachment here: Bug 47473)
Comment 8 Lionel Elie Mamane 2012-06-05 08:58:29 UTC
Created attachment 62590 [details]
*very* tentative patch

Could someone please try this patch?

Thanks. There is a small chance it could also help for bug 47473, but I'm not holding my breath.
Comment 9 Not Assigned 2012-06-05 09:45:03 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=58c716d6ef550c056cc19b75f109983e661b9246&g=libreoffice-3-6

fdo#47325 legacy reports: survive absence of Sorting hidden control


It will be available in LibreOffice 3.6.
Comment 10 Not Assigned 2012-06-05 09:45:27 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3ec6e1378545b5d5071531d1f6de259ac9028176

fdo#47325 legacy reports: survive absence of Sorting hidden control
Comment 11 Lionel Elie Mamane 2012-06-05 09:55:11 UTC
Asked for review for application to LibreOffice 3.5 branch. May take a few days.
Comment 12 Michael Stahl (CIB) 2012-06-05 11:45:49 UTC
interesting, looks like a regression from OOo 3.4 CWS dba34d
commit e0c1daa9561ff447351135f3318d1a1183077212

did anybody try if the patch is sufficient to fix the problem?
i'll push it to the 3.5 branch in any case...
Comment 13 Not Assigned 2012-06-05 11:53:29 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bcf7425c7222e6c1e343c5e9a45d5fdf66dac53d&g=libreoffice-3-5

fdo#47325 legacy reports: survive absence of Sorting hidden control


It will be available in LibreOffice 3.5.5.
Comment 14 sasha.libreoffice 2012-06-05 23:29:06 UTC
Thanks for fixing this bug (at least I hope that it fixed because not tested)
Comment 15 Rainer Bielefeld Retired 2012-08-03 09:10:04 UTC
We need exact and correct target information for automated lists in Wiki and LibO Web Site.