Bug Hunting Session
Bug 47365 - Impress does not honor loop in powerpoint presentation
Summary: Impress does not honor loop in powerpoint presentation
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords: filter:pptx
Depends on:
Blocks: PPTX
  Show dependency treegraph
 
Reported: 2012-03-15 08:18 UTC by Rui
Modified: 2019-02-23 10:59 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
looped presentation in ppt format (48.00 KB, application/vnd.ms-powerpoint)
2013-05-29 11:28 UTC, sasha.libreoffice
Details
looped presentation in pptx format (35.44 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2013-05-29 11:29 UTC, sasha.libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rui 2012-03-15 08:18:40 UTC
When playing a powerpoint ppsx file that has a loop directive Impress stops at a black screen with "press ESC to exit presentation" instead of looping to the first slide.
Comment 1 sasha.libreoffice 2012-03-23 06:21:18 UTC
Thanks for bugreport
Please, attach presentation that demonstrates this problem (with set loop directive On)
Comment 2 Joel Madero 2013-05-28 15:38:00 UTC Comment hidden (obsolete)
Comment 3 sasha.libreoffice 2013-05-29 11:28:41 UTC
Created attachment 79955 [details]
looped presentation in ppt format
Comment 4 sasha.libreoffice 2013-05-29 11:29:14 UTC
Created attachment 79956 [details]
looped presentation in pptx format
Comment 5 sasha.libreoffice 2013-05-29 11:32:13 UTC
in 4.0.3 on Fedora (RFR) 64 bit:
ppt loop is working. But after last slide before next round added pause 10 sec
pptx loop not working
Comment 6 Jochen 2013-12-26 11:27:10 UTC
An user in de-user-ML has reported, that the bug exits also in LO 4.1.4. I have asked him to attach the document.
Comment 7 Andreas 2013-12-26 12:28:43 UTC
I am the user of de-user-ML, as Jochen wrote. I have installed version 4.1.4.2 of LibreOffice. 

When I will open a ppsx-file it appears to me only the first slide of the presentation and unfortunately nothing more.

With the PowerPoint-Viewer a have no problems to look the presentation.

My ppsx-file is nearly 5 MB an if you want or need it, I will try to upload it as attachment.

Is a very nice Christmas animation deposited with moving images and music.

Best regards
Andreas
Comment 8 QA Administrators 2015-04-19 03:22:34 UTC Comment hidden (obsolete)
Comment 9 Buovjaga 2015-06-18 14:09:16 UTC
(In reply to sasha.libreoffice from comment #5)
> in 4.0.3 on Fedora (RFR) 64 bit:
> ppt loop is working. But after last slide before next round added pause 10
> sec
> pptx loop not working

Still same result.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 437210d58f32177ef1829d704f7f4d2f1bbfbfdd
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-18_07:21:56
Locale: fi-FI (fi_FI)
Comment 10 QA Administrators 2016-09-20 10:10:46 UTC Comment hidden (obsolete)
Comment 11 eisa01 2018-09-24 20:54:34 UTC
Still the same

Version: 6.2.0.0.alpha0+
Build ID: 16a0a64e7ec9c25e991d164f540f8e9edaea99af
CPU threads: 2; OS: Mac OS X 10.13.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2018-09-24_06:53:45
Locale: en-US (en_US.UTF-8); Calc: threaded
Comment 12 Mike Kaganski 2019-02-22 22:55:29 UTC
https://gerrit.libreoffice.org/68237

Only import is handled; I don't plan to work on export - someone needs to do export part.
Comment 13 Commit Notification 2019-02-23 10:50:27 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/ad2809b4b6dc4837b0c1cadd89a14a234d995fb2%5E%21

tdf#47365: import support for PPTX presentation's loop attribute

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Mike Kaganski 2019-02-23 10:59:36 UTC
Unassigning to allow others to work on export part.