Bug 47650 - Create a bibisect repo for 3.3->3.4
Summary: Create a bibisect repo for 3.3->3.4
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords: difficultyInteresting, easyHack, topicQA
Depends on:
Blocks:
 
Reported: 2012-03-21 06:54 CET by Björn Michaelsen
Modified: 2016-02-18 16:37 CET (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Michaelsen 2012-03-21 06:54:18 CET
http://wiki.documentfoundation.org/QA/HowToBibisect

describes "binary bisect" for hunting regressions in LibreOffice 3.5. Since we had quite a few regressions introduced with 3.4 which are still open, it would be great to have the same available for 3.3->3.4.

The 3.5 repo was created with the scripting at:

 http://cgit.freedesktop.org/libreoffice/contrib/dev-tools/tree/bibisect

it would need quite a bit of adjustment to cope with the old multi-repo setup of the 3.4 days.
Comment 1 Florian Reisinger 2012-05-18 09:25:33 CEST
Deleted "Easyhack" from summary.
Comment 2 Samuel Mehrbrodt (CIB) 2013-10-01 22:08:46 CEST
Is this still valid?
Comment 3 Björn Michaelsen 2013-10-18 19:59:52 CEST
@Samuel: Still valid.
Comment 4 Björn Michaelsen 2013-10-18 20:03:42 CEST
CCing developer list to Easy Hacks missing this.
Comment 6 Robinson Tryon (qubit) 2015-12-16 05:27:33 CET
Migrating Whiteboard tags to Keywords: (EasyHack DifficultyInteresting TopicQA)
[NinjaEdit]
Comment 7 Robinson Tryon (qubit) 2016-02-18 16:37:04 CET
Remove LibreOffice Dev List from CC on EasyHacks
(curtailing excessive email to list)
[NinjaEdit]