Download it now!
Bug 47677 - New Toolbar that has "Record Changes" (Track Changes) options
Summary: New Toolbar that has "Record Changes" (Track Changes) options
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium enhancement
Assignee: Joel Madero
URL:
Whiteboard: target:4.2.0
Keywords: needsDevEval
: 65777 70101 (view as bug list)
Depends on:
Blocks: Track-Changes
  Show dependency treegraph
 
Reported: 2012-03-21 12:11 UTC by almos
Modified: 2017-12-05 13:49 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments
MS Word 2011 - Review Changes - Toolbar Buttons (129.60 KB, image/png)
2013-07-24 10:10 UTC, Peter Lairo
Details
MS Word 2003 - Review Toolbar (6.68 KB, image/png)
2013-07-24 10:27 UTC, Eyal Rozenberg
Details
Screenshot of my "Review Changes" Toolbar in LibrOffice - with Icon (3.58 KB, image/jpeg)
2013-07-24 10:37 UTC, Peter Lairo
Details
Screenshot of my Toolbar with icons & text (8.09 KB, image/jpeg)
2013-07-24 10:39 UTC, Peter Lairo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description almos 2012-03-21 12:11:25 UTC
Also, a 'jump to next/previous change' feature would be nice.
Comment 1 Joel Madero 2012-12-07 23:58:32 UTC
With such limited space we won't be adding more to the default toolbar. The track changes feature is really nice but most users who know how to use track changes could figure out how to add the option to the toolbar if they want it.

If you're unsure how to do it:

View -> Toolbars -> Customize

Then go to "Add...." click "Edit" and select record and show.

Thanks for the suggestion, unfortunately with space limitations having a feature like this by default isn't going to happen.

Many thanks again, please keep the suggestions coming :)
Comment 2 almos 2012-12-08 11:28:34 UTC
I didn't say 'add track changes buttons to the default toolbar', I said 'add a new toolbar by default that has the track changes buttons'. There are 22 toolbars already, adding a new one won't hurt.

Just compare the workflow with msword. There you have a toolbar for it by default, which is activated whenever there are recorded changes, and you simply click on the next/previous change buttons to navigate, and click on the accept/reject buttons to handle the changes. In lo you have to open the 'accept or reject...' dialog, which disrupts the normal workflow, or manually find the changes (the navigator doesn't know about them) and use the right click context menu, where accept and reject are two of the too many items.

And I haven't said anything about tracking changes and adding notes in impress yet...
Comment 3 Joel Madero 2012-12-08 17:40:51 UTC
ah my mistake, I agree, that shouldn't be tough ;) 


Marking as NEW
Comment 4 Jorendc 2013-07-04 21:56:13 UTC
*** Bug 65777 has been marked as a duplicate of this bug. ***
Comment 5 Peter Lairo 2013-07-21 07:10:33 UTC
Create a Toolbar called "Changes" and place the following three buttons into it:

- Record Changes
- Show Changes
- Accept or Reject Changes

IMO the Toolbar should be OFF by default, and the default location of the Toolbar should be: floating on the screen (e.g. like the "3D Settings" Toolbar).

BTW: When I manually created this Toolbar, I also included the "Comments" Button.

Reporter: If you want buttons for "Next Change" and "Previous Change" (and I do too), the we would also need "Accept" and "Reject" buttons to be able to accept/reject changes directly from the Toolbar (and avoid the disrupting "Accept or Reject Changes" dialog. You probably need to file a separate bug for this.

New Toolbar UI (using currently limited buttons):

+-------------------------------------------+
| Record   Show   Accept or Reject Changes  |
+-------------------------------------------+

Ideal UI:

+----------------------------------------------------+
| Record   Show   Previous   Next   Accept   Reject  |
+----------------------------------------------------+

PS. Reporter: Please add the word "Record" to the bug's Summary.
Comment 6 Eyal Rozenberg 2013-07-21 11:20:41 UTC
I would say such a toolbar should also include, by default:

- Accept all/reject all
- choice of partial display of changes (a-la MS Word) - only style, only content, only some revisers etc.

And possibly also buttons relating to comments and to color-highlighting.
Comment 7 Joel Madero 2013-07-22 06:02:01 UTC
I'll see what I can do - no promises ;) If I don't make progress in the next 1-2 weeks I'll drop it so someone else can take it over
Comment 8 Joel Madero 2013-07-24 05:35:16 UTC
I'm making substantial progress on the first idea:

+-------------------------------------------+
| Record   Show   Accept or Reject Changes  |
+-------------------------------------------+

the second one is quite a bit more difficult.


CC'ing Astron:

Astron - do we have icons for these buttons , it's actually more under the "changes" options:

Record
Protect Records
Show
Accept/Reject
Comments


If we don't have icons I think we'll need them for the new toolbar.
Comment 9 Eyal Rozenberg 2013-07-24 06:44:37 UTC
I'll use this opportunity to note that the existing icons for recording, accepting and rejecting changes are too undistinctive - not so easy to tell apart from other toolbar icons. The distinctive part of them is small compared to the common 'blank page' image taking up most of the icon.

Still, even a poor icon and a less-than-featureful toolbar would be a great improvement, thanks Joel.
Comment 10 Peter Lairo 2013-07-24 10:10:11 UTC
Created attachment 82916 [details]
MS Word 2011 - Review Changes - Toolbar Buttons

Screenshot of MS Word 2011's "Review Changes" Toolbar Buttons.

For the icon, they use a page with a pencil across it as the universal "review" symbol, and then, for the individual icons, they overlay:

   - check-mark    (accept change)
   - red X         (reject change)
   - left-arrow    (previous change)
   - right-arrow   (next change)

BTW: Word 2011 also has a "Review Pane", but I don't know what it does.

LibreOffice would need to make the individual symbols *bigger* because our icons are smaller, and it is important that the icons be easily identified (a big weakness in LibreOffice's awful default Tango icons).

I don't think the icons should hold up this bug. The Toolbar would be fine without them. Many programs have Buttons without icons for lesser used functions. The icons could be added in a follow-up bug.

Joel: Thanks so much for taking this on!
Comment 11 Peter Lairo 2013-07-24 10:22:02 UTC
Oh, an MS Word 2011 also has drop-down menus for the Accept and Reject buttons, which let the user select "Accept All" and Reject All". That's pretty useful IMO and avoids cluttering up the Toolbar.

Scroll down in this page: 
http://www.papercheck.com/instructions-microsoft-word-2011-track-changes.html

I also agree that Previous & Next buttons should be *to the right of* the Accept & Reject buttons. Maybe even include some Separator Lines:

+----------------------------------------------------------+
| Record   Show  |  Accept^   Reject^  |  Previous   Next  |
+----------------------------------------------------------+
                 | Accept and move to next change |   <-- default action
                 | Accept selected changes        |   <-- I'm allowed to dream :-)
                 | Accept all changes             |
                 +--------------------------------+
Comment 12 Eyal Rozenberg 2013-07-24 10:27:22 UTC
Created attachment 82919 [details]
MS Word 2003 - Review Toolbar

In MS Word 2003, and with smaller toolbar icons, we see that the prominent and larget element of the icon is the abstract indicator of specific function:

- Red X for reject
- Blue V for accept 
- Blue arrows for next/prev change

The track changes button is kind of jumbled visually, but it's distinctively jumbled... can't mistake it for anything else on the toolbar.
Comment 13 Peter Lairo 2013-07-24 10:37:25 UTC
Created attachment 82920 [details]
Screenshot of my "Review Changes" Toolbar in LibrOffice - with Icon

I used the icons that are built into LibreOffice (icon style "Galaxy"). Most of them are adequate to get this bug finished with a high degree of quality. Better icons could follow in a future bug.

BTW: I also have the "Comments" button included, but this bug should probably not add that one too.
Comment 14 Peter Lairo 2013-07-24 10:39:12 UTC
Created attachment 82921 [details]
Screenshot of my Toolbar with icons & text

Same Toolbar, now showing icons and text.
Comment 15 Joel Madero 2013-07-24 15:00:24 UTC
Ah so there are icons for it - I'll have to dig because I didn't see them. 

For all other comments - thank you - in general we try not to do a "this is how MS does it so you should do the same" mentality. It's fine to offer suggestions but I'm not a huge fan of "do it exactly like they do it" ;) 

I'll most likely push the patch "as is" relatively soon and then I can play around with making it better over time.
Comment 16 Peter Lairo 2013-07-24 20:55:18 UTC
(In reply to comment #15)
> in general we try not to do a "this is
> how MS does it so you should do the same" mentality. It's fine to offer
> suggestions but I'm not a huge fan of "do it exactly like they do it" ;) 

Just for the record: I'm not suggesting we do it the way I suggested "because" Microsoft does it that way, but because it is the *best* way anyone has come up with so far. So, in absence of a better idea, I hope it will be implemented for the sake of the users who do not want to wait (forever) for a (potentially existent) better solution.

> I'll most likely push the patch "as is" relatively soon and then I can play
> around with making it better over time.

I know what that means, but I'll be happy to have any Toolbar (although I hope you will include the Next and Previous Buttons, since they do already exist in LibreOffice.

Whatever you do, I'm happy with it, because you might be the last person to care enough about this bug! I've seen very good bugs languish for years. So: THANK YOU!
Comment 17 Joel Madero 2013-07-26 15:26:19 UTC
I've done as much as I can without icons - from what I can see we do not have icons for any of these options:

Record Changes
Show Changes
Accept/Reject
Accept All
Reject All
Next/Previous
Protect

UX - any input here would be appreciated so I can tackle this one :-D
Comment 18 Eyal Rozenberg 2013-07-26 17:57:36 UTC
So, is there a patch with the toolbar?

Also, are rudimentary icons necessary for this to be committed? If that's the case, provide a link to a file/folder with existing icons in the appropriate format and maybe we'll do something about it.
Comment 19 Joel Madero 2013-07-26 18:07:43 UTC
Currently I don't see any icons at all and yes - we'd want icons before I submit a patch to git as right now it's just text: https://lh5.googleusercontent.com/-DzF5fk6XVYI/UfGxEgpW9KI/AAAAAAAAAQs/Pn2P7VIAgQU/w1046-h654-no/shot-2013-07-25_16-12-41.jpg

In terms of icons and what folder - if someone just makes some icons for me that fit the general theme (Galaxy) I can probably start with that. Just zip it up and attach to this report but even with this UX team probably will have to give the +1 before an actual commit happens.

For a patch of what I've done already - I'd prefer not to provide just quite yet as I haven't cleaned and I still have a bit of stuff to add - going to try to add the "Accept All" "Reject All" if I can track the uno. commands down.


Best
Comment 20 Peter Lairo 2013-07-27 11:30:18 UTC
(In reply to comment #19)
> In terms of icons and what folder - if someone just makes some icons for me
> that fit the general theme (Galaxy) I can probably start with that.

If someone is willing to look around here, they should be able to find icons for each button:

http://openiconlibrary.sourceforge.net/gallery2/?./Icons
Comment 21 Stefan Knorr (astron) 2013-07-27 11:54:40 UTC
Right, ideally, we would want icons & text at the same time, but in LibreOffice, afaik, these are mutually exclusive right now.
(CCing Kendy, who is currently mentoring a GSoC student implementing some improvements to toolbars. Kendy, are you maybe working on this issue already?)

As long as we can't use both icons & text, I'd propose to stay with text.
Comment 22 Cor Nouws 2013-07-27 12:26:29 UTC
(In reply to comment #2)

> ....  In lo you have to open the
> 'accept or reject...' dialog, which disrupts the normal workflow, or

It's a dialog that allows you to work in the document too (and that has some nice other extra's). But indeed, it is quite large ;)

Set the version to the oldest LibreOffice: it's proposed to be a new toolbar that has never been there.
Comment 23 Joel Madero 2013-07-27 17:16:11 UTC
If it's just text - like the image I showed in the link I provided - the toolbar is basically done. I'll try to add at least accept/reject all and then it would be done with text.

The interesting thing is - there's an extension for this already but I tried installing it and it failed 

http://extensions.libreoffice.org/extension-center/review-toolbar/pscreleasefolder.2011-12-03.6583332356/201204.12.0.1
Comment 24 Joel Madero 2013-07-27 22:38:03 UTC
That extension does actually do everything you're looking for - I wonder if we can just incorporate it into our code -

Michael - how hard is it to just take the code from the extension? The icons show up correctly and seems to do what's being asked in its entirety which is a bit farther than I've managed to get up to now.

http://extensions.libreoffice.org/extension-center/review-toolbar/pscreleasefolder.2011-12-03.6583332356/201204.12.0.1
Comment 25 Michael Meeks 2013-07-29 09:44:02 UTC
I'd love to get that functionality included. I'd have this set of actions there:

+ re-write as C++:
++ so it won't impact startup-performance (extensions do sadly)
++ so we can include a sidebar pane / area for this
+ get it MPLv2 licensed

Otherwise it looks like a sexy feature to add; I'd love it as a stock toolbar that automatically shows up for documents with red-lining enabled :-)

Who is the author ? Cloph - any chance you can dig that out of plone ? also re-writing this as a built-in toolbar should be an easy-hack I think - with enough code-pointers.
Comment 26 Joel Madero 2013-07-29 14:39:43 UTC
well if you want it just re-written, I have at least 50% of the work already done;) So I'll take it. the only thing I'm currently lacking is icons and a couple of the functions which I think will be easy enough to add. 

So I'm still having some issues with the icons - weird thing is when I installed the extension icons came up on the toolbar I added - so maybe the extension adds icons?
Comment 27 Michael Meeks 2013-07-29 15:11:33 UTC
> well if you want it just re-written, I have at least 50% of the work already
> done ;) So I'll take it.

Nice :-) looking forward to reviewing the patch.

> the only thing I'm currently lacking is icons and a couple of the
> functions which I think will be easy enough to add.

Sounds lovely.

> So I'm still having some issues with the icons - weird thing is when I
> installed the extension icons came up on the toolbar I added - so maybe
> the extension adds icons?

Sure - unzip it and look in images/ - but of course, we'd need to get our artists to draw some new Tango'y ones if we need them for this; that is assuming we don't have those images in icon-themes/galaxy/cmd/ - they look simple enough that we could well have them there already.

Thanks !
Comment 28 Jan Holesovsky 2013-07-31 21:10:49 UTC
Astron: Wrt. comment 21, it turns out it is possible to show both the text as well as icon when you specify

toolbar:style="image text"

to the toolbar item description (ie. like

<toolbar:toolbaritem xlink:href=".uno:Save" toolbar:helpid="5505" toolbar:style="image text"/>

in the appropriate toolbar description .xml).
Comment 29 Michael Meeks 2013-08-20 09:46:05 UTC
Hi Joel - really looking forward to having this; do you have a patch ? :-) I'd love to read it over and/or get it polished up & merged.
Comment 30 Zeki Bildirici 2013-10-04 07:01:00 UTC
*** Bug 70101 has been marked as a duplicate of this bug. ***
Comment 31 Zeki Bildirici 2013-10-04 07:23:38 UTC
(In reply to comment #24)
Hi,
> That extension does actually do everything you're looking for - I wonder if
> we can just incorporate it into our code -
> http://extensions.libreoffice.org/extension-center/review-toolbar/
> pscreleasefolder.2011-12-03.6583332356/201204.12.0.1

This extension is very useful and the functions are satisfying but i think -because of being crucial functions on review process- having Compare Document and Merge Document functions in this toolbar will be great.

Hope to have this soon.

Best regards,
Zeki
Comment 32 Joel Madero 2013-10-23 23:39:46 UTC
So I've made a commit on this but several things still need done - I am going to open new reports for each:

1. Track changes for Spreadsheet (this one only encompasses Writer which seemed to be the most natural)

2. New uno commands for Accept All and Reject All

3. Ideally the "accept" and "reject" buttons would automatically select the next word (currently you have to click on the word and then you can either accept or reject the change)

That being said, it's a start
Comment 33 Michael Meeks 2013-11-05 11:29:54 UTC
Hi Joel - I couldn't see your commit :-) is it stalled in gerrit or something ? - the feature freeze is looming for 4.2 and I'd love to get this one in...
Comment 34 Joel Madero 2013-11-05 14:08:05 UTC
Well, that's interesting ;) I'll ping you on IRC to figure out how to get to it - I submitted it with one of the git GUI's for the first time - wonder if something wacky happened
Comment 35 Commit Notification 2013-11-14 11:50:21 UTC
Joel Madero committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=686ab95e97e3a432fcccc88ae30b8ad6eed1b2b4

fdo#47677 - Track Changes Toolbar



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 36 Robinson Tryon (qubit) 2013-12-14 11:39:18 UTC
This bug is in 'ASSIGNED' state but not actually assigned to anyone...

Assigning to Joel (as that appears to make the most sense)
Comment 37 Joel Madero 2014-02-27 23:31:05 UTC
FIXED but there is room for improvement that should be reported in a new bug
Comment 38 Robinson Tryon (qubit) 2015-12-18 10:13:13 UTC
Migrating Whiteboard tags to Keywords: (ProposedEasyHack -> needsDevEval)
[NinjaEdit]