Download it now!
Bug 47709 - Writer does not respect the KDE system setting paper size
Summary: Writer does not respect the KDE system setting paper size
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: needsKDE
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2012-03-22 04:45 UTC by Dotan Cohen
Modified: 2019-09-19 19:40 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dotan Cohen 2012-03-22 04:45:48 UTC
In KDE 4.7 I have the system settings paper size set to A4. Despite this, Writer insists on using Letter for all new documents. Furthermore, there is no way to set the default paper size in Writer for all new documents.
Comment 1 Dotan Cohen 2014-11-08 14:29:37 UTC
I see that this bug was recently changed to status NEEDINFO. What information do you need?

The distribution is Kubntu Linux, I have experienced this issue in all versions including the latest LTS release 14.04.
Comment 2 Buovjaga 2014-11-08 14:36:43 UTC
(In reply to Dotan Cohen from comment #1)
> I see that this bug was recently changed to status NEEDINFO. What
> information do you need?
> 
> The distribution is Kubntu Linux, I have experienced this issue in all
> versions including the latest LTS release 14.04.

It's just that Bugzilla does not allow to change from NEW to UNCONFIRMED directly. Someone has to confirm this independently before it can be set to NEW.
Comment 3 tommy27 2014-12-29 08:27:51 UTC
@Dotan
please retest using latest 4.3.5.2 release and tell if bug is still present
when done, revert status to UNCONFIRMED if the bug is still present or change it to RESOLVED WORKSFORME if the bug is gone.
Comment 4 QA Administrators 2015-07-18 17:36:36 UTC Comment hidden (obsolete)
Comment 5 Dotan Cohen 2015-07-20 16:32:35 UTC
Thank you. The bug is reproducible in Kubuntu 15.04 with LO version 4.4.
Comment 6 tommy27 2015-07-20 17:16:36 UTC
@Dotan
thanks 4 feedback. now we need another Linux user to confirm it.
Comment 7 Jean-Baptiste Faure 2015-08-01 05:44:04 UTC
(In reply to Dotan Cohen from comment #0)
> In KDE 4.7 I have the system settings paper size set to A4. 

I guess you are speaking about default paper size in the printer, right?

> Despite this, Writer insists on using Letter for all new documents. 
> Furthermore, there is no way to set the default paper size in Writer 
> for all new documents.

The paper size for a text document is defined by the page format. The default page size is defined in the default page style.
To change the default page style, you have to define your own default template.
See the documentation about default template: https://help.libreoffice.org/Writer/Changing_the_Default_Template

For me, it is not a bug if Writer does not get the default page size from the default paper size in the printer. AFAIK Writer get the default page size from the locale (Letter in USA, A4 in Europe, etc.).

Best regards. JBF
Comment 8 Carlos Rodriguez 2015-10-04 22:10:56 UTC
Hi! I'm getting the same behavior as comment #0. Changing locale settings on KDE does not change default paper size on LibO. 

On KDE System Settings there is a value for "Paper size" on "Locale"->"Other" tab. The help menu says that this option is for creating new documents and not related to printer paper size. Changing this value makes no change on LibO about starting a new text document.

I know that using the method mentioned by JBF on comment #7 is fine for setting the default template, but he also says that LibO should detect paper size on behalf of the Locale Settings.
Comment 9 Carlos Rodriguez 2015-10-04 22:15:59 UTC
(In reply to Carlos Rodriguez from comment #8)
> Hi! I'm getting the same behavior as comment #0. Changing locale settings on
> KDE does not change default paper size on LibO. 
> 
> On KDE System Settings there is a value for "Paper size" on
> "Locale"->"Other" tab. The help menu says that this option is for creating
> new documents and not related to printer paper size. Changing this value
> makes no change on LibO about starting a new text document.
> 
> I know that using the method mentioned by JBF on comment #7 is fine for
> setting the default template, but he also says that LibO should detect paper
> size on behalf of the Locale Settings.

Tested Debian 8 (jessie) with KDE:

Version: 5.1.0.0.alpha1+
Build ID: 329496c1f75f97d2e6119ceb214a2ea1fbadb17a
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-10-03_02:47:24
Locale: es-ES (es_ES.UTF-8)

Version: 5.0.3.0.0+
Build ID: cf54f3a3e2afa313cadb7c83934c9d8a1470e287
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-5-0, Time: 2015-10-03_09:35:59
Locale: es-ES (es_ES.UTF-8)

Version: 4.4.7.0.0+
Build ID: 8387e93a7e57cd88e8e5691c6b603d927d5c51a3
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-4-4, Time: 2015-10-02_11:37:13
Locale: es_ES.UTF-8
Comment 10 tommy27 2016-05-29 04:44:06 UTC
@Carlos
has the situation changed with LibO 5.1.2.2 or 5.2 alpha?
Comment 11 QA Administrators 2017-12-13 09:30:10 UTC Comment hidden (obsolete)
Comment 12 Buovjaga 2019-01-01 18:32:51 UTC
(In reply to Carlos Rodriguez from comment #8)
> On KDE System Settings there is a value for "Paper size" on
> "Locale"->"Other" tab. The help menu says that this option is for creating
> new documents and not related to printer paper size. Changing this value
> makes no change on LibO about starting a new text document.

I am unable to find this setting in the current KDE Plasma. According to this thread https://forums.opensuse.org/showthread.php/532281-KDE-applications-always-print-A4-paper-size it should be in System settings>Regional settings>Formats, but it seems the setting has been removed.

However, if you check the last messages in the openSUSE thread, they point to this unresolved Qt bug: https://bugreports.qt.io/browse/QTBUG-71600
It might not be the cause for this LibreOffice issue, though.
Comment 13 Xisco Faulí 2019-06-13 15:44:48 UTC
Dear Dotan Cohen,
KDE4 support has been dropped in LibreOffice 6.3.
Could you please try to reproduce it with LibreOffice 6.3 Beta1 from https://wiki.documentfoundation.org/QA/GetInvolved#Test_Pre-releases ?
You can install it alongside the standard version.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'NEW' if the bug is still present in the master build
Comment 14 Timur 2019-09-19 13:24:47 UTC
I'm with OpenSuse Thumbleweed. As described in Comment 12. Workaround for older system Comment 7. Looking at Comment 13, I think it's safe to close.
Comment 15 Buovjaga 2019-09-19 19:40:10 UTC
(In reply to Buovjaga from comment #12)
> However, if you check the last messages in the openSUSE thread, they point
> to this unresolved Qt bug: https://bugreports.qt.io/browse/QTBUG-71600
> It might not be the cause for this LibreOffice issue, though.

The Qt bug got fixed in February 2019.