Bug 47789 - Functionality request for Impress: Add links to good templates (or separate installation file with collection of templates)
Summary: Functionality request for Impress: Add links to good templates (or separate i...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-23 20:21 UTC by Josh Leverette
Modified: 2017-01-19 15:22 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Showing off one of the many impressive themes. (257.86 KB, image/png)
2012-03-23 20:21 UTC, Josh Leverette
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Josh Leverette 2012-03-23 20:21:50 UTC
Created attachment 58953 [details]
Showing off one of the many impressive themes.

(please realize, the following is a satirical exaggeration to some extent, but just how close it is to the truth is the sad thing. There are maybe two decent themes included with Impress.)

Problem description: 
LibreOffice has only one issue that annoys me. The Impress component fails to impress me because of how it has no good templates/themes. When you open Microsoft Office or iWork, you expect to be able to quickly make a beautiful presentation. When you open LibreOffice, you expect to quickly make an average presentation.

Perhaps this is all just personal opinion, but LibreOffice's homepage is an excellent work of art -- so why has no one made Impress have impressive templates by default? It saddens me that I cannot recommend LibreOffice for presentations, because I know how potent that actual software is and wish to be able to do so. With all the talent involved with LibreOffice, I know there are people who could resolve this glaring issue. Please make an effort to do so. I am not skilled enough in this area to be making themes for the entire user base.


Steps to reproduce:
1. Open Impress
2. Attempt to make a beautiful presentation from default templates
3. There is no step three

Current behavior:
Results in user disappointment and general despair. Feelings of an impulsive desire to return to Microsoft Office have been reported.

Expected behavior:
Following these steps should result in the user having trouble picking how they want their presentation to look, since there is such a variety of excellent themes to choose from. The user is filled with a sense of a job well done from the moment they pick a theme.

Platform (if different from the browser):
              
Browser: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.11 (KHTML, like Gecko) Chrome/17.0.963.83 Safari/535.11
Comment 1 sasha.libreoffice 2012-06-18 04:35:26 UTC
Thanks for new idea
Indeed, in default installation is very few themes for presentations.
For example, I usually install additional themes downloaded some-when from OpenOffice and KOffice sites. Then becomes enough themes.
But not all people using LibreOffice for creating presentations. Placing themes inside of main installation file is not good idea. 
But placing links to themes for people can download them by few clicks may be very good thing. For example as menu item Help->Download themes. Or something so.
Also good thing would be to create separate installation file for themes (msi, rpm, deb, ...). For users can easily download and install. And maintainers can add to distros.
Comment 2 Samuel Mehrbrodt (CIB) 2017-01-19 15:22:09 UTC
We included some nice themes in the meantime; also the template selector will now be shown when you switch to impress.
So this is Worksforme.