Bug 47800 - Most of the predefined autotexts are missing in czech language
Summary: Most of the predefined autotexts are missing in czech language
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: Other All
: medium normal
Assignee: Michal Horák
URL:
Whiteboard: BSA target:4.3.0
Keywords: difficultyBeginner, easyHack
Depends on:
Blocks:
 
Reported: 2012-03-24 04:22 UTC by Ondrej Koncek
Modified: 2016-02-18 16:37 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
only screenshot showing that it is really not working (86.51 KB, image/jpeg)
2012-03-24 04:22 UTC, Ondrej Koncek
Details
Fixed autotext libraries in cs version (150.22 KB, image/jpeg)
2014-04-21 06:55 UTC, Michal Horák
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ondrej Koncek 2012-03-24 04:22:34 UTC
Created attachment 58965 [details]
only screenshot showing that it is really not working

Problem description: 
Shortcut fn+f3 for inserting formula is not working for me (on my home PC I use Ubuntu 11.10 in Czech language and LibreOffice 3.5.1.2 
Build:102 with Czech langpack).
On my working notebook (Ubuntu 11.10 in English and LibreOffice 3.5.1.2 
also in English) this shortcut is working correctly.


Steps to reproduce:
1. open eg. new document in LibreOffice Writer with Czech langpack
2. write "fn"
3. press f3 key
4. appears message:"Automaticky text pro zkratku 'fn' nebyl nalezen" which means in English: "Automatic text for shortcut 'fn' was not found"

Current behavior:
fn+f3 does not inserts formula

Expected behavior:
fn+f3 inserts formula

Platform (if different from the browser): 
      
Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:11.0) Gecko/20100101 Firefox/11.0
Comment 1 sasha.libreoffice 2012-06-18 05:20:44 UTC
@ Petr
Greetings
This bug looks like locale specific. Please, help to reproduce it.
Comment 2 Petr Mladek 2012-06-21 02:44:19 UTC
I am able to reproduce it. If you look into the autotext using "Edit/Autotext..." or by pressing [Ctrl-F3] you see four autotext libraries:

   crdbus50
   crdbus54
   standard
   template

but the are empty.

The related files are installed in /opt/libreoffice3.5/share/autotext/cs/*.bau
The *.bau files are zip archives. You could unzip them to see the content.

I compared the content with the working en/standard.bau. The main difference seems to be in META-INF/manifest.xml. It is almost empty in the "cs" version. It includes many entries in the "en" version.

So, the solution is to create correct manifest files in the cs/*.bau files.

Stefan, Michael, just by chance, do you know about any helper tool to create the .bau files? Or do we need to create the manifest files by hand?
Comment 3 Petr Mladek 2012-06-21 02:52:21 UTC
Anyway, this is very nice easy hack, so marking it this way.

The last .bau files can be found at http://cgit.freedesktop.org/libreoffice/core/tree/extras/source/autotext/lang/cs

The manual solution is to unzip them, update the META-INF/manifest.xml files and zip them again.

You could take inspiration in the .bau files for other localizations.

You could try the result if you copy them to the installed system, restart LO and try try to edit or use the autotext.
Comment 4 Julien Nabet 2012-08-15 18:27:36 UTC
Perhaps this commit helps http://cgit.freedesktop.org/libreoffice/core/commit/?id=109209c4f1db04eccf02d283f9d4ce039418603b ?
Ondrej: If interested, daily builds are here:http://dev-builds.libreoffice.org/daily/
Comment 5 Stanislav Horacek 2013-09-12 20:43:55 UTC
I can confirm that this issue still persists in 4.1.1 (Czech language, Ubuntu 13.04).
Comment 6 Björn Michaelsen 2013-10-04 18:47:27 UTC
adding LibreOffice developer list as CC to unresolved EasyHacks for better visibility.

see e.g. http://nabble.documentfoundation.org/minutes-of-ESC-call-td4076214.html for details
Comment 7 Jean-Baptiste Faure 2014-03-16 13:53:59 UTC
It does not work in French too because the shortcut is localized. In French it is nf+F3 (Numérotation de Formule). If I switch back to the English/USA UI, then the shortcut becomes fn+F3.

To found the correct shortcut: menu Edit > AutoText and search in the list "Standard" the equivalent of "Formula Numbering".

For me it is not a bug.

Best regards. JBF
Comment 8 Stanislav Horacek 2014-03-16 14:22:58 UTC
In Czech, there are no items in the AutoText dialog (only a few empty categories), so it is indeed a bug.
Comment 9 Jean-Baptiste Faure 2014-03-16 15:13:04 UTC
(In reply to comment #8)
> In Czech, there are no items in the AutoText dialog (only a few empty
> categories), so it is indeed a bug.

Ok, so it is not a shortcut problem. Modified summary accordingly.

Best regards. JBF
Comment 10 Michal Horák 2014-04-21 06:55:28 UTC
Created attachment 97663 [details]
Fixed autotext libraries in cs version
Comment 11 Michal Horák 2014-04-21 06:56:32 UTC
Comment on attachment 97663 [details]
Fixed autotext libraries in cs version

Sorry fo being late in fixing this bug..

I corrected manifest files in autotext cs libraries. Also I deleted some useless CVS dirs and MANIFEST.MF files according to the http://cgit.freedesktop.org/libreoffice/core/commit/?id=109209c4f1db04eccf02d283f9d4ce039418603b

Now, all the czech autotext working fine.

I create patch and push it to the gerrit for code review: https://gerrit.libreoffice.org/#/c/9109/
Comment 12 Commit Notification 2014-04-21 20:23:31 UTC
Michal Horak committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a62d76b0d1815b848b28f3d097fede1fa9be6365

fdo#47800 Fixing manifest files in cs autotext libraries



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Milos Sramek 2014-05-19 16:58:44 UTC
Hi,

the same siutuation is with Slovak Autotext. Could you, please, correct also that? 
Thank you 
Milos
Comment 14 Stanislav Horacek 2014-05-25 16:56:43 UTC
I confirm that Autotext works nicely for Czech language in 4.3 beta 1. Michal, thanks a lot for fixing!

I think this bug should be closed, or it should be changed to reflect that it persists in Slovak language only.
Comment 15 michalis 2014-07-12 13:23:55 UTC
I reopen the bug and change the title because the same problem exists also in Greek language and seems to affect other languages also. There is no autotext, is totally empty so I can't use the formula numbering fn F3. Moreover in my installation I have both Greek and English languages installed and it is not working (is empty) for English too. I checked the folder /share/autotext/ and all the language subdirs there are empty. Also I am missing the en-US/ subfolder, which suggests that the installation file is missing the /share/autotext/en-US/ folder. I have a clean install.

version 4.2.5.2 windows
Comment 16 David Tardon 2014-07-14 11:21:46 UTC
(In reply to comment #15)
> I checked the
> folder /share/autotext/ and all the language subdirs there are empty. Also I
> am missing the en-US/ subfolder, which suggests that the installation file
> is missing the /share/autotext/en-US/ folder.

Which means it is a different bug. Closing again.
Comment 17 michalis 2014-07-14 21:50:08 UTC
(In reply to comment #16)
> Which means it is a different bug. Closing again.

Still most of the languages lack the autotext features as seen also from comment 13. So I believe it should be reopened.
Another better solution could be, a basic thing like inserting a formula and having it numbered automatically (what fn+F3 does), to get build in with a language agnostic manner.
Comment 18 Petr Mladek 2014-07-15 07:39:14 UTC
I suggest to open a new bug and mention this one there if needed.

It will be much more motivating for developers to work on it. You know. One feels happy when some work is done and the related bug can be marked as fixed. On the other hand, it is a bit frustrating, when a bug is repeatedly reopened "only" because of some similar problems that are still there. Then it is like getting rid of a chewing gum from your clothes :-)
Comment 19 Tor Lillqvist 2014-07-15 07:41:53 UTC
(In reply to comment #18)
> Then it is like getting rid of a chewing gum from your clothes :-)

Well said, lol;)
Comment 20 Robinson Tryon (qubit) 2015-12-15 12:09:26 UTC
Migrating Whiteboard tags to Keywords: ( EasyHack DifficultyBeginner )
[NinjaEdit]
Comment 21 Robinson Tryon (qubit) 2016-02-18 16:37:25 UTC
Remove LibreOffice Dev List from CC on EasyHacks
(curtailing excessive email to list)
[NinjaEdit]