Bug 48053 - [easy hack] Do not allow saving into hidden or tmp directories
Summary: [easy hack] Do not allow saving into hidden or tmp directories
Status: RESOLVED DUPLICATE of bug 43895
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-29 09:58 UTC by Jean-François Fortin Tam
Modified: 2012-09-15 18:09 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-François Fortin Tam 2012-03-29 09:58:33 UTC
See also: https://bugzilla.gnome.org/show_bug.cgi?id=673097

In some cases, applications put files into hidden/temporary directories. For LibreOffice's target user demographic, it does not make any sense to allow saving in those directories.

When the current file is in a hidden directory or /tmp/ or whatever, when saving LibreOffice should not pass a default directory as an argument to the filechooser (therefore letting the filechooser do its job at offering the user with a better default), or at least use a better default folder (I think LibreOffice suggests the XDG "Documents" folder as a default?).
Comment 1 Andrzej Hunt 2012-09-15 18:09:22 UTC

*** This bug has been marked as a duplicate of bug 43895 ***