Bug Hunting Session
Bug 48099 - MediaWiki Export Fails to Login to a MediaWiki-powered site for MediaWiki export
Summary: MediaWiki Export Fails to Login to a MediaWiki-powered site for MediaWiki export
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: x86-64 (AMD64) All
: medium major
Assignee: Julien Nabet
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: MediaWiki
  Show dependency treegraph
 
Reported: 2012-03-30 09:39 UTC by Rob Shinn
Modified: 2017-08-18 20:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rob Shinn 2012-03-30 09:39:02 UTC
Wiki Publisher Version 1.1

Steps to reproduce:
1.  Either select Tools -> Options -> Internet -> MediaWiki or go through the Extension Manager
2.  Click "Add.."
3.  In the URL, put the Media URL.  In my case,my URL looked like 'http://www.example.com/wiki'.
4.  Fill out username and password.
5.  Note that Save Password box is still greyed out (that's another bug)
6.  Click Ok.

Expected results:
The dialog box should login to the wiki and allow me to save the username and pasword.

Actual results:  
Error received is "User name or password is incorrect.  Please try again, or leave the fields blank for an anonymous connection."

Other notes:
* MediaWiki version is 1.16.2
* I am using version 1.2d of the the LDAP Authentication Extension for   MediaWiki. http://www.mediawiki.org/wiki/Extension:LDAP_Authentication
Comment 1 Mats Dahlgren 2012-04-23 02:02:40 UTC
I can confirm that this problem still exists in the following:
LibreOffice 3.5.2.2 (build ID 281b639-6baa1d3-ef66a77-d866f25-f36d45f)
Windows7 64 bit English
Mediawiki 1.16 on OpenBSD 4.6
Wikipublisher 1.1.1


/mats dahlgren
Comment 2 lucazeo 2012-09-07 08:15:38 UTC
I confirm the same.
LibreOffice version: 3.6.1.2
Platform: Windows 7 64 bit English
Mediawiki 1.16 on windows
Comment 3 Rob Shinn 2013-03-13 20:51:11 UTC
I can confirm that this is still an issue in LibreOFfice Version 3.6.2.2 (Build ID: 360m1(Build:2)) on Linux Mint 14 (Ubuntu 12.10) and MediaWiki 1.16 on Red Hat Enterprise Linux 6.3
Comment 4 Julien Nabet 2014-02-20 21:52:20 UTC
Rob: I might be wrong but about the grey save password checkbox, you must first check the option "Persistently save password for web connections" in LO general/Security tab.

For the rest, could you give an update with a newer LO version? (Last one is 4.1.5 or 4.2.1)
Comment 5 Claus Kulis 2014-03-23 20:50:25 UTC
Julien,
I can confirm that the password checkbox becomes available once you checked the option "Persistently save password for web connections" in LO general/Security tab.

The other problem is still existing in LibreOffice Version 4.2.2.1 (Portable Version !) 
Platform is Win 7 64 bit

Remark: In fact the upload to MediaWiki worked for exactly 1 time - so I'm pretty sure that username and password are correct. After this first time I always received "User name or password is incorrect.  Please try again, or leave the fields blank for an anonymous connection."
Comment 6 Julien Nabet 2014-03-23 21:02:43 UTC
Thank you Claus for your feedback, I put it back to NEW since I don't have more questions.
Comment 7 Joel Madero 2015-05-02 15:42:34 UTC Comment hidden (obsolete)
Comment 8 Josh Kim 2015-09-11 03:42:13 UTC
The problem persists.
Comment 9 Julien Nabet 2015-09-11 05:07:19 UTC
Version field must be earlier version, not the most recent one.
Comment 10 QA Administrators 2016-09-20 10:29:56 UTC Comment hidden (obsolete)
Comment 11 Julien Nabet 2017-06-10 19:47:08 UTC
I'm quite sure it's the same as tdf#97743
I submitted a patch to gerrit.
I tested it successfully with wikipedia + https://wiki.documentfoundation.org.
Comment 12 Xisco Faulí 2017-06-12 12:02:53 UTC
Changing version back to the earliest affected version.
Comment 13 Julien Nabet 2017-06-24 19:22:14 UTC
For information, the patch for tdf#97743 is pushed on master branch and 5.4 branch.
I'm waiting for review for 5.3 branch, see https://gerrit.libreoffice.org/#/c/38646/
It could be interesting someone gives a try with a daily build, see http://dev-builds.libreoffice.org/daily/
Comment 14 Julien Nabet 2017-08-18 20:39:11 UTC
Let's put this one to FIXED.
Don't hesitate to reopen this tracker if it can be reproduced with 5.4 version or daily master build.