Bug Hunting Session
Bug 48528 - UI: Recent Documents list stays empty
Summary: UI: Recent Documents list stays empty
Status: RESOLVED DUPLICATE of bug 46074
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 48624 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-10 14:32 UTC by David King
Modified: 2018-02-26 11:14 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
The file asked in comment 9 (deleted)
2012-04-16 09:30 UTC, info.kalsan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David King 2012-04-10 14:32:34 UTC
After having worked on a few documents, when I later reopen Libre Office, there is nothing listed in Recent Documents. There used to be when I used version 3.5.0, but in 3.5.2 nothing is listed there at all now.
Comment 1 David King 2012-04-10 16:44:05 UTC
This also occurs in the Windows version. Previously tried in Ubuntu.
Comment 2 Rainer Bielefeld Retired 2012-04-12 22:57:24 UTC
*** Bug 48624 has been marked as a duplicate of this bug. ***
Comment 3 Stephan Bergmann 2012-04-12 23:58:12 UTC
David, does the problem go away if you temporarily move away LO's per-user configuration data (~/.config/libreoffice on Linux)?  Move it away, start soffice (it will create a new ~/config/libreoffice), open a few docs, close soffice and restart it and check if the docs are listed.
Comment 4 info.kalsan 2012-04-13 00:36:54 UTC
For me, that didn't work. Ubuntu 12.04, LibreOffice 3.5.2.2
Comment 5 Stephan Bergmann 2012-04-13 01:44:14 UTC
...which makes this bug look unrelated to bug 46074.
Comment 6 Rainer Bielefeld Retired 2012-04-15 22:29:08 UTC
NOT Reproducible with "LibreOffice 3.5.2.2 German UI/Locale [Build-ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45f] on German WIN7 Home Premium (64bit); but my update history is very untypical. 

For a WIN 7 64Bit PC and 3.5.2 with a PC named "Anni" and a user named "worker" I heard a suspect that there might be a problem for LibreOffice to decide whether it works for 
(1) C:\Users\worker.Anni\AppData\Roaming\LibreOffice\3\user oder
(2) C:\Users\worker\AppData\Roaming\LibreOffice\3\user

This user updated after uninstall of 3.4.x to 3.5.2

I can't tell whether this matches with the other problems here.

@David King, info.kalsan@valaiscom.ch:
Please contribute EXACT information concerning your OS, LibO version and update history.

@Stephan
Any suggestions what additional information might help to find out what's happening here?
Comment 7 Stephan Bergmann 2012-04-16 00:20:05 UTC
Just in case, it might be helpful to see the registrymodifications.xcu in the per-user configuration data (~/.config/libreoffice/3/user/registrymodifications.xcu) after the steps in comment 3 have been executed.
Comment 8 David King 2012-04-16 02:53:18 UTC
@Rainer Bielefeld
OS: Ubuntu Studio 10.10, 64-bit
LibO version: LibreOffice 3.5.2.2 
Build ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45f
previously 3.5.0, 3.4, 3.3

When I deleted user settings, opened LibreOffice, opened some docs, closed program, reopened, then the Recent Documents were remembered.

I restored my personal settings, and it was back to not listing any Recent Documents.

I deleted ~/.config/libreoffice/3/user/registrymodifications.xcu and then opened and closed docs, closed program, reopened, and Recent Documents were remembered again.

So it is a problem with ~/.config/libreoffice/3/user/registrymodifications.xcu
Comment 9 Stephan Bergmann 2012-04-16 03:04:22 UTC
@David King:  Your comment 8 now makes it look more like the problem you are experiencing is bug 46074 after all.  (Once your registrymodifications.xcu is "infected" as described in that bug, there is no easy fix short of removing at least registrymodifications.xcu from your existing per-user configuration data.)

@info.kalsan@valaiscom.ch:  As you claim that my recipe from comment 3 did not fix the problem for you, I would be interested in your registrymodifications.xcu as per comment 7.
Comment 10 info.kalsan 2012-04-16 09:30:22 UTC
Created attachment 60071 [details]
The file asked in comment 9
Comment 11 Stephan Bergmann 2012-04-16 13:06:59 UTC
@info.kalsan@valaiscom.ch, re your attached registrymodifications.xcu:

* From its length, it looks unlikely that it is only the result of strictly following the steps in comment 3.

* Do you have an old ~/.libreoffice (or even ~/openoffice.org) and does it contain any MIGRATED file (e.g., ~/.libreoffice/3/MIGRATED)?

* If I use that registrymodifications.xcu in a build of mine, the list of recently used documents ("File - Recent Documents") is *not* empty.  I cannot reproduce your claimed problem that it is empty.
Comment 12 info.kalsan 2012-04-18 07:41:28 UTC
*1: The file I uploaded is the result of these steps and about two weeks of normal use of LO.
*2: Yes, the old .libroffice/3 folder does contain a MIGRATED file. And there is a .openoffice.org folder as well.
*3: So this time, I can tell exactly what I did: delete .openoffice.org AND .libreoffice (no open LO window at that moment), start LO Writer, Ctrl+O, open document, close (Alt+F4), open another document over Nautilus. Open Recent is empty. Close Writer, Open Writer without opening a document, Open Recent is empty.
Comment 13 Stephan Bergmann 2012-04-18 09:22:38 UTC
(In reply to comment #12)
> *3: So this time, I can tell exactly what I did: delete .openoffice.org AND
> .libreoffice (no open LO window at that moment), start LO Writer, Ctrl+O, open
> document, close (Alt+F4), open another document over Nautilus. Open Recent is
> empty. Close Writer, Open Writer without opening a document, Open Recent is
> empty.

So you removed ~/.openoffice.org and ~/.libreoffice but still had a ~/.config/libreoffice?
Comment 14 Stephan Bergmann 2012-04-19 04:46:48 UTC
So comment 8 in this bug makes it look like the problem of David King is exactly the one discussed and fixed as bug 46074, and <https://bugs.freedesktop.org/show_bug.cgi?id=46074#c52> acknowledges that the problem of info.kalsan@valaiscom.ch described in comment 4 and following in this bug is also exactly the one discussed and fixed as bug 46074.

So I am closing this bug as a duplicate of bug 46074.

*** This bug has been marked as a duplicate of bug 46074 ***
Comment 15 David King 2012-04-21 15:28:47 UTC
I had kept my ~/.config/libreoffice/3/user/registrymodifications.xcu file, and then I decided to delete it again and get my recent documents list back. However, now the recent documents list does not come back at all.
Comment 16 Xisco Faulí 2018-02-26 11:14:31 UTC
The content of attachment 60071 [details] has been deleted