Download it now!
Bug 48673 - UI: No keyboard shortcut for "Ignore All" on misspelled word
Summary: UI: No keyboard shortcut for "Ignore All" on misspelled word
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: All All
: medium normal
Assignee: Jorendc
URL:
Whiteboard: BSA target:4.4.0
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-13 15:01 UTC by bevanfindlay
Modified: 2014-06-26 15:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshots with comments (38.93 KB, application/pdf)
2012-04-14 06:42 UTC, Rainer Bielefeld Retired
Details
screenshot 'fdo#48673_lo-3.6.0.4_en-UK.png' (25.09 KB, image/png)
2012-08-13 20:32 UTC, manj_k
Details
Screenshot of problem still occuring, 3.6.0.4. (8.17 KB, image/png)
2012-08-14 01:01 UTC, bevanfindlay
Details
Screenshot: fdo#48673_lo-3.6.0.4__ui_en-UK__text_en-UK_en-NZ.png (14.66 KB, image/png)
2012-08-14 08:39 UTC, manj_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bevanfindlay 2012-04-13 15:01:55 UTC
Problem description: No keyboard shortcut (underlined letter) for "Ignore" or "Ignore All" when right-clicking a misspelled word.

Steps to reproduce:
1. Type a misspelled word.
2. Right click (or hit the "context menu" button in Windows).
3. Should be able to hit "i" (or similar) for Ignore All, but have to either go use the mouse or manually arrow-key down through the menu.

Current behavior: No keyboard shortcut.

Expected behavior: Useful keyboard shortcut.

Platform (if different from the browser): Windows 7 SP1
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Comment 1 Rainer Bielefeld Retired 2012-04-14 03:14:49 UTC
NOT Reproducible with "LibreOffice 3.5.1.2 German UI/Locale [Build-ID: dc9775d-05ecbee-0851ad3-1586698-727bf66] on German WIN7 Home Premium (64bit) an native Spell Check (No LanguageTools istalled).

[Reproducible] with parallel  installation of  Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: e00e693]" (tinderbox: Win-x86@6-fast pull time 2012-04-13 22:07:42)

My suspect: this problem might be Localization related

@bevanfindlay@gmail.com
What UI language do you use?
Can you confirm that AutoCorrect also is missing?
Comment 2 Rainer Bielefeld Retired 2012-04-14 06:42:18 UTC
Created attachment 59971 [details]
Screenshots with comments
Comment 3 bevanfindlay 2012-04-14 16:02:41 UTC
Windows is running with en-NZ (English New Zealand), but I find I have to use en-UK (English UK) for the spellcheck etc as there is no NZ spellcheck dictionary.
Hope this helps.
Comment 4 manj_k 2012-08-13 20:31:26 UTC
WORKSFORME (on WinXP 32b) with
LibO 3.6.0.4 (Build ID: 932b512)
UI en-US
text language English (UK) / Englisch (New Zealand).

See attached screenshot 'fdo#48673_lo-3.6.0.4_en-UK.png'.

Feel free to reopen this bug if the problem still exists for you with a current stable LibreOffice version.
Comment 5 manj_k 2012-08-13 20:32:14 UTC
Created attachment 65515 [details]
screenshot 'fdo#48673_lo-3.6.0.4_en-UK.png'
Comment 6 bevanfindlay 2012-08-14 01:01:05 UTC
Created attachment 65523 [details]
Screenshot of problem still occuring, 3.6.0.4.

Issue is *not* resolved in 3.6.0.4 (Win 7 x64 SP1) - still happens.  See attached screenshot.  Used en-GB version of installer, en-UK interface.
Comment 7 manj_k 2012-08-14 08:39:07 UTC
Created attachment 65533 [details]
Screenshot: fdo#48673_lo-3.6.0.4__ui_en-UK__text_en-UK_en-NZ.png

Works for me (on WinXP 32b) with LibO 3.6.0.4 release
UI: en-UK
text language: English (UK) / Englisch (New Zealand).

See attached screenshot 'fdo#48673_lo-3.6.0.4__ui_en-UK__text_en-UK_en-NZ.png'.

Nevertheless, marked as REOPENED due to attachment 65523 [details].
Waiting for additional comments...
Comment 8 bevanfindlay 2012-08-14 09:34:25 UTC
(In reply to comment #7)
> Created attachment 65533 [details]
> Screenshot: fdo#48673_lo-3.6.0.4__ui_en-UK__text_en-UK_en-NZ.png
> 
> Works for me (on WinXP 32b) with LibO 3.6.0.4 release
> UI: en-UK
> text language: English (UK) / Englisch (New Zealand).
> 
> See attached screenshot 'fdo#48673_lo-3.6.0.4__ui_en-UK__text_en-UK_en-NZ.png'.
> 
> Nevertheless, marked as REOPENED due to attachment 65523 [details].
> Waiting for additional comments...

Is definitely still a problem with 3.6.0.4 release on Win 7 (x64, SP1) with the "GB English" installer, though I did run into a separate bug where the spellcheck didn't work *at all* until I deleted the "extensions" folder from my user profile (as per instructions in the release notes), so maybe need to wait until that issue is resolved?

Hope this helps.
Comment 9 Rainer Bielefeld Retired 2012-08-14 11:39:00 UTC
Reported problem Still [Reproducible] with Server Installation of  "LibreOffice 3.6.0.4 English (US+UK) UI/ German Locale [Build-ID:  932b512] on German WIN7 Home Premium (64bit). Theme and user profile does not matter

@bevanfindlay@gmail.com
<http://wiki.documentfoundation.org/BugReport_Details#Version>

@manj_k
Any idea what we still can test?
I wonder why I see the old bluegray menu background on your screenshot, 3.6 normally has "greygrey"?
Comment 10 manj_k 2012-08-14 12:05:45 UTC
@ Rainer Bielefeld:
(In reply to comment #9)
> 
> @manj_k
> Any idea what we still can test?

At the moment, I have no further ideas.
But I've seen (about twice) the missing keyboard shortcuts in previous versions (in relation with large suggestion lists).

> I wonder why I see the old bluegray menu background on your screenshot, 3.6
> normally has "greygrey"?

These are settings on OS level. :)
Comment 11 Commit Notification 2014-06-26 15:45:36 UTC
Joren De Cuyper committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=224d51af5aa9faa33a57f1325431cd12a7952a62

fdo#48673 - UI: No keyboard shortcut for "Ignore All" on misspelled word



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.