Download it now!
Bug 48735 - FILESAVE save as pptx discard crop information
Summary: FILESAVE save as pptx discard crop information
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.1.0 target:7.0.0
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-15 09:30 UTC by Korrawit Pruegsanusak
Modified: 2020-04-12 21:28 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
screenshot in powerpoint 2007, it *should not* have red border (10.30 KB, image/png)
2012-04-15 09:33 UTC, Korrawit Pruegsanusak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Korrawit Pruegsanusak 2012-04-15 09:30:32 UTC
This is a spin-off from bug 33361 comment 3, credit to sasha.libreoffice

When save file to .pptx format, libreoffice doesn't save crop information.

Steps:
1. Open attachment 43916 [details]
2. File > Save As > select format as "Open Office XML Presentation (.pptx)"
3. Save, Close File, Open again in both LibreOffice and PowerPoint

Expected: NO red border around green square
Actual: have red border, see screenshot

In step 2, also [REPRODUCIBLE] with format "Microsoft PowerPoint 2007/2010 XML (.pptx)", but [NOT REPRODUCIBLE] with format "Microsoft PowerPoint 97/2000/XP/2003 (.ppt)"

[REPRODUCIBLE] on Windows XP
* 3.3.4 final
* 3.5.2 final
* daily build from @6-fast tinderbox 2012-04-09 Build ID: e194f5b-6299bf6-ec8645

CANNOT REPRODUCIBLE in 3.3.0 Beta 1 because it can't export to .pptx, but exporting to .ppt works fine as expected.
Comment 1 Korrawit Pruegsanusak 2012-04-15 09:33:52 UTC
Created attachment 60019 [details]
screenshot in powerpoint 2007, it *should not* have red border

NEW due to bug 33361 comment 3
Comment 2 Commit Notification 2013-03-06 08:30:15 UTC
Pallavi Jadhav committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5d10a0180f5e9922ca197cdea00ee84bc4b2d313

fdo#48735: Save crop information in PPTX.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Antonio Martins 2013-11-29 16:20:58 UTC
In LO 4.1.3.2 if you use attachment #43916 [details] and simply save the file to .pptx format, when you later open it, the problem seems to be fixed (correctly crops the image).
However, if you take Attachment #60019 [details] and insert the png file in a new Impress file, save the file as .pptx format and then open it again, the crop information is lost.

This means that the attachment #43916 [details] has something that has been fixed for that particular situation, but if you perform he whole operation from the png file, then the problem persists.

I have seen this occur in Linux and i imagine this problem shows in any architecture.
Comment 4 QA Administrators 2015-04-19 03:19:51 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 5 Buovjaga 2015-06-15 07:15:02 UTC
(In reply to Antonio Martins from comment #3)
> In LO 4.1.3.2 if you use attachment #43916 [details] and simply save the
> file to .pptx format, when you later open it, the problem seems to be fixed
> (correctly crops the image).
> However, if you take Attachment #60019 [details] and insert the png file in
> a new Impress file, save the file as .pptx format and then open it again,
> the crop information is lost.
> 
> This means that the attachment #43916 [details] has something that has been
> fixed for that particular situation, but if you perform he whole operation
> from the png file, then the problem persists.
> 
> I have seen this occur in Linux and i imagine this problem shows in any
> architecture.

Inserted Attachment 60019 [details] into new Impress file.
Cropped it so that the green square was visible.
Saved as .pptx and reloaded.
Crop info is ok.

I will set this to FIXED.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 01a189abcd9a4ca472a74b3b2c000c9338fc2c91
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-14_07:46:28
Locale: fi-FI (fi_FI)
Comment 6 Commit Notification 2020-04-12 21:28:39 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/04f5e991178cdc459d34b6d6406603f180334425

tdf#48735: Add unittest

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.