Download it now!
Bug 48846 - FORMATTING Writer: Formula resizing not working
Summary: FORMATTING Writer: Formula resizing not working
Status: RESOLVED DUPLICATE of bug 85860
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium enhancement
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.2.0
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-17 15:12 UTC by svend
Modified: 2019-10-03 13:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description svend 2012-04-17 15:12:07 UTC
Impossible to change the size of the formula in wrtier.

In draw, the size is protected (size is checked in position and size). 

When unchecked, size is automatically checked again.
Comment 1 Jean-Baptiste Faure 2012-04-20 03:32:59 UTC
What do you mean by "change the size of the formula" ? Please provide a step by step scenario to reproduce the problem.
Good thing to read before reporting a suspected bug : http://wiki.documentfoundation.org/BugReport#Reporting_a_bug_in_few_Steps

Best regards. JBF
Comment 2 svend 2012-04-20 05:39:33 UTC
Did you try to resize a formula in writer ? Type a formula, enter and then try to grab one size to resize : not possible. 

In draw : Right clicking and uncheck size under protection in "Position and Size" does not do anything, it's checked again and again
Comment 3 Jean-Baptiste Faure 2012-04-20 06:16:43 UTC
A formula is not an image. The size of the formula is defined by the size of the used fonts : menu Format -> Font size.

Best regards. JBF
Comment 4 Regina Henschel 2012-09-02 18:20:10 UTC
In Draw/Impress you have to set the new size immediately after removing the check by entering new size values in the dialog. Don't forget to check "keep ratio". Such formula resizing is possible in Calc too.

Resizing is possible for other OLE-objects and I see no reason, why it should not be possible for Math-OLE. It is an artificial restriction that resizing is not possible in writer.
Comment 5 Commit Notification 2013-10-07 15:21:04 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1b717e5686f34c3ce798310a6216f7ea98fb2cd9

Resolves: rhbz#1012353 fdo#48846 allow starmath objects to be resized



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 V Stuart Foote 2014-11-04 13:15:14 UTC
apparently causes regression of unintended resizing of OLE object when adjusting borders (e.g. Math and Charts) in bug 75408
Comment 7 Caolán McNamara 2014-11-26 15:50:37 UTC

*** This bug has been marked as a duplicate of bug 85860 ***