Bug 48916 - FORMATTING: The clipping of EMF files are ignored.
Summary: FORMATTING: The clipping of EMF files are ignored.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: Other All
: medium normal
Assignee: Bartosz
URL:
Whiteboard: target:7.2.0 target:7.1.3
Keywords:
Depends on:
Blocks: EMF-WMF
  Show dependency treegraph
 
Reported: 2012-04-19 02:21 UTC by Horcrux7
Modified: 2021-04-07 09:38 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
ODS file with EMF file (3.52 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-04-19 02:21 UTC, Horcrux7
Details
emf file result with LibreOffice3.5.2 (10.52 KB, image/jpeg)
2012-04-19 02:27 UTC, Horcrux7
Details
expected result, MS Office 2010 show the ODS file correctly (8.24 KB, image/jpeg)
2012-04-19 02:34 UTC, Horcrux7
Details
EDF Image extracted from ODS (1.18 KB, image/x-emf)
2017-03-31 15:01 UTC, Bartosz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Horcrux7 2012-04-19 02:21:31 UTC
Created attachment 60301 [details]
ODS file with EMF file

An EMF file with clipping will be formated/painted wrong.
Comment 1 Horcrux7 2012-04-19 02:27:15 UTC
Created attachment 60302 [details]
emf file result with LibreOffice3.5.2
Comment 2 Horcrux7 2012-04-19 02:34:04 UTC
Created attachment 60303 [details]
expected result, MS Office 2010 show the ODS file correctly
Comment 3 A (Andy) 2015-02-12 20:29:45 UTC
Reproducible with LO 4.4.0.3, Win 8.1,

Note: The image is only shown after a double left mouse click on it.
Comment 4 QA Administrators 2016-02-21 08:36:59 UTC Comment hidden (obsolete)
Comment 5 Horcrux7 2016-02-21 09:41:06 UTC
No change in behavior in version 5.1.0.3 on Windows 10.
Comment 6 Bartosz 2017-03-31 15:01:54 UTC
Created attachment 132298 [details]
EDF Image extracted from ODS
Comment 7 QA Administrators 2018-06-10 02:45:39 UTC Comment hidden (obsolete)
Comment 8 Chris Sherlock 2019-11-19 10:13:14 UTC
I can confirm that the issue is still occurring. I just tested this on master, and the rectangle is not rotated.
Comment 9 Commit Notification 2021-04-03 13:32:04 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/aa17ea3d36b8f1ea8cd3d2fb215e80051547439d

tdf#37281 tdf#45820 tdf#48916 tdf#55058 EMF Implement complex clipping

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2021-04-06 12:05:45 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/8deb9b3d2f8781628db73d3b2a3c7939ea4fcc2d

tdf#37281 tdf#45820 tdf#48916 tdf#55058 EMF Implement complex clipping

It will be available in 7.1.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.