Bug Hunting Session
Bug 48918 - FORMATTING: grow / shrink custom animation effect still missing
Summary: FORMATTING: grow / shrink custom animation effect still missing
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA target:5.5.0
Keywords:
: 67531 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-19 03:25 UTC by koppieskrap
Modified: 2017-06-10 19:05 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Grow and Shrink Effect UI is missing (30.69 KB, application/vnd.oasis.opendocument.presentation)
2014-02-04 19:34 UTC, Luke
Details
PowerPoint grow and shrink animations on a shape (38.96 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2017-02-12 20:58 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description koppieskrap 2012-04-19 03:25:15 UTC
Problem description: 
The custom animation effect to grow or shrink images is STILL missing in the drop-down menu (goes back to 2006)

Steps to reproduce:
Cannot be reproduced since the menu entry is missing.

Current behavior:
No behaviour - which IS the bug

Expected behavior:
Customizable animation to resize image in a presentation

Platform (if different from the browser): ALL
Comment 1 Stefan Knorr (astron) 2012-11-22 18:55:31 UTC
Can you please link to the original Openoffice bug report?

Otherwise, it is pretty hard to guess exactly what you want and if anyone has already worked on this feature.

(Openoffice's bugzilla now resides at: https://issues.apache.org/ooo/ )
Comment 2 Stefan Knorr (astron) 2013-04-07 11:05:05 UTC
Resolving as invalid – we have no way to reach out to the person opening this (trash-mail.com deletes all mail received after a few hours and does not have user accounts).
If you know what this is about, please reopen with a bug number from Openoffice.
Comment 3 rainyday26 2013-12-07 05:48:07 UTC
Reopening this bug as I am running into the same issue as the original reporter.

**Bug Description**

In LibreOffice Impress, there should be a custom animation under the Emphasis category for Grow/Shrink.

Others have confirmed that this feature does exist in Impress. If you import a PowerPoint project that uses this feature, it works correctly in Impress (see OpenOffice Forum and Launchpad links below).

**Related Background Information**

It was "reported" and confirmed back in 2006. I say "reported" because searching various bug trackers and discussion leads me to this OpenOffice discussion being the first (and only) reported incident back in 2006: http://www.oooforum.org/forum/viewtopic.phtml?t=33998

The first real bug report was in Launchpad in 2010 on the Ubuntu bug tracker for both OpenOffice and LibreOffice Impress as it effects both projects: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/651511

This bug report references that discussion and I believe whoever reported this bug also is referencing that forum discussion (but without providing a link).

No fix was ever implemented by Ubuntu because it was deemed something that it should be fixed upstream. Also, since no new packages from OpenOffice/LibreOffice were going into the reported version of Ubuntu, the bug was closed as Won't Fix.

Searching on the OpenOffice bug tracker, the closest thing I found was this report about Grow/Shrink in the Draw application: https://issues.apache.org/ooo/show_bug.cgi?id=82717 There does not appear to be any report of this bug in the OpenOffice tracker for Impress.

Searching on the LibreOffice bug tracker obviously led me to this being the only reported incident of the bug.

**Updated Information / Confirmation**

I've tested that this option is missing on both:

* Windows 7 x86_64 - LibreOffice Impress version 4.1.3.2
* ArchLinux x86_64 - LibreOffice Impress version 4.1.3.2

If needed, I can test this on other platforms as well but the bug seems straightforward. If needed, I can get a PowerPoint file with the animation to test in Impress when I go to work on Monday.
Comment 4 Luke 2014-02-04 19:34:45 UTC
Created attachment 93409 [details]
Grow and Shrink Effect UI is missing

Attached is a file that shows the logic for the Grow and Shrink Effect is in LO, but the UI is missing. It should be found here:

Slide Show -> Custom Animation -> Add -> Emphasis
Comment 5 Owen Genat (retired) 2014-04-17 11:44:02 UTC
(In reply to comment #3)
> Searching on the OpenOffice bug tracker, the closest thing I found was this
> report about Grow/Shrink in the Draw application:
> https://issues.apache.org/ooo/show_bug.cgi?id=82717 There does not appear to
> be any report of this bug in the OpenOffice tracker for Impress.

It appears a new bug has now been added to the Apache OO bugzilla:

https://issues.apache.org/ooo/show_bug.cgi?id=124184

Link added to the See Also list.
Comment 6 Paul-Antoine Arras 2016-02-09 14:50:45 UTC
The UI in LO 4.3.7.2 is still missing the feature.
I second this RFE since it is needed for high-quality, professional presentations and there currently exists no workaround.
Comment 7 Luke 2016-02-10 05:06:28 UTC
Emmanuel,
Could you offer any tips on this? Could it be an easy hack?
Comment 8 Regina Henschel 2017-02-12 20:58:50 UTC
Created attachment 131155 [details]
PowerPoint grow and shrink animations on a shape

If you import a pptx, which has this animation, you get a UI for it. But you cannot get this animation in a native LO presentation.

The animation itself has some bugs. The scaling factor is not imported from *.pptx and it is not possible in that UI to set a "shrinking" factor. You can click on "smaller" and "tiny" but you get a growing.

Therefore I think, the UI should only be enabled, if these bugs are fixed too.
Comment 9 Regina Henschel 2017-02-12 21:04:32 UTC
The import from pptx problem is in bug 98477.
Comment 10 Commit Notification 2017-05-27 17:08:20 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7d70516bb1aef8c234788c1cc515d78ac2df7a0c

Resolves: tdf#48918 grow/shrink effect missing from ui

It will be available in 5.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Buovjaga 2017-06-02 16:40:33 UTC
Thanks, Caolán.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.5.0.0.alpha0+
Build ID: c855400e9686ddd8bcba5691393f839f6f52c966
CPU threads: 8; OS: Linux 4.11; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on June 2nd 2017
Comment 12 Buovjaga 2017-06-02 16:42:09 UTC
*** Bug 67531 has been marked as a duplicate of this bug. ***
Comment 13 Iceflower S 2017-06-10 18:53:18 UTC
It seems that shrinking is not working. Daily Build 10.06. (5.5.0). It grows only. 


Offtopic:
Auto preview, has a bad behavior. Type one size number and it tabs out and start auto preview. Cant type more than one number... Maybe should wait for enter.
Comment 14 Buovjaga 2017-06-10 19:02:41 UTC
(In reply to Iceflower S from comment #13)
> It seems that shrinking is not working. Daily Build 10.06. (5.5.0). It grows
> only. 
> 
> 
> Offtopic:
> Auto preview, has a bad behavior. Type one size number and it tabs out and
> start auto preview. Cant type more than one number... Maybe should wait for
> enter.

That's not the topic of this report, though.

Please open a new report for the shrinking problem and add me to CC. I confirm it.
Comment 15 Buovjaga 2017-06-10 19:03:01 UTC
Iceflower: see previous comment.
Comment 16 Iceflower S 2017-06-10 19:05:21 UTC
(In reply to Buovjaga from comment #14)
> (In reply to Iceflower S from comment #13)
> > It seems that shrinking is not working. Daily Build 10.06. (5.5.0). It grows
> > only. 
> > 
> > 
> > Offtopic:
> > Auto preview, has a bad behavior. Type one size number and it tabs out and
> > start auto preview. Cant type more than one number... Maybe should wait for
> > enter.
> 
> That's not the topic of this report, though.
> 
> Please open a new report for the shrinking problem and add me to CC. I
> confirm it.

I answered because comment 10: "Affected users are encouraged to test the fix and report feedback."

I will open a new issue.