Bug 49028 - FILEOPEN: Spreadsheet Opens, Sheets are There, but Data Not Displayed (works in Excel)
Summary: FILEOPEN: Spreadsheet Opens, Sheets are There, but Data Not Displayed (works ...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-20 14:29 UTC by Eric Olsen
Modified: 2013-12-04 21:30 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test Spreadsheet (3.86 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2012-04-20 14:29 UTC, Eric Olsen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Olsen 2012-04-20 14:29:52 UTC
Created attachment 60408 [details]
Test Spreadsheet

Problem description: Spreadsheet opens, but no data is displayed.  If you open in MS Excel 2010, the spreadsheet opens and all data is displayed; if you save from Excel, then LibreOffice is able to open and display data.

Steps to reproduce:
1. Open spreadsheet attached to this bug.


Current behavior: Data not displayed.

Expected behavior:  See data.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Comment 1 Rainer Bielefeld Retired 2012-04-21 04:07:02 UTC
Effect is Reproducible with "LibreOffice 3.5.3.1 German UI/Locale [Build-ID: 21cb047-d7e6025-9ba54fc-b4a51a8-f42372b] on German WIN7 Home Premium (64bit). Same effect sith OOo 3.4 Beta. 

Might be invalid / damaged document? My old GNUMERIC complains errors like "services: invalid cell [C-1]0"

@Eric Olsen:
How has that document been created?
Comment 2 Eric Olsen 2012-04-21 04:32:21 UTC
Document created with xlsx4j (http://www.docx4java.org/trac/docx4j).
Comment 3 Eric Olsen 2012-04-24 09:14:58 UTC
Got the programmers to add "R" values to both <row> and <c> elements -- this allowed LibreOffice Calc to open spreadsheet.

Still, Excel is able to open without "R" values listed.  (Not sure if you care, but it is a difference in the ability of Excel and LibreOffice Calc to handle generated spreadsheets).

Looks like it is something that xlsx4j people are aware of:

  http://www.docx4java.org/forums/xlsx-java-f15/openoffice-xlsx-files-t988.html
Comment 4 Rainer Bielefeld Retired 2013-03-19 09:48:21 UTC
So I close this one for now.

@Eric Olsen:
Please feel free to reopen this bug if you find out that the problem still exists with the current stable LibreOffice version and with sample Documentvalid ODF 1.2 due to <http://odf-validator2.rhcloud.com/odf-validator2/>