Download it now!
Bug 49100 - PDF: SMP1 characters do not show properly in PDF exported document
Summary: PDF: SMP1 characters do not show properly in PDF exported document
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.5 release
Hardware: x86 (IA32) Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: filter:pdf
: 77136 (view as bug list)
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2012-04-24 01:57 UTC by mjb0
Modified: 2019-11-03 15:09 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
A comparison of two PDF files: produced by LO PDF export (left) and PrimoPDF (right) from the same ODT document (181.96 KB, image/jpeg)
2012-04-24 01:57 UTC, mjb0
Details
Test file (9.86 KB, application/vnd.oasis.opendocument.text)
2012-04-24 10:24 UTC, mjb0
Details
Result of the test file with LO PDF Export feature (35.52 KB, application/pdf)
2012-04-24 10:25 UTC, mjb0
Details
Expected result (printed with PrimoPDF) (48.86 KB, application/pdf)
2012-04-24 10:26 UTC, mjb0
Details
archive with PDF files from bugdoc (254.29 KB, application/x-zip-compressed)
2012-04-25 12:59 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mjb0 2012-04-24 01:57:39 UTC
Created attachment 60514 [details]
A comparison of two PDF files: produced by LO PDF export (left) and PrimoPDF (right) from the same ODT document

Problem description: 

Supplementary Multilingual Plane 1 characters are needed in my document to render cuneiform glyphs. No problem to embed them in the ODT file using the appropriate fonts (Aegean, Assurbanipal...) and the Insert special character feature. When I export the file to PDF, however, the PDF file shows said characters improperly, though the fonts appear to be embedded in the PDF document.

Steps to reproduce:
1. Open a new LO Writer document
2. Insert some characters above 0x10000
3. Export to PDF
4. Read the PDF file with Acrobat Reader or equivalent

Current behavior:

The SMP1 characters from Aegean font appear as two boxed question marks. Characters from Assurbanipal font appear as blanks. Nota: The problem dates back from at least OO 2.4. It is still present in LO 3.5.

Expected behavior:

The SMP1 characters appear as they should...

Platform (if different from the browser): Windows XP
              
Browser: irrelevant

PDF Reader: Acrobat, Foxit
Comment 1 Jean-Baptiste Faure 2012-04-24 04:42:29 UTC
Please, attach the original odt file to allow QA team to confirm the bug and developers to test solutions.

Best regards. JBF
Comment 2 mjb0 2012-04-24 10:24:25 UTC
Created attachment 60538 [details]
Test file

A simple file with three lines of different fonts' SMP1 characters. In order to avoid any difficulty to retreive Aegean or Assurbanipal, I included a line with a DejaVu font.
Comment 3 mjb0 2012-04-24 10:25:26 UTC
Created attachment 60539 [details]
Result of the test file with LO PDF Export feature
Comment 4 mjb0 2012-04-24 10:26:49 UTC
Created attachment 60540 [details]
Expected result (printed with PrimoPDF)
Comment 5 mjb0 2012-04-24 10:41:04 UTC
Looking at the properties of the two PDF result files, I notice that the one produced by LO displays an empty attribute "encoding" for the embedded fonts, whereas the one produced by PrimoPDF has "ANSI" there. Maybe a clue why it does not work?
Comment 6 Jean-Baptiste Faure 2012-04-25 12:59:00 UTC
Created attachment 60589 [details]
archive with PDF files from bugdoc

Well, I do not reproduce under Ubuntu 11.10 x86_64 with LO 3.4.5 (ubuntu version), LO 3.4.6, LO 3.5.2, LO 3.5.3rc1 and LO 3.5.4 rc0+.
What I did:
1/ installed Assurbanipal font from http://www.hethport.uni-wuerzburg.de/cuneifont/ in ~/.fonts
2/ installed aegean font from http://users.teilar.gr/~g1951d/ in ~/.fonts
3/ restart LO and open bugdoc => looks fine
4/ export in pdf format
5/ did 3/ and 4/ for each version of LO
Attached is an archive with all pdf files. Please verify if they are correct as I think they are.

Best regards. JBF
Comment 7 mjb0 2012-04-26 01:53:14 UTC
(In reply to comment #6)
> Created attachment 60589 [details]

Thank you for this detailed trial. So it seems everything works fine under Ubuntu and the problem is related to the Windows XP LO version only?

I suppose I checked all possible export options and did not see any influence on the result. I reproduced the problem with various versions of LO and OO (including 3.5.0rc3, native or embedded in Liberkey and Portable Apps), and I tested it on two Win XP platforms, properly configured to display SMP1 characters under LO. 

Is it possible to find out which registry keys are necessary for the Window XP version of LO to export SMP1?


> archive with PDF files from bugdoc
> 
> Well, I do not reproduce under Ubuntu 11.10 x86_64 with LO 3.4.5 (ubuntu
> version), LO 3.4.6, LO 3.5.2, LO 3.5.3rc1 and LO 3.5.4 rc0+.
> What I did:
> 1/ installed Assurbanipal font from
> http://www.hethport.uni-wuerzburg.de/cuneifont/ in ~/.fonts
> 2/ installed aegean font from http://users.teilar.gr/~g1951d/ in ~/.fonts
> 3/ restart LO and open bugdoc => looks fine
> 4/ export in pdf format
> 5/ did 3/ and 4/ for each version of LO
> Attached is an archive with all pdf files. Please verify if they are correct as
> I think they are.
> 
> Best regards. JBF
Comment 8 mjb0 2012-04-26 05:40:12 UTC
FYI: I just had an occasion to test the test file on Windows 7 with LO 3.4.5 (embedded in Liberkey) and the bug is present too.
Comment 9 pierre-yves samyn 2012-04-27 01:45:38 UTC
Hello

I reproduce the bug with Windows 7 64-bit and LibreOffice 3.5.3.2
Version ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b80

I followed the steps given by JBF (comment #6)

note: the document generated by File> Print> PDFCreator is OK

Regards
Pierre-Yves
Comment 10 mjb0 2012-04-28 10:23:24 UTC
Thank you Pierre-Yves for reproducing it. I don't know if I am allowed to do that, but I upgraded the status to NEW (UNCONFIRMED seemed a bit too shy to me). I suppose this is a necessary step if I want it to be proposed to developpers.
Comment 11 Jean-Baptiste Faure 2012-04-28 10:37:14 UTC
(In reply to comment #10)
> Thank you Pierre-Yves for reproducing it. I don't know if I am allowed to do
> that, but I upgraded the status to NEW.

No problem, you are right since the bug has been confirmed on MS-Windows :-)

Best regards. JBF
Comment 12 Andras Timar 2014-04-27 19:17:13 UTC
*** Bug 77136 has been marked as a duplicate of this bug. ***
Comment 13 QA Administrators 2015-06-08 14:41:53 UTC Comment hidden (obsolete)
Comment 14 QA Administrators 2016-09-20 10:00:53 UTC Comment hidden (obsolete)
Comment 15 eisa01 2019-11-03 15:09:27 UTC
This exports fine, for all three fonts

Version: 6.3.3.2 (x64)
Build ID: a64200df03143b798afd1ec74a12ab50359878ed
CPU threads: 2; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded