Download it now!
Bug 49614 - Cannot resize inserted formula in Impress via mouse
Summary: Cannot resize inserted formula in Impress via mouse
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: All Linux (All)
: lowest trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-07 23:37 UTC by Fredrik
Modified: 2018-06-03 19:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fredrik 2012-05-07 23:37:16 UTC
1) lsb_release -rd
Description: Ubuntu 12.04 LTS
Release: 12.04

2) apt-cache policy libreoffice-impress
libreoffice-impress:
  Installed: 1:3.5.2-2ubuntu1
  Candidate: 1:3.5.2-2ubuntu1
  Version table:
 *** 1:3.5.2-2ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen in a blank Impress file is if one adds a formula via Insert -> Object -> Formula, one may resize the formula window.

4) What happens instead is the formula is not resizable via clicking and dragging the edges of the formula.

WORKAROUND: Secondary click the formula -> Position and Size... -> under Protect uncheck checkbox Size -> under Size choose the desired Width and Height.
Comment 1 A (Andy) 2013-04-25 19:57:24 UTC
reproducible with LO 4.0.2.2 (Win7 Home, 64bit)
Comment 2 QA Administrators 2015-03-04 02:23:55 UTC Comment hidden (obsolete)
Comment 3 Jean-Baptiste Faure 2015-03-09 06:25:09 UTC
It is not a bug it is by design because a formula is not an image. You can set the size of the formula by modifying it (use the keyword size).

Closing as NOTABUG.

Best regards. JBF
Comment 4 Matthew Slyman 2017-04-30 15:26:20 UTC
This problem, or its close relatives, have existed in OpenOffice.org / LibreOffice ever since the very first version!
https://bz.apache.org/ooo/show_bug.cgi?id=5266
Can we get it sorted out please?
My comment from OOO bug tracker…

I have a degree in computer science, and I just spent about 1 hour converting a formula into SVG graphic format.
This required approximately the following procedure:
* Open LibreOffice Math
* Write formula
* Could not find a way to "export to Draw", "export to SVG", etc.
* Open LibreOffice Draw
* Menu: Insert/ Object/ Formula
* Manually edit the formula (paste in formula code)
* Format/ Font size/ make the text incredibly tiny with 5 point text, so that the entire formula would be shown inside the tiny, rigid, NON-RESIZEABLE box thata Insert/Object had placed it inside (the formula was internally overflowing, and being clipped) — of course this NON-RESIZEABLE box was NOT automatically resizing itself to the formula contained inside it…
* Context menu: Convert to profile (initially attempted convert to curve, but this resulted in resizing & clipping so had to try another option)
* Manually resize resulting formula-profile to width of page.
* Manually resize page to vertical size of object
* Export as SVG

I'm running LO 5.2.3.3 x64 — it baffles me how anyone thinks this procedure is acceptable in 2017. Perhaps with Windows 3.1 in 1992, I would have thought this about normal, but these days, this is well below my expectations for how software should work! Anyone who thinks that being inside this strait-jacket is a "feature" is frankly an idiot. Sorry for the undiplomatic language!
Comment 5 Jean-Baptiste Faure 2017-04-30 16:12:32 UTC
(In reply to Matthew Slyman from comment #4)
> This problem, or its close relatives, have existed in OpenOffice.org /
> LibreOffice ever since the very first version!

This bug tracker is not an helpdesk. For help on Math module you can ask on users mailing list or on https://ask.libreoffice.org/en/questions/
In comment #3 it is indicated that the size of a formula can be modified by using the keyword size in the formula code.

Please don't reopen a old bug report closed as Not_A_Bug. If you think that this functionality should be implemented, please open a new enhancement request.

If you think that the procedure you described in comment #4, that is different than resizing a formula using the mouse, don't work as expected, please open a distinct bug report.

Closing again.

Best regards. JBF
Comment 6 Buovjaga 2018-06-03 19:23:39 UTC
*** Bug 117361 has been marked as a duplicate of this bug. ***