Bug Hunting Session
Bug 49948 - FILEOPEN: No recent documents
Summary: FILEOPEN: No recent documents
Status: RESOLVED DUPLICATE of bug 46074
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-15 03:26 UTC by Yorick Bosman
Modified: 2018-02-26 11:14 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
An image showing the recent document list.. wich is empty while it should be full. (26.78 KB, image/png)
2012-05-15 03:26 UTC, Yorick Bosman
Details
registerymodifications.xcu which was asked to attach (deleted)
2012-05-15 05:31 UTC, Yorick Bosman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yorick Bosman 2012-05-15 03:26:59 UTC
Created attachment 61674 [details]
An image showing the recent document list.. wich is empty while it should be full.

Problem description:
I don't have a list of recent documents...

Steps to reproduce:
1. open a document
2. save document
3. try to open document through "recent documents"

Platform (if different from the browser): 
Windows 7 Ultimate 32Bit
Browser: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.168 Safari/535.19
Comment 1 Stephan Bergmann 2012-05-15 05:23:00 UTC
Hm, this sounds like bug 46074, only that <https://bugs.freedesktop.org/show_bug.cgi?id=46074#c59> means it should automatically work again in LO 3.5.3.

Yorick, there should be a file registrymodifications.xcu in LO's per-user configuration data (not sure where exactly that is located on your machine, likely somewhere underneath "C:\Documents and Settings" or somesuch).  Can you check whether temporarily moving that file away solves the problem?  Also, I would be interested in the content of that file -- it is a text XML file and should not really contain sensitive information, so if you are OK with sharing it you can attach it here or send it to me directly, sbergman at redhat dot com.
Comment 2 Yorick Bosman 2012-05-15 05:31:39 UTC
Created attachment 61679 [details]
registerymodifications.xcu which was asked to attach
Comment 3 Yorick Bosman 2012-05-15 05:32:44 UTC
When opening a document directly from explorer it will work but when opening a file from the menu it wil not.
Comment 4 Stephan Bergmann 2012-05-16 00:52:28 UTC
With the attached registrymodifications.xcu, I could reproduce the problem.  The auto-healing attempts from <https://bugs.freedesktop.org/show_bug.cgi?id=46074#c59> were obviously not sufficient for all cases.  The further auto-healing fix from <https://bugs.freedesktop.org/show_bug.cgi?id=46074#c67> should address that (on master, but I intend to get it backported to libreoffice-3-5-4).

I'm marking this bug now as a duplicate of bug 46074, bundling all the auto-healing attempts there.

*** This bug has been marked as a duplicate of bug 46074 ***
Comment 5 Xisco Faulí 2018-02-26 11:14:44 UTC
The content of attachment 61679 [details] has been deleted