Bug Hunting Session
Bug 49967 - In LibreOffice the OS X Lion Feature "Press and hold a character to invoke the special characters menu." doesn't work.
Summary: In LibreOffice the OS X Lion Feature "Press and hold a character to invoke th...
Status: RESOLVED DUPLICATE of bug 42437
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) Mac OS X (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-15 13:12 UTC by Allards
Modified: 2017-06-01 01:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example missing feature (36.28 KB, image/png)
2012-05-15 13:12 UTC, Allards
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Allards 2012-05-15 13:12:26 UTC
Created attachment 61692 [details]
Example missing feature

"Lion Apple has implemented a new Special Characters feature to allow you to quickly input optional character such as those with accents for European and South American languages. In Lion, instead of a key's input repeating when it's pressed and held, you will see a small menu giving you options for the various alternative characters that are available."

I hope this could be implemented.
Comment 1 Roman Eisele 2012-05-16 11:11:20 UTC
This is a feature/enhancement request, therefore changed the Importance field accordingly.
Comment 2 Roman Eisele 2012-09-04 08:29:34 UTC
@ Alex Thurgood:
Hello Alex,
you happen to know Mac OS X Lion much better than me (I have to stay with Snow Leopard for myself). Could you please do a quick check if the OS X Lion Feature mentioned in this bug report really does not work with LibO 3.6? Then we can set the status of this enhancement request to NEW.

Thank you very much!
Comment 3 Alex Thurgood 2012-09-05 08:11:16 UTC
(In reply to comment #0)
> Created attachment 61692 [details]
> Example missing feature
> 
> "Lion Apple has implemented a new Special Characters feature to allow you to
> quickly input optional character such as those with accents for European and
> South American languages. In Lion, instead of a key's input repeating when it's
> pressed and held, you will see a small menu giving you options for the various
> alternative characters that are available."
> 
> I hope this could be implemented.

As you have mentioned, this is a new feature introduced in Lion. LO is built against the 10.4 SDK, so it can not possibly have this feature. Any chance of this feature ever being available in LO will be dependent on the LO build process switching to a more recent Apple SDK which, unless a LO developer wishes to correct me, is not currently foreseen.


Alex
Comment 4 Alex Thurgood 2012-09-05 08:14:52 UTC
Well it doesn't work in Firefox either, or Thunderbird, in fact, any opensource application that is built with backwards compatibility against the 10.4 SDK that I currently have on my system, so at least LO is not alone :-))


Alex
Comment 5 Alex Thurgood 2012-09-05 08:15:30 UTC
Tested on OSX 10.8.1
Comment 6 Roman Eisele 2012-09-05 08:22:41 UTC
@Alex:
Thank you for testing this and for your careful explanation!
Comment 7 Don't use this account, use tml@iki.fi 2013-08-06 07:22:17 UTC

*** This bug has been marked as a duplicate of bug 42437 ***
Comment 8 EricP 2017-06-01 01:56:19 UTC
A few years later now...
Press And Hold still does not work in LibreOffice, even though LibreOffice is now built against an SDK requiring MacOS 10.8 or higher (see comment 3).  As indicated in bug 42437, comment 7, just an SDK update is not enough; adding this feature will require some developer time.

It is, apparently, possible to "add" Press and Hold support to some applications simply by typing a Terminal command similar to this:

defaults write org.libreoffice ApplePressAndHoldEnabled -bool true

but this does NOT enable Press and Hold in LibreOffice 5.3.