Bug 50022 - Base fails to work with Java 1.7 on Windows 32 bit (invalid/corrupted or not found)
Summary: Base fails to work with Java 1.7 on Windows 32 bit (invalid/corrupted or not ...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 50023 51419 52984 54248 54821 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-05-16 12:16 UTC by jcs.LibreOffice
Modified: 2018-04-15 16:02 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jcs.LibreOffice 2012-05-16 12:16:06 UTC
Problem description: 
When selecting Java 7 from the Java Menu version 3.5.3 and version 5.2 report it as corrupt. I do not have any existing databases to test with. Using version 6 I have been able to run through the tutorial material.

Steps to reproduce:
1. ....Version 1.6.0_31 and 1.7.0_04 are both installed
2. ....select version 7, error reported
3. ....Note on one occasion LO would not then restart adnI had to edit the xml configuration file

Current behaviour:
Works with Java 1.6. Won't work at all with Java 1.7

Expected behaviour:
To be able use latest Java as this has latest security patches

Platform (if different from the browser): 
Windows Vista on 32 bit HP laptop. Reproducible on Windows 7 on a 32 bit virtual machine
              
Browser: Mozilla/5.0 (Windows NT 6.0) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.46 Safari/536.5
Not relevant
Comment 1 Robert Großkopf 2012-07-07 23:37:26 UTC
*** Bug 50023 has been marked as a duplicate of this bug. ***
Comment 2 Jochen 2012-08-28 18:41:28 UTC
IMHO a known bug with Java 7 and have nothing to with LO. Okay für all?
Comment 3 ratrace 2012-09-11 15:47:12 UTC
*** Bug 51419 has been marked as a duplicate of this bug. ***
Comment 4 Robert Großkopf 2012-10-10 06:58:14 UTC
It's a bug, that LO-Base don't work with a new JRE. We can't set it to NEEDINFO, when there are many other reports, which were marked as "duplicate" of this report.
Comment 5 Robert Großkopf 2012-10-10 07:03:48 UTC
*** Bug 54248 has been marked as a duplicate of this bug. ***
Comment 6 Robert Großkopf 2012-10-11 10:31:02 UTC
*** Bug 54821 has been marked as a duplicate of this bug. ***
Comment 7 Robert Großkopf 2012-10-12 17:19:43 UTC
*** Bug 52984 has been marked as a duplicate of this bug. ***
Comment 8 Robert Großkopf 2013-03-30 19:04:46 UTC
Does this problem already exist with LO 4.0 ? I have often heard from Windows-users, that this problem has gone with LO 4.0.0.3
Comment 9 retired 2013-06-24 09:50:32 UTC
*** Bug 66014 has been marked as a duplicate of this bug. ***
Comment 10 Julien Nabet 2013-10-10 20:43:49 UTC
jcs: could you give a try with LO 4.1.2? Also, LO is 32 bit only on Windows, so you must have a Java 32 installed.
Comment 11 Dick 2013-10-10 23:41:05 UTC
I still have version 6 plus version 7 on my pc.  I am running Libre Office
4.1.2.  I did not have any problems, but not sure which Java it uses.  

 

Richard Seidemann

  _____  

From: bugzilla-daemon@freedesktop.org
[mailto:bugzilla-daemon@freedesktop.org] 
Sent: Thursday, October 10, 2013 3:44 PM
To: seidedick@charter.net
Subject: [Bug 50022] : Base fails to work with Java 1.7 on Windows 32 bit

 

 <mailto:serval2412@yahoo.fr> Julien Nabet changed bug
<https://bugs.freedesktop.org/show_bug.cgi?id=50022>  50022 


What

Removed

Added


Status

NEW 

NEEDINFO 


CC

  

serval2412@yahoo.fr 

Comment <https://bugs.freedesktop.org/show_bug.cgi?id=50022#c10>  # 10 on
bug <https://bugs.freedesktop.org/show_bug.cgi?id=50022>  50022 from
<mailto:serval2412@yahoo.fr> Julien Nabet 

jcs: could you give a try with LO 4.1.2? Also, LO is 32 bit only on Windows,
so
you must have a Java 32 installed.
  _____  


You are receiving this mail because: 

*	You are on the CC list for the bug.

No virus found in this message.
Checked by AVG - www.avg.com
Version: 2014.0.4158 / Virus Database: 3609/6739 - Release Date: 10/10/13




-----
No virus found in this message.
Checked by AVG - www.avg.com
Version: 2014.0.4158 / Virus Database: 3609/6739 - Release Date: 10/10/13
Comment 12 Frank Fuchs 2013-10-11 09:16:41 UTC
LO 4.1.2.3 on W7 32bit does recognize Sun Java 7u40 32bit.

The true problem is the missing Java 7 64-bit support which is the only one available from Oracle for Mac OS X 10.8 / 10.9
Comment 13 Julien Nabet 2013-10-11 18:51:36 UTC
Richard: thank you for your feedback.

Frank: Java7 64 can be used with 64 applications. LO has a 64 bit version for Linux but not yet for Windows and MacOs. For MacOs, it's in development. I don't know if it'll be done for 4.2.0
Anyway, fdo#58663 is the tracker about LO port on MacOs64

Finally I put this tracker as NOTABUG.
Now of course, it could be interesting there's an LO 64 port for Windows but IMHO this would be enhancement more than a bug.