Download it now!
Bug 50396 - EDITING: grouped shapes drawings become distorted
Summary: EDITING: grouped shapes drawings become distorted
Status: RESOLVED DUPLICATE of bug 50399
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-27 09:50 UTC by Rainer Bielefeld Retired
Modified: 2013-02-12 21:19 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
test kit (264.63 KB, application/zip)
2012-05-27 09:50 UTC, Rainer Bielefeld Retired
Details
New Test Kit 2013-01-19 (229.09 KB, application/x-zip-compressed)
2013-01-19 08:13 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-05-27 09:50:12 UTC
Created attachment 62144 [details]
test kit

I observe the problem in drawings I (accidently) open alternating with LibO 3.4.5. 3.5 (current versions) and sometimes Master. Some few drawings composed of shapes created by copying, rotating and flipping basic shape(s) become more and more distorted. In attached document "sample.odg" from textkit the most left shows how the shape should look. The medium one showed how it looked 2012-05-10, and the right one how it looks today. 

Additionally in test kit you find 4 documents. "veryearly345.odg" I created from an old document what has been untouched 2012-01-4 what I opened and saved with 3.4.5 (WIN7 64 Bit) after I had deleted most slides. Same open, delete slides, save proceeding for same source document with "LibreOffice 3.5.4.2 (RC2) German UI/Locale [Build-ID: 165a79a-7059095-e13bb37-fef39a4-9503d18] on German WIN7 Home Premium (64bit) as "veryearly354.odg".

And same proceeding for a document version edited today, saved from 3.4.5 as "latestsaved345.odg" and from 3.5.4 as "latestsaved345.odg"

Comparing the "Latestsaved" documents in 3.4.5 you see a difference in the first slide in the shape looking as the example in "sample.odg" the triangle "arrowdown" in it has moved a little up during proceeding. Seldom success until now I never have been able to observe such a change, until now I only saw after a while that situation has become worse. And I was not able to reproduce the problem again with my samples.

To compare documents I opened both with 3.4.5, set zoom to "optimum" and switched between the windows, saw that everything was identical except that "arrowdown triangle"

An other very very ugly effect you see comparing the Window drawing on the second slide .

You also find PDF exports from all my views.
Comment 1 Björn Michaelsen 2012-05-30 01:10:58 UTC
regression against 3.4, needs a bibisect.
Comment 2 Rainer Bielefeld Retired 2012-05-30 02:28:49 UTC
@Bjoern:
please excuse me, but I really really doubt that Bibisecting will lead to a result for a problem what is so difficult to reproduce and currently only observed with WIN
Comment 3 Rainer Bielefeld Retired 2012-05-30 02:41:48 UTC
My results seem to show that the problem started (a lot of time)  before 3.5.4, but 3.5.4RC2 was the only version with what I was able to see a difference between before/after save.
Comment 4 Rainer Bielefeld Retired 2012-05-30 02:49:05 UTC
Accident, did not want to modify status (in spite of my doubts)
Comment 5 Björn Michaelsen 2012-05-30 02:55:59 UTC
@Rainer: Yes, bibisecting this is a challenge. However, fixing this without bibisecting isnt a walk in the park either. So unless some dev comes along and says "oh, yeah, I might have broken that with my change X", bibisecting is the only way to push this issue forward. Chances of the first are pretty slim.
Comment 6 Muthu 2012-06-19 03:27:54 UTC
Older versions of LO were affected by bug 47406 . Are we sure this is not something to do with that, please?
Comment 7 Rainer Bielefeld Retired 2012-06-19 04:56:43 UTC
With 3.6.0RC I will start a new isolated branch of the effected drawings, we will see what happens and whether I will find a way to make the problem reproducible
Comment 8 Rainer Bielefeld Retired 2013-01-19 08:13:25 UTC
Created attachment 73276 [details]
New Test Kit 2013-01-19

Old test  kit contained 1 wrong document
Comment 9 Jorendc 2013-02-07 20:20:16 UTC
@Rainer: Sorry to interrupt; is it possible to retest with 4.0? And if still reproducible move it to mab3.6 please. We're moving all 'still reproducible' and 'valid' MAB3.5 bugs to MAB3.6. I don't have any Windows machine to test right now.

Kind regards,
Joren

PS: bug status is NEEDINFO?
Comment 10 Rainer Bielefeld Retired 2013-02-07 21:42:07 UTC
I wonder what the relation might be to "Bug 50399 - FILESAVE document created with 3.4.5 destroys grouped elements for 3.4 VIEWING",  I will do some tests next week. Thank you for reminder
Comment 11 Joel Madero 2013-02-12 19:08:02 UTC
Removing from 3.5 MAB just to get it out of the list. 

@Rainer - if it's still an issue (also don't have Windows to test), can you push it to 3.6 MAB and mark as NEW? Thanks!
Comment 12 Rainer Bielefeld Retired 2013-02-12 21:19:12 UTC
I am pretty sure that this one is a DUP of "Bug 50399 - FILESAVE document created with 3.4.5 destroys grouped elements for 3.4 VIEWING". I mark this one as DUP and will check all related shapes after a fix for Bug 50399

*** This bug has been marked as a duplicate of bug 50399 ***