Bug 50559 - FORMATTING: Alignment center incorrect if page size too large
Summary: FORMATTING: Alignment center incorrect if page size too large
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 68080 (view as bug list)
Depends on:
Blocks: Page
  Show dependency treegraph
 
Reported: 2012-05-31 13:51 UTC by Laurent BP
Modified: 2019-08-13 14:05 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Test file which looks left align. It should be centered. (8.84 KB, application/vnd.oasis.opendocument.text)
2012-05-31 13:51 UTC, Laurent BP
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent BP 2012-05-31 13:51:04 UTC
Created attachment 62350 [details]
Test file which looks left align. It should be centered.

Problem description: 

Steps to reproduce:
1. create a new document
2. change page width to 70cm
3. change paragraph alignment to center

Current behavior:
Alignment is visibly kept left. Same in preview.

Expected behavior:
Alignment should become center

Check with attach file: alignment is set to center, but it is visibly Left alignment.
Add a character, and it works as expected.
The problem appears when empty space between text and margin (= page width - left margin - right margin - text length) is higher or equal to 57.80cm (it works correctly at 57.79cm).
It is an old bug as it is present in OOo 2.3.1 (check with PortableApps).

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.1; rv:12.0) Gecko/20100101 Firefox/12.0
Comment 1 Laurent BP 2012-05-31 14:00:07 UTC
I found issue 27878 from OOo 1.1.1.
https://issues.apache.org/ooo/show_bug.cgi?id=27878
Comment 3 Christian Gonzalez 2013-03-12 21:28:27 UTC
This bug is still present in LibreOffice 4.0.1. It really is severe as it renders your complete work unusable for posters e.g. - NO centered alignment possible.
Comment 4 Christian Gonzalez 2013-03-12 21:42:33 UTC
a workaround is to put e.g. 20 spaces before AND after the line, so the space between the last (space) character and the right page border is smaller and coverable by LibreOffice. Center aligning then works ok, but it is a bad workaround.
Comment 5 Jean-Baptiste Faure 2013-03-13 05:32:22 UTC
(In reply to comment #3)
> This bug is still present in LibreOffice 4.0.1. It really is severe as it
> renders your complete work unusable for posters e.g. - NO centered alignment
> possible.

For posters you should prefer to use Draw instead of Writer.

Best regards. JBF
Comment 6 Christian Gonzalez 2013-03-13 18:39:40 UTC
I first used Draw, but it has no possibility to add footnotes with automatic references which is often used in posters for presenting scientific data: yo have to provide scientific data sources.

So Draw is no real option here - or I did not see that Draw has this ability too.

But anyway, it is a bug, nevertheless...
Comment 7 seechop 2013-05-21 18:57:03 UTC
I can't use Draw either and this bug in Writer is very disturbing. The bug should have a higher priority.

The bug appears when I set the page width to 655 mm or more. 654mm works fine, so I just assume it's a single number which has to be set larger in code. Set it to 10000mm at least.

I use LibreOffice 3.5.7.2 
Build ID: 350m1(Build:2)

This bug is so disturbing I'm considering using some other editor.
Comment 8 tommy27 2014-07-06 07:20:54 UTC
issue still reproducible in AOO 4.1, LibO 4.2.4.2 and LibO 4.4.0.0.alpha0+
Build ID: 95272e7e5b7e38753ab07dbd6503b7cfa2974842
TinderBox: Win-x86@42, Branch:master, Time: 2014-06-26_23:01:43
Comment 9 Gordo 2015-04-25 14:22:06 UTC
*** Bug 68080 has been marked as a duplicate of this bug. ***
Comment 10 QA Administrators 2016-09-20 09:32:19 UTC Comment hidden (obsolete)
Comment 11 Jean-Baptiste Faure 2016-09-24 20:59:22 UTC
Still reproducible with LO 5.2.3.0+ and master, both built at home under Ubuntu 16.04 x86-64.

Best regards. JBF
Comment 12 Laurent BP 2017-03-15 09:01:44 UTC
Confirmed with Version: 5.3.1.2 (x64)
Build ID: e80a0e0fd1875e1696614d24c32df0f95f03deb2
Threads CPU : 2; Version de l'OS :Windows 6.1; UI Render : par défaut; Moteur de mise en page : nouveau; 
Locale : fr-FR (fr_FR); Calc: CL

and AOO 4.1.3

change version according to comment 1
Comment 13 QA Administrators 2018-06-17 02:44:16 UTC Comment hidden (obsolete)
Comment 14 Jean-Baptiste Faure 2018-06-17 10:56:07 UTC
Still reproducible with LibreOffice 6.1.0.0.beta2 built at home under Ubuntu 16.04 x86-64.

Best regards. JBF
Comment 15 QA Administrators 2019-06-18 02:48:08 UTC Comment hidden (obsolete)
Comment 16 Jean-Baptiste Faure 2019-08-10 20:02:39 UTC
Not reproducible anymore with LO 6.3.1.0+ and current master, both built at home under Ubuntu 18.04 x86-64.

Closing as WorksForMe. Please, feel free to reopen if you disagree.

Best regards. JBF
Comment 17 Laurent BP 2019-08-13 14:05:45 UTC
I confirm: NOT reproduced with
Version: 6.3.0.1
Build ID: 41ac97386aba908b6db860cfb4cfe2da871886ae
Threads CPU : 8; OS : Linux 4.15; UI Render : par défaut; VCL: gtk3; 
Locale : fr-FR (fr_FR.UTF-8); UI-Language: fr-FR
Calc: threaded