Bug 50833 - SLIDESHOW: Custom Animations doesn't repeat
Summary: SLIDESHOW: Custom Animations doesn't repeat
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: x86-64 (AMD64) All
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 33018 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-06-07 07:02 UTC by MrBrownwait
Modified: 2018-11-18 20:31 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample File (10.90 KB, application/vnd.oasis.opendocument.presentation)
2012-07-16 15:55 UTC, MrBrownwait
Details

Note You need to log in before you can comment on or make changes to this bug.
Description MrBrownwait 2012-06-07 07:02:52 UTC
Problem description: 

Steps to reproduce:
1. Create arbitrary object for example a simple text
2. Add custom animation which is able to be repeated for example "blink"
3. Edit "Effect Options" / "Timing" / "Repeat"
4. Set value to any value different to "1"

Current behavior: Animation is repeated once

Expected behavior: Animation should be repeated as set

Platform (if different from the browser): Linux / Fedora 17
              
Browser: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.52 Safari/536.5
Comment 1 MrBrownwait 2012-06-07 07:04:51 UTC
Set platform to: Linux x86_64
Set importance to: high
Comment 2 Joel Madero 2012-07-16 15:41:28 UTC
I've confirmed this. Setting to NEW. Please attach a document showing the problem, I would but net is acting buggy right now, thanks for helping out.
Comment 3 MrBrownwait 2012-07-16 15:55:14 UTC
Created attachment 64282 [details]
Sample File
Comment 4 Schlomo Schapiro 2012-08-21 16:12:19 UTC
Very annoying bug. Also observed in LibreOffice 3.5.4.2 Build ID: 350m1(Build:2) on Ubuntu 12.04 amd64.
Comment 5 Joel Madero 2012-08-23 22:37:31 UTC
Thorsten or Radek, do one of you have time to take a look at this one. It may qualify as a MAB as it makes one of the prime features of Impress unusable.
Comment 6 Thorsten Behrens (CIB) 2012-08-24 15:43:41 UTC
This is fixed in master meanwhile, with Marco Cecchetti's great impress svg improvements. Beyond that, it's a long-standing bug we inherited from OOo even - see https://issues.apache.org/ooo/show_bug.cgi?id=113969 and others.
Comment 7 Regina Henschel 2012-10-22 15:57:10 UTC
*** Bug 33018 has been marked as a duplicate of this bug. ***
Comment 8 cedrcaba 2012-12-27 12:50:58 UTC
As for LibreOffice 4.0.0.0.beta2 (Build ID: 4104d660979c57e1160b5135634f732918460a0), the animation can be repeated up to 10 times and it works.
But the other options "Until next click" and "Until end of slide" still don't work.
Comment 9 Gregor 2014-11-01 20:13:50 UTC
Has returned in 4.3.2.2 at least on the Windows platform (Windows 7 64bit)
The set number of repeats (I tried 3 from the list) does not stay but is reset to 0 (follows path once, no repeats)
Comment 10 Joel Madero 2014-11-02 00:12:16 UTC
Please report it as a new bug - if it was fixed and returned it should be reported anew. Thanks
Comment 11 cedrcaba 2014-11-22 22:50:48 UTC
See https://bugs.freedesktop.org/show_bug.cgi?id=77186 for a continuation.