Bug Hunting Session
Bug 50988 - Draw crashes on loading MS Logical Design Diagram example viso file.
Summary: Draw crashes on loading MS Logical Design Diagram example viso file.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: target:3.7.0 target:3.5.5 target:3.6....
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-11 22:07 UTC by John Smith
Modified: 2012-06-18 10:39 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Microsoft 'Logical Design Diagram' example viso file. (1.24 MB, application/vnd.visio)
2012-06-11 22:07 UTC, John Smith
Details
Microsoft 'High-Level Physical Design Diagram' example viso file. (1.48 MB, application/vnd.visio)
2012-06-11 22:17 UTC, John Smith
Details
bt + console msgs on master (3.65 KB, text/plain)
2012-06-13 14:38 UTC, Julien Nabet
Details
LibO-3.5.5rc1 open VSD-files (244.11 KB, image/png)
2012-06-15 18:48 UTC, ape
Details
"sitplan.vsd" is opened (102.21 KB, image/png)
2012-06-16 07:03 UTC, ape
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Smith 2012-06-11 22:07:53 UTC
Created attachment 62910 [details]
Microsoft 'Logical Design Diagram' example viso file.

When opening the example Microsoft Visio 'Logical_Design_Diagram.vsd' file, LibreOffice crashes. I reproduced with both the daily build 'master~2012-06-10_08.54.55_LibO-Dev_3.7.0alpha0_Win_x86_install_en-US', and with 3.5.4.
Comment 1 John Smith 2012-06-11 22:17:29 UTC
Created attachment 62911 [details]
Microsoft 'High-Level Physical Design Diagram' example viso file.
Comment 2 Julien Nabet 2012-06-13 14:38:00 UTC
Created attachment 62989 [details]
bt + console msgs on master

On pc Debian x86-64, with master sources updated today, I reproduced the pb.

By looking at the bt and the console msg, it seems the same type of problem as fdo#50178.

I think I should be able to fix it so assign it to myself.
(however if someone wants to take it, go ahead, there's enough bugs to investigate/fix for everybody :-))
Comment 3 Not Assigned 2012-06-14 13:03:51 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cc85e1303fbdf7d1ff9c5b63ed9942206b53ddac

Resolves: fdo#50988
Comment 4 Julien Nabet 2012-06-15 04:55:50 UTC
John: Could you please test again the 2 files you attached with the most recent daily build ?
Also, if you don't reproduce the crash with these 2 files but have a crash with another Visio file you have, don't hesitate to attach it here.

Just for information, I posted on dev mailing list about fix backporting here :
http://nabble.documentfoundation.org/REVIEW-fdo-50988-Draw-crashes-on-loading-MS-Logical-Design-Diagram-example-visio-file-tp3990215.html
Comment 5 Not Assigned 2012-06-15 13:17:47 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cf30232897adb16a038cef9a66f1dbee1318db43&g=libreoffice-3-5

Resolves: fdo#50988


It will be available in LibreOffice 3.5.6.
Comment 6 Not Assigned 2012-06-15 13:18:11 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=70ed7beae7b21e391df0a246078c2103f8b3fe3a&g=libreoffice-3-6

Resolves: fdo#50988


It will be available in LibreOffice 3.6.
Comment 7 ape 2012-06-15 18:48:14 UTC
Created attachment 63095 [details]
LibO-3.5.5rc1 open VSD-files

Windows XP sp3. LibreOffice 3.5.5.1 (ID: c9944f7-48b7ff5-0507789-54a4c8a-8b242a8)
1. Run LibreDraw-3.5.5rc1
2. Menu File > Open
3. Select "attachment_62910.vsd". The result - the file is opened.
4. Select "attachment_62911.vsd". The result - the file is opened.
It seems to me that this bug duplicates the bug_48601.
Comment 8 Julien Nabet 2012-06-15 23:26:50 UTC
ape: badfully not, fdo#48601 files still crash
Comment 9 ape 2012-06-16 07:03:38 UTC
Created attachment 63113 [details]
"sitplan.vsd" is opened

(In reply to comment #8)
> ape: badfully not, fdo#48601 files still crash

Sorry, I understand very little English. But LibreDraw-3.5.5rc1_Win_x86 also opens the file "sitplan.vsd" (attachment_59854; fdo#48601) without crashing, if:
1. Run LibreDraw-3.5.5rc1
2. Menu File > Open
3. Select "sitplan.vsd".
4. The file is opened.
Comment 10 John Smith 2012-06-16 11:06:39 UTC
(In reply to comment #4)
> John: Could you please test again the 2 files you attached with the most recent
> daily build ?
> Also, if you don't reproduce the crash with these 2 files but have a crash with
> another Visio file you have, don't hesitate to attach it here.
> 
> Just for information, I posted on dev mailing list about fix backporting here :
> http://nabble.documentfoundation.org/REVIEW-fdo-50988-Draw-crashes-on-loading-MS-Logical-Design-Diagram-example-visio-file-tp3990215.html

@Julien Nabet: I tried opening tyhe files I attached with daily build 'master~2012-06-16_00.24.35_LibO-Dev_3.7.0alpha0_Win_x86_install_en-US.msi'. Both files open without crashing now. Unfortuantely, I dont have any more Visio files that actually *crash* :). The only problem im left with right now is a visio file that doenst display at all (*blank*page*) in Draw: bug #50990. Thanks for the work.
Comment 11 Not Assigned 2012-06-18 09:10:02 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-3-5-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c49a512e630fdba3a706f582cd37424f9d695281&g=libreoffice-3-5-5

Resolves: fdo#50988


It will be available already in LibreOffice 3.5.5.
Comment 12 Julien Nabet 2012-06-18 10:39:06 UTC
John: Thank you for your feedback. Since you tested it ok with daily build, I update the tracker to RESOLVED/FIXED.
About fdo#50990, don't hesitate to post if necessary.