Bug 51311 - FILESAVE: Writer takes a long time to begin saving large files
Summary: FILESAVE: Writer takes a long time to begin saving large files
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
Depends on:
Blocks: Save
  Show dependency treegraph
 
Reported: 2012-06-21 11:25 UTC by Aibara
Modified: 2019-04-18 17:54 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Large almost 900 page file (1.40 MB, application/vnd.oasis.opendocument.text)
2012-06-21 11:25 UTC, Aibara
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aibara 2012-06-21 11:25:31 UTC
Created attachment 63317 [details]
Large almost 900 page file

I've had a problem with saving since the 3.5 series began (currently using 3.5.4.2 on Ubuntu 12.04): big files take a long time to save, whereas in the 3.4 series and before I never had a problem and the saving process would begin instantly. 

Steps to reproduce:
Open attached file.
Add a small change like typing a character.
Save the file.

Expected behavior:
File begins saving process immediately.

Actual behavior:
LibreOffice freezes for up to 40 seconds and is totally unresponsive.


Note that smaller files save instantly, but starting with about 100 pages files, Writer freezes up for a bit before showing the file saving progress bar and filling it at a normal pace. It takes maybe 5 seconds for a 100 page file, 15 for a 300 page one. Ones much larger take 40 seconds, but don't seem to freeze for longer than that (a 900 page file, like the one I've attached as a test case, takes 40 seconds, but that's the same as a 4,000 page document). 

Another note is that this only seems to occur if I try to save the file within the first few minutes of opening LibreOffice. If I wait, say, 10 minutes and hit save, the save progress bar immediately appears and the file is quickly saved.

I thought this might be related to, but I'm not too sure:
https://bugs.freedesktop.org/show_bug.cgi?id=40718

Thanks!
Comment 1 Aibara 2012-07-16 13:23:42 UTC
This problem is still present in LibreOffice 3.5.5.3.
Comment 2 Aibara 2012-08-20 18:36:27 UTC
In version 3.6.0.2 (Build ID: 360m1(Build:102)) the problem has changed: Writer now hangs as soon as a large file begins to be edited (e.g. type a few characters).
Comment 3 Aibara 2012-12-09 07:01:42 UTC
In LO 4.0.0.0 beta1 the problem seems to have shifted (I imagine its related) - LO hangs when it opens the file. 

See:
https://bugs.freedesktop.org/show_bug.cgi?id=58040
Comment 4 Brenda Granados 2013-02-15 18:24:01 UTC
I tested the save for the large file that you provided on LibreOffice 4.0.1.0+ and 4.0.0.3 on Ubuntu 12.04 LTS. I think they're both a little sluggish in opening, but it's only about 2 seconds of delay. For the saving, there is a similar length of delay. When I first started adding text to the document, shortly after opening, there was a very minor < 1 second delay, in text appearing, but that effect quickly went away.

I would like to set the priority as Minor, Medium, because the saving delay is inconvenient, but it does save, and not prevent a user from making high quality work. Do you agree? If there's any other information about this bug, or certain other scenarios that you think are relevant to this one, please respond.
Comment 5 Aibara 2013-02-20 08:09:50 UTC
I still have the same issues described in bug #58040: when I open the file the progress bar fills, then the program hangs for a good 15 seconds. Editing text doesn't work immediately either (that takes another 10 seconds about to work properly). Perhaps the difference is due to my laptop. Though of course back in 3.4 series and earlier there was no problem at all.

As for marking this minor or medium, it's up to you. It's an annoying regression, plus if the user thinks the program has hung they might just try to force quit it. But I'm not sure how that fits into minor/medium destinctions.
Comment 6 Brenda Granados 2013-02-20 14:37:09 UTC
After reading the bug you directed me to, I really don't know what to say. I don't experience the same issue, but I can see how it would be really frustrating for those who do. I will just leave the priority as you originally set it.
Comment 7 QA Administrators 2015-09-04 02:49:54 UTC Comment hidden (obsolete)
Comment 8 Buovjaga 2015-11-30 14:10:26 UTC
This might be related to spellchecking, bug 96145
Comment 9 Robinson Tryon (qubit) 2015-12-09 17:59:25 UTC Comment hidden (obsolete)
Comment 10 Telesto 2016-12-21 11:40:30 UTC
No repro
Version: 5.4.0.0.alpha0+
Build ID: 9cfb2f2f03b5ec086487fd483298466db0b09010
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-20_23:58:02
Locale: nl-NL (nl_NL); Calc: CL

behaves similar to:

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 11 QA Administrators 2018-06-26 02:44:09 UTC Comment hidden (obsolete)
Comment 12 Buovjaga 2019-04-18 17:54:37 UTC
Seems to work fine now. Let's close.

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: 1fee3f1da6291bfbcd75455512726215d41b3e83
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 18 April 2019