Bug 51524 - FILESAVE .xlsx and.xls looses width information for hidden/collapsed grouped columns
Summary: FILESAVE .xlsx and.xls looses width information for hidden/collapsed grouped...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Bartosz
QA Contact:
URL:
Whiteboard: target:5.3.0 target:5.2.5
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-28 08:28 UTC by Florian Reisinger
Modified: 2016-12-05 17:45 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
The test document (64.50 KB, application/vnd.ms-excel)
2012-06-28 08:28 UTC, Florian Reisinger
Details
Screenshot for bug 1 (2.54 KB, image/png)
2012-06-28 08:29 UTC, Florian Reisinger
Details
Simple sample created from the scratch (8.62 KB, application/x-vnd.oasis.opendocument.spreadsheet)
2012-11-24 19:02 UTC, Rainer Bielefeld Retired
Details
Row and Column Outline created by Excel 2010 (.xlsx) (8.80 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2016-07-07 08:10 UTC, Bartosz
Details
Row and Column Outline created by Excel 2010 (.xls) (23.00 KB, application/vnd.ms-excel)
2016-07-07 08:11 UTC, Bartosz
Details
Simple sample converted to .xlsx by MS Excel 2010 (8.42 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2016-07-07 08:41 UTC, Bartosz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Reisinger 2012-06-28 08:28:59 UTC
Created attachment 63569 [details]
The test document

Open the attached file. Column A-C are hidden...

BUG 1: When you open the file you have to click a "-" symbol and nothing happens. As a next step you have to click "+", which should be default

BUG 2: The cell width is not remembered, when the three columns are invisible, but the width is remembered when they are visible...
Comment 1 Florian Reisinger 2012-06-28 08:29:59 UTC
Created attachment 63570 [details]
Screenshot for bug 1

@ Bernhard M. : Alles zu deiner Zufriedenheit?
Comment 2 Rainer Bielefeld Retired 2012-11-24 08:09:31 UTC
I did a quick test with 3.3.3 and saw the expand button - problem, I doubt that that has to do with the rest here, so I will submit a new bug for that.
 <http://wiki.documentfoundation.org/BugReport#General_information> item 4
So Is stripped away that problem and submitted 
"Bug 57477 - FILESAVE as .xls with wrong info concerning collapsed grouped columns"
"Bug 57478 - UI: FILEOPEN LibOCreated.xls with grouped columns shows "collapse '-'" instead "expand'+'" above collapsed columns"


I checked with Server Installation of "LibreOffice 3.3.3  German UI/Locale [OOO330m19 (Build:301) tag libreoffice-3.3.3.1] on German WIN7 Home Premium (64bit) 

Steps:
1. Open sample document 2012-06-28 08:28 UTC, Florian Reisinger 
   > columns A-C are hidden
2. Click the small "-" or "+" above column header "D" to show columns A-D
   until Columns A-C appear
3. With menu 'format -> Column' check column width of Columns A-D
   > Is 2,36cm
4. close without saving and reopen
5. Save as newname.xls
6. reopen newname.xls
   Expected: column width of Columns A-D: 2,36cm
   Actual: as expected.

So I cannot reproduce a change column width problem.
But on <discuss@de.libreoffice.org>
 <http://listarchives.libreoffice.org/de/discuss/msg12890.html>
original reporter Bernhard Mock says that he expected a column width of 1 cm in step 3? I can't confirm that for attached sample, even Excel 2010 shows a column width of 2,36cm

@Florian:
To be honest, it was some hare work to find out what problems we are talking about here. And the original report on <discuss@de.libreoffice.org> was concerning Libreoffice 3.5.3.2 Build-ID: 350m1(Build:2), Ubuntu 12.04, 64 bit  and here the report is for 3.3.0 Beta2, all OS? Did you really do any own test, and if yes how and with what results?
Comment 3 Rainer Bielefeld Retired 2012-11-24 17:53:38 UTC
[Reproducible] with "LibreOffice 3.6.4.1 rc" German UI/ German Locale [Build-ID: a9a0717] on German WIN7 Home Premium (64bit):

1. open attached sample document
2. Expand hidden columns A...C using small '-' button above column D 
3. Select Columns A...C
4. Menu 'format -> Column  -> Width -> 10mm <ok>'
   Column now is 10mm
5. Coollapse columns A...C using small '-' button above column D 
6. Save as "sample10mm.xls" and "sample10mm.ods", close document
7. reopen "sample10mm.xls" , expand columns A...D and check width
   Expected: 10mm
   Actual: 23,62mm  !!!

Problem is not visible in "sample10mm.ods" 

Problem is visible with EXCEL 2010, so definitively FILESAVE problem

I will do some more investigation, soon
Comment 4 Florian Reisinger 2012-11-24 18:21:41 UTC
I did investigations with MS Office 2010 LibreOffice x.x (newest stabl build that time) and OpenOffice 3.2.1 --> Oldest version should be in version field which is "inherited from OpenOffice older than 3.3" so first LibO version...

IMHO this bug can be closed, because of the 2 new bugs submitted by you...
Comment 5 Rainer Bielefeld Retired 2012-11-24 19:02:04 UTC
Created attachment 70526 [details]
Simple sample created from the scratch

Problem indeed only appears for collapsed rows, not when they are visible.

I can reproduce the problem with an own simple sample created "from the scratch"

Simply download "simplesample11.ods", check row heights and column widths if you want, don't forget to collapse again, and save as "simplesample11.xls" (MSO97).

After close and reopen you will see that rows 5,6,9 kept their heights, but columns A,B,C all have default width.

XLSX (MSO) and XLSX (OOX) also are affected
Comment 6 Rainer Bielefeld Retired 2012-11-24 20:09:29 UTC
Already a problem with OOo 3.1.1, so inherited from OOo

@Spreadsheet Team
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf (and remove others in team from CC).
Comment 7 QA Administrators 2015-04-19 03:23:40 UTC Comment hidden (obsolete)
Comment 8 Buovjaga 2015-06-19 14:38:08 UTC
Still repro.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 437210d58f32177ef1829d704f7f4d2f1bbfbfdd
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-18_07:21:56
Locale: fi-FI (fi_FI)
Comment 9 Bartosz 2016-07-07 08:10:01 UTC
Created attachment 126098 [details]
Row and Column Outline created by Excel 2010 (.xlsx)

The same issues exists with .xlsx format on master branch (Libreoffice 5.3).
I will investigate that issue
Comment 10 Bartosz 2016-07-07 08:11:38 UTC
Created attachment 126099 [details]
Row and Column Outline created by Excel 2010 (.xls)
Comment 11 Bartosz 2016-07-07 08:41:22 UTC
Created attachment 126100 [details]
Simple sample converted to .xlsx by MS Excel 2010
Comment 12 Commit Notification 2016-07-12 09:21:39 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b0d96a82a4f6a0832d03d185f4a53db669adcc99

tdf#51524 Preserve hidden column width after saving into .xlsx and .xls

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Bartosz 2016-07-12 16:37:36 UTC
Unforuntely this issue was resolved only for .xlsx and not for .xls

I will investigate it further and get back with results
Comment 14 Bartosz 2016-07-14 06:11:55 UTC
It's working for me correctly with .xlsx and .xls
Comment 15 Commit Notification 2016-12-05 17:45:54 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=740f369a90a7e524bfd2f82ba9cb350c190fe282&h=libreoffice-5-2

tdf#51524 Preserve hidden column width after saving into .xlsx and .xls

It will be available in 5.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.