Bug Hunting Session
Bug 51701 - Visio Document checked in Windows installer
Summary: Visio Document checked in Windows installer
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta2
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-03 17:15 UTC by Pedro
Modified: 2013-05-28 21:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro 2012-07-03 17:15:09 UTC
In the current Windows installer for 3.6.0 Beta 2+ (libreoffice-3-6~2012-07-02_20.24.23_LibO-Dev_3.6.0.0.beta2_Win_x86_install_en-US.msi) the Microsoft Visio Document option is checked by default (at least when running the Custom option)

Expected: it should be unselected as for all other Microsoft file types
Comment 1 Andras Timar 2012-07-07 11:54:30 UTC
Why do you think it is a bug? Do you have Visio/Visio Viewer installed? If not, LibreOffice installer does the right thing when it offers to open Visio files in LibreOffice.
Comment 2 V Stuart Foote 2012-07-09 04:23:55 UTC
(In reply to comment #0)
> In the current Windows installer for 3.6.0 Beta 2+
> (libreoffice-3-6~2012-07-02_20.24.23_LibO-Dev_3.6.0.0.beta2_Win_x86_install_en-US.msi)
> the Microsoft Visio Document option is checked by default (at least when
> running the Custom option)
> 
> Expected: it should be unselected as for all other Microsoft file types

It worked correctly for me with both LOdev3.6b2 and then again with LOdev3.6b3, i.e. option to set LO as prefered program of all four MSO components was presented unchecked on the installer panel.

But with both releases, I was working on systems with no LibreOffice 3.5.x configuration remaining following complete uninstallation.

Perhaps make another attempt following complete uninstall and removal of all LO configuration files from user profile and system.
Comment 3 Pedro 2012-07-09 22:57:26 UTC
(In reply to comment #1)
> Why do you think it is a bug? Do you have Visio/Visio Viewer installed? If not,
> LibreOffice installer does the right thing when it offers to open Visio files
> in LibreOffice.

It does make sense. But unfortunately that does not happen for the other file types. I uninstalled my copy of MS Office 2003 to test it. So I guess it's a bug (or inconsistency)
Comment 4 Pedro 2012-08-14 12:40:27 UTC
When installing on a brand new PC (which never had MS Office installed) all 4 file types show checked (as expected). This possibly means that the LO installer is checking some registry keys that are NOT removed after MS Office uninstall. Since currently most systems are provided with some free/limited version of MS Office, then file association with LO will not happen except for Visio.
Comment 5 Joel Madero 2013-05-28 15:37:38 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team