Bug 51735 - Wavy red underline for spelling errors pixelated on Retina display (HiDPI)
Summary: Wavy red underline for spelling errors pixelated on Retina display (HiDPI)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Tomaz Vajngerl
URL:
Whiteboard: target:6.4.0
Keywords:
Depends on:
Blocks: MacOS-Wishlist HiDPI
  Show dependency treegraph
 
Reported: 2012-07-04 15:51 UTC by Brion Vibber
Modified: 2019-07-01 12:34 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of Writer on Retina MacBook Pro. Red underline is pixelated. (108.70 KB, image/png)
2012-07-04 15:51 UTC, Brion Vibber
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brion Vibber 2012-07-04 15:51:27 UTC
Created attachment 63835 [details]
Screenshot of Writer on Retina MacBook Pro. Red underline is pixelated.

Testing LibreOffice 3.5.4.2 on a MacBook Pro with Retina display... most stuff works pretty well!

I notice that the wavy red underline for spelling errors, in at least Writer and Impress, is pixelated. Seems to be from a low-resolution image rather than being drawn wavy?

Needs to use a higher-resolution base image when displaying a window on a HiDPI screen.
Comment 1 Roman Eisele 2012-07-14 07:56:03 UTC
@Brion Vibber:
Thank you very much for your report, especially for the screenshot!
I'm sorry that I can't confirm it (I don't have a Retina display :-(,
but we will see ...
Comment 2 tommy27 2013-08-18 16:25:28 UTC
@Brion Vibber  
have you tried upgrading to a more recent release (4.0.4 or 4.1.0)?
LibO 3.5.2 is an obsolete version.
Comment 3 Keith Curtis 2013-12-09 21:13:38 UTC
I'm going to work on this.
Comment 4 Keith Curtis 2013-12-20 07:15:44 UTC
Actually, I'm not going to work on this.

The Mac works fine right now because of this:
https://developer.apple.com/library/mac/documentation/GraphicsAnimation/Conceptual/HighResolutionOSX/CapturingScreenContents/CapturingScreenContents.html

It doubles everything but text drawing, which is very reasonable except for a few bugs like the pixelated squiggly underlines. It will be some time before high-res can be turned on for Macs, until the issues are worked out and possibly until LO gets high-res toolbar bitmaps.

My goal is to make Linux / Windows look reasonable and so I won't be working on this.
Comment 5 mrjbq7 2015-02-27 15:17:31 UTC
This is still a bug in LibreOffice 4.4.1 on MacBook Pro with Retina display.
Comment 6 mrjbq7 2015-08-05 14:22:21 UTC
Confirmed still in LibreOffice 5.0.0 x86.64 on MacBook Pro with Retina display.
Comment 7 QA Administrators 2016-09-20 10:21:42 UTC Comment hidden (obsolete)
Comment 8 Chris Sherlock 2018-03-04 05:34:06 UTC
Brion, I’ll see if this is still occurring.