Download it now!
Bug 52086 - UI: COPY SORT RESULTS only works when sorting from the Options tab.
Summary: UI: COPY SORT RESULTS only works when sorting from the Options tab.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-14 14:59 UTC by pierre-yves samyn
Modified: 2014-10-02 19:56 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2012-07-14 14:59:05 UTC
Hello

The sort option "copy sort results to" only works if we launch sorting from the Options tab.

Steps to reproduce:

1. File> New> Spreadsheet
2. Enter 1, 2, 3 respectively A1, A2, A3
(or open a Spreadsheet containing data to sort)
3. Click in the range (eg A1) then Data> Sort
4. "Options" tab check "Copy sort results to" and specify a
destination, eg A10
5. Tab "Sort Criteria" select "Column A" and "Descending"
6. Click on "Options" tab to check "Copy to" still indicates A10
7. Back on the "Sort Criteria" and confirm with Ok

Expected result: copy sorted data in A10
Actual result: Data sorted replace data "in situ", no copy

Note: the "copy sort results to" is ok if done to Step 6
(from the "Options").

REGRESSION

Platform: Windows 7 64bit & Version 3.6.0.1 (Build ID: 73f9fb6)

Regards
Pierre-Yves
Comment 1 pierre-yves samyn 2012-07-14 15:01:05 UTC
Reproduced (fr-discuss) with Windows XP SP3 3.6.0.1 (Build ID: 73f9fb6)
Comment 2 Jean-Baptiste Faure 2012-07-16 05:44:22 UTC
Reproduced on Ubuntu 11.10 x86_64 with gnome-shell.

Best regards. JBF
Comment 3 Albert Thuswaldner 2012-08-14 19:14:45 UTC
Can't reproduce this with current master. Who has fixed this?
Comment 4 pierre-yves samyn 2012-08-25 12:54:03 UTC
Hello

WORKSFORME with Version 3.6.1.2 (Build ID: e29a214) & Windows 7 64bits (& XP)

Regards
Pierre-Yves
Comment 5 pierre-yves samyn 2012-09-09 09:02:24 UTC
hello

Sorry, testing bug 54260 makes me reopen this one and I wonder if they are not related.

I don't understand, my first tests were successful but I can no longer get it

Regards
Pierre-Yves
Comment 6 Rainer Bielefeld Retired 2012-10-15 06:08:01 UTC
[Reproducible] with  "LibreOffice 3.6.3.1” German UI/ German Locale [Build-ID: f8fce0b] on German WIN7 Home Premium (64bit)

Already [Reproducible] with Server Installation of  "LibreOffice 3.6.0beta1  German UI/Locale [Build-ID: 1f1cdd8] on German WIN7 Home Premium (64bit)

Was still ok  with Server installation of Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: a502549]" (tinderbox: Win-x86@6-fast, pull time 2012-05-31 07:33:55)

I am pretty sure that tis one is related to
"Bug 55967 - EDITING: Sorts columns instead of rows"
"Bug 53482 - UI: Option 'Range contains column headings' ignored"

@Spreadsheet Team
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf (and remove others in team from CC).
Comment 7 Teo91 2014-10-02 19:56:30 UTC
No bug in LO 4.2.6 on Win7 64 Sp1. Following steps to reproduce, it works as expected, result is correct.

Set to WORKSFORME.