Bug 52100 - UI: Calc 3.5.5 borders too bold and current not visible
Summary: UI: Calc 3.5.5 borders too bold and current not visible
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.5.3 release
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 54108 56675 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-07-14 20:53 UTC by Pierre Decrocq
Modified: 2016-04-18 04:53 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
ZIp file with Calc v3.5.5 with thick borders and correct v3.5.4 UI (145.49 KB, application/zip)
2012-07-14 20:53 UTC, Pierre Decrocq
Details
A simple calc documents with differents cells border (24.81 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-09-30 09:31 UTC, Friedmann Bruno
Details
A simple calc documents with differents cells border (21.33 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-09-30 11:32 UTC, Friedmann Bruno
Details
Pdf output of bordure.ods (27.58 KB, application/octet-stream)
2014-09-30 11:33 UTC, Friedmann Bruno
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre Decrocq 2012-07-14 20:53:36 UTC
Created attachment 64219 [details]
ZIp file with Calc v3.5.5 with thick borders and correct v3.5.4 UI

Hi,

I just installer v3.5.5 and noticed the following in Calc:
- all cell borders are now too thick (bold)
- current cell can no longer be easily distinguished.

I join two screenshots of the exact same file file displayed withj v3.5.4 and v3.5.5.

Thanks for confirming and hopefully fixing this bug.

-Pierre
Comment 1 Markus Mohrhard 2012-07-15 02:00:41 UTC
The old behavior was the bug in this case. We did not really respect the border width in the old code and only differentiated between some values. A border of width 0.05 and 0.5 had the same width but was printed differently to some output formats.
Comment 2 vinschen 2012-07-24 09:09:16 UTC
Hi,

sorry for reopening, but I disagree with the notion that the new behaviour is correct.

while the new behavior may be more correct in some circumstances, it seems to be worse than the old one in others.

I don't know about the example document of the original reporter, but I have a bunch of ods documents, which use a line size of 1 pt.  While the output on the printer looks correct, the output of the same documents on the screen looks wrong.  The line width on the screen is about 1 mm, which is thrice as much as
1 pt.  Also, a line of 1 mm is awfully thick on the screen and makes a document less readable.

So, even if the new behavior is more correct, it appears that it's only more correct on the printer, while it's still wrong, just worse than before, on the screen.


Regards,
Corinna
Comment 3 Jean-Baptiste Faure 2012-07-26 07:52:13 UTC
The problem on the screen comes from anti-aliasing for graphics rendering. If you disable it, the appearance on the screen is similar to the appearance on the exported pdf.
To disable anti-aliasing for graphics rendering: menu Tools > Options > LibreOffice > View > uncheck "Use Anti-Aliasing" under "Graphics output".

@Markus: do you know if it is possible to disable anti-aliasing for cells borders only?

Best regards. JBF
Comment 4 Jean-Baptiste Faure 2012-07-26 07:53:37 UTC
According to comment 3, changing from bug to enhancement.

Best regards. JBF
Comment 5 vinschen 2012-07-26 08:49:32 UTC
Switching off anti-aliasing did it.

Thanks!
Corinna
Comment 6 Jean-Baptiste Faure 2012-07-26 09:02:50 UTC
(In reply to comment #5)
> Switching off anti-aliasing did it.
> 
> Thanks!
> Corinna

Hi Corinna,

Why did you changed platform value? the "problem" occurs not only on MS-Windows platform, but on Linux too (I did my tests on Ubuntu 11.10).

According to my comment 3, it is not a bug in cell borders code but an effect of graphics anti-aliasing. So enhancement (disable anti-aliasing for cell borders) is the right severity level.

Best regards. JBF
Comment 7 vinschen 2012-07-26 09:39:01 UTC
Hi Jean,

sorry about that.  In fact, I encountered the problem (and the solution)
on Fedora 17.  I only intended the comment as feedback, and I'm not quite
sure how I managed to screw up the platform entries at all.


Corinna
Comment 8 Stefan Schweizer 2012-10-09 06:41:58 UTC
*** Bug 54108 has been marked as a duplicate of this bug. ***
Comment 9 Stefan Schweizer 2012-10-09 06:46:07 UTC
Switching off anti-aliasing in LO makes it better but does not resolve the problem!
All lines in LO Calc are/appears generally thicker than in MS Excel even with anti-aliasing off (on Windows and Linux/Ubuntu).
Comment 10 Stefan Schweizer 2012-10-10 08:11:39 UTC
IMHO this is a bug not an enhancement. The line widths are not correctly handled by LO.
E.g.: Open a MS Excel file (.xlsx) with thin and thick lines (borders) with LO (all lines are thicker than in MS Excel) and save it again (with another file name) as MS Excel file (.xlsx). Open the file with MS Excel again and all lines are thicker in MS Excel also. Tested with latest LO version 3.6.2 (on Win 7 and Ubuntu 12.10 64bit).
Prio changed from high enhancement to high normal because this very old bug (I know of no LO version which handled the line widths correctly) is very annoying if you want to exchange files with MS Excel.
Comment 11 mwu 2012-10-24 10:40:08 UTC
Once we switch off anti-aliasing in LO ( both 3.5.7.2. and 3.6.2.2 ), then the "Page Preview" will not be viewed normally if we zoom in the preview over 120%. Hence, there is another annoyance appeared if we disable anti-aliasing for graphics rendering.

Best regards, Michael
Comment 12 Jean-Baptiste Faure 2012-11-02 13:29:50 UTC
*** Bug 56675 has been marked as a duplicate of this bug. ***
Comment 13 Kohei Yoshida 2012-11-16 02:54:12 UTC
(In reply to comment #3)
 
> @Markus: do you know if it is possible to disable anti-aliasing for cells
> borders only?

FYI, the master build (for 4.0) should disable anti-aliasing just for the cell borders.
Comment 14 Jean-Baptiste Faure 2012-11-17 15:15:59 UTC
(In reply to comment #13)
> (In reply to comment #3)
>  
> > @Markus: do you know if it is possible to disable anti-aliasing for cells
> > borders only?
> 
> FYI, the master build (for 4.0) should disable anti-aliasing just for the
> cell borders.

Indeed, I can confirm :-) Thank you very much for that.

Best regards. JBF
Comment 15 Thomas Arnhold 2013-02-10 17:53:54 UTC
Maybe related: bug #51901.
Comment 16 retired 2014-08-13 11:32:34 UTC
Can you please provide a test document so this can be tested against and subsequently be confirmed. If your document contains sensitive data, please clear that or replace it with random information.

A step-by-step description of how to reproduce the issue is most helpful and will help to speed up the processing of this problem a lot.

Setting to NEEDINFO until more detail is provided.

After providing the requested info, please reset this bug to NEW.

Also, does this persist with LO 4.3.0.4 or newer?
Comment 17 Friedmann Bruno 2014-09-30 09:31:22 UTC
Created attachment 107110 [details]
A simple calc documents with differents cells border

Made with Loo 4.3.2.2 under Windows 7 64bits
Comment 18 Friedmann Bruno 2014-09-30 11:32:13 UTC
Created attachment 107116 [details]
A simple calc documents with differents cells border

You can see a set of border made with Loo 4.3.x (.1 and .2) tested
under Linux & Windows 
with or without hardware acceleration on

Will follow attached pdf

Symptom : 
 DATA LOSS : if on line 4 you setup a double ligne with a larger < 1.5pt save and close the document, at reopen, the cells will not more have the border as setup ( shadow, content spacing and other attribute okay)
Comment 19 Friedmann Bruno 2014-09-30 11:33:33 UTC
Created attachment 107117 [details]
Pdf output of bordure.ods

Resulting printed result.

Zoom to double border cells and see how they don't stick together.
Comment 20 Friedmann Bruno 2014-09-30 11:34:15 UTC
Status and version update
Comment 21 Thomas Arnhold 2014-09-30 11:38:03 UTC
Bruno: Please never change the version. This is meant to be the version of the first observation of this bug.
Comment 22 Friedmann Bruno 2014-10-13 07:07:52 UTC
Thomas, ok for not touching the version. but then how to make it visible that under 4.3x version there's a DATA loss ?
Comment 23 Thomas Arnhold 2014-10-17 07:09:01 UTC
Bruno: Maybe open a new bug with importance critical (and link to this one here). If this is new in 4.3 then probably it has nothing to do with this bug here.
Comment 24 steve -_- 2015-08-12 12:24:11 UTC
Not sure what's up with this bug. I look at the test ods file and the PDF but where is the problem? I don't see it indicated.

Is this bug persisting with the latest nightly builds of LO?
http://dev-builds.libreoffice.org/daily/master/

For any other problems, please do create new bug reports as suggested by Thomas in comment #23.

Since I'm not 100% sure about this one, setting to NEEDINFO. So retesting with nightly would be great. After that please decide if this is fixed or still valid and new.
Comment 25 mahfiaz 2016-04-17 18:04:37 UTC
I believe the original bug was fixed long ago. Therefore I mark it as Resolved, fixed.

As for Bruno's example, the "Double line border 4" in current 5.1.2.1 looks just like "Double line border 1.5" or "Double line border 2".
But this would be bug "Double borders too narrow" not too bold as the current one is.

If you would like to report that bug, please provide test document AND screenshots pointing out exactly (red arrows, please) what is wrong.
Comment 26 Adolfo Jayme 2016-04-18 04:53:22 UTC
The “FIXED” resolution is reserved to issues closed with an explicit commit to one of our code repositories. Otherwise, please close as “WORKSFORME”.