Bug 52319 - Chart wizard freezes Calc for a long time on both initialization and cancellation.
Summary: Chart wizard freezes Calc for a long time on both initialization and cancella...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.5.3 release
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
Depends on:
Blocks: Chart-Wizard
  Show dependency treegraph
 
Reported: 2012-07-20 18:18 UTC by Johnny Baloney
Modified: 2017-04-21 14:30 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Follow the description to recreate. (412.01 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-07-20 18:18 UTC, Johnny Baloney
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johnny Baloney 2012-07-20 18:18:26 UTC
Created attachment 64459 [details]
Follow the description to recreate.

Open the attached spreadsheet.

Click on the cell E13. Now click on the chart wizard icon.

Now wait, and wait, and wait......

After the chart wizard window eventually opens the cpu will still stay busy for a considerable time and Calc will remain unresponsive. Wait for it to finish processing.

Once it's done with whatever it was doing cancel the wizard.

Now wait, and wait, and wait......

After the chart wizard window eventually closes once again the cpu will still stay busy for a considerable time and Calc will remain unresponsive.
Comment 1 billhook 2012-07-21 21:22:54 UTC
Confirmed on 3.5.5.3 WinXp Sp3

I also tried clicking on a different cell instead of E13 and had the same problem.
Comment 2 Johnny Baloney 2014-09-15 22:59:51 UTC
Still an issue in Version: 4.3.1.2.
Comment 3 QA Administrators 2015-10-14 19:57:16 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2016-01-29 14:26:06 UTC
Still an issue.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: 259c1ed201f4277d74dfd600fed8c837cbf56abc
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-01-27_00:45:12
Locale: fi-FI (fi_FI)
Comment 5 Yuri Khan 2016-12-28 12:25:18 UTC
Affects and annoys me too, version 4.2.8.2 on GNU/Linux.

Expected behavior:

* After clicking the Chart button or selecting the Insert | Object | Chart menu command, the Chart Wizard appears and is responsive immediately. The preview generation is started asynchronously or skipped altogether.

* As the user modifies settings that affect the preview, preview generation is restarted asynchronously.

* If the user clicks Finish in the Chart Wizard, preview generation is stopped and the actual chart generation starts. A Stop button is displayed; clicking it cancels chart generation.
Comment 6 Yousuf Philips (jay) (retired) 2017-04-21 14:30:03 UTC
Issue seems to be resolved.

Version: 5.2.1.2
Build ID: 31dd62db80d4e60af04904455ec9c9219178d620
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: group

Version: 5.4.0.0.alpha0+
Build ID: 44b14e8c7c485d8a3bb99d9484ac63273988b633
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-04-17_03:32:22
Locale: en-US (en_US.UTF-8); Calc: group