Bug 52395 - UI: Can not open the "Styles and Formatting" window after upgrade with existing User Profile
Summary: UI: Can not open the "Styles and Formatting" window after upgrade with existi...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.5.3 release
Hardware: x86 (IA32) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 43489
  Show dependency treegraph
 
Reported: 2012-07-23 13:28 UTC by Jan
Modified: 2018-02-26 11:23 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
LibreOffice-oud.zip (68.89 KB, image/png)
2012-07-27 08:05 UTC, Jan
Details
The original reporter's registrymodifications.xcu file, which causes the problem (deleted)
2012-08-03 13:24 UTC, Roman Eisele
Details
registrymodifications.xcu changed (deleted)
2012-10-26 21:56 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan 2012-07-23 13:28:31 UTC
I want to make a table in landscape. The first step is open the Styles and Formatting window. There are three possibilties and none of them will open this window. It is clear that I cannot go further in designing my table.

Greetings
Jan
Comment 1 Roman Eisele 2012-07-23 18:54:10 UTC
Hello Jan,

I'm sorry but I don't understand what is not working for you as expected.

I understand that you "want to make a table in landscape", OK. I suppose you mean just a table in the ordinary sense of the word, somewhere on a Writer page, similar to:

+----------+----------+----------+
|  And     |  some    |    text  |
+----------+----------+----------+
| in       |      the |  table,  |
+----------+----------+----------+
|  as you  |    like  |     it!  |
+----------+----------+----------+

Question 1): By "landscape", do you just mean a table which is wider than it's height? Or do you mean something else (e.g. a table which is rotated by 90° as compared to the normal text on the page)?

Furthermore, you say "The first step is open the Styles and Formatting window. There are three possibilties and none of them will open this window." Here I don't understand three points:

2) Why is the "first step" to create a table in landscape to open the "Styles and Formatting" window? IMHO the first step is just to select "Table > Insert > Table..." from the menu bar. Or, if there is already a table, to select "Table > Table properties" or so.

3) "There are three possibilties": what possibilities to do what? Do you mean, three possibilites to open the "Styles and Formatting" window?

4) "and none of them will open this window": which window? The "Styles and Formatting" window? Do you mean that you can't open the "Styles and Formatting" window?

Sorry for asking so incredibly dumb questions, but I really don't understand the issue -- opening the "Styles and Formatting" works fine for me in any LibO version I ever used, therefore I always think you are talking about something completely different ...

5) And a last question: Which version of LibreOffice do you use (and on what version of MacOS X)? It is very important to know this in order to help you!

Thank you very much for explaining all this stuff to a simple-minded QA volunteer ;-)
Comment 2 Jan 2012-07-25 08:49:34 UTC
Hello Roman,
I will try to answer your questions.
> what is not working for you as expected. 
Simple: I can't open the "Styles and Formatting" window.

I use an iMac Intel  Core 2 Duo, OS X 10.6.8, LibreOffice 3.5.5.3.
In a previous version of LO I could open the Styles and Formatting window.
I start by reading the Writer tutorial chapter 3 pages 102-103-104.

The 3 possibilities are:
1. menu Format click 'Styles and Formatting'
2. Cmd+T
3. in the menu bar go to the far left and click the icon 
None of the 3 opens the wanted window.

I hope that I give you some information to help you understand my problem.

Greetings

Jan



On 24 jul 2012, at 03:54, bugzilla-daemon@freedesktop.org wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=52395
> 
> Roman Eisele <bugs@eikota.de> changed:
> 
>           What    |Removed                     |Added
> ----------------------------------------------------------------------------
>             Status|UNCONFIRMED                 |NEEDINFO
>                 CC|                            |bugs@eikota.de
>     Ever Confirmed|0                           |1
> 
> --- Comment #1 from Roman Eisele <bugs@eikota.de> 2012-07-23 18:54:10 PDT ---
> Hello Jan,
> 
> I'm sorry but I don't understand what is not working for you as expected.
> 
> I understand that you "want to make a table in landscape", OK. I suppose you
> mean just a table in the ordinary sense of the word, somewhere on a Writer
> page, similar to:
Yes
> 
> +----------+----------+----------+
> |  And     |  some    |    text  |
> +----------+----------+----------+
> | in       |      the |  table,  |
> +----------+----------+----------+
> |  as you  |    like  |     it!  |
> +----------+----------+----------+
> 
> Question 1): By "landscape", do you just mean a table which is wider than it's
> height?
Yes, in A4 format landscape is the wider side horizontal
> Or do you mean something else (e.g. a table which is rotated by 90° as
> compared to the normal text on the page)?
> 
> Furthermore, you say "The first step is open the Styles and Formatting window.
> There are three possibilti

> es and none of them will open this window." Here I
> don't understand three points:
> 
> 2) Why is the "first step" to create a table in landscape to open the "Styles
> and Formatting" window? IMHO the first step is just to select "Table > Insert >
> Table..." from the menu bar. Or, if there is already a table, to select "Table
>> Table properties" or so.
> 
> 3) "There are three possibilties": what possibilities to do what? Do you mean,
> three possibilites to open the "Styles and Formatting" window?
> 
> 4) "and none of them will open this window": which window? The "Styles and
> Formatting" window? Do you mean that you can't open the "Styles and Formatting"
> window?
> 
> Sorry for asking so incredibly dumb questions, but I really don't understand
> the issue -- opening the "Styles and Formatting" works fine for me in any LibO
> version I ever used, therefore I always think you are talking about something
> completely different ...
> 
> 5) And a last question: Which version of LibreOffice do you use (and on what
> version of MacOS X)? It is very important to know this in order to help you!
> 
> Thank you very much for explaining all this stuff to a simple-minded QA
> volunteer ;-)
> 
> -- 
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
Comment 3 Roman Eisele 2012-07-25 09:46:39 UTC
(In reply to comment #2)
> I hope that I give you some information to help you understand my problem.

Yes -- thank you very much! Now I understand the issue. (I have adjusted the Summary and Version fields to reflect the problem correctly.)

An interesting issue. I can not reproduce it directly -- I am using LibreOffice 3.5.5.3 on OS X 10.6.8 (Intel), just like you, but opening the "Styles and Formatting" window works just fine for me. So we need to find out what makes the difference, i.e. why opening that window does not work for you.


A first idea to check: You wrote
> In a previous version of LO I could open the Styles and Formatting window.
Therefore, this could be an upgrade problem. Could you please try the following:

1) Open the folder "Application Support" inside of the "Library" folder in your personal home folder (i.e., /Users/<your user name/Library/Application Support/). Inside of "Application Support", there should be a folder called "LibreOffice". This folder contains all settings of LibreOffice, the User profile.

2) Please rename the folder "LibreOffice" to something else, just "LibreOffice-old" or so. This causes LibreOffice to create a brand new, fresh "LibreOffice" folder at the same place with a fresh user profile.

3) Now start LibreOffice, create a new, empty Writer (text) document, and try again if opening the "Styles and Formatting" window works now.

I hope this will help you; if not, we have to check other things.


A final note: Please do NOT answer with your e-mail client to the messages sent by bugzilla to you! For answering e.g. to *this* message, just come back to this web page
  https://bugs.freedesktop.org/show_bug.cgi?id=52395
then enter an "Additional comment" and click on "Save changes". This keeps the bug report short and clean, as we need it. Thank you!
Comment 4 Jan 2012-07-26 07:02:30 UTC
Helo Roman,
I followed your advise and it was a success. Styles and Formatting opens as a charme. Thanks for your help.

As you see I answer as you advised.

Again thanks and the bug is completed.

Greetings

Jan
Comment 5 Roman Eisele 2012-07-26 15:01:21 UTC
(In reply to comment #4)
> I followed your advise and it was a success. Styles and Formatting opens as a
> charme. Thanks for your help.

Good to hear that! This means that something with the existing User Profile went wrong, I mean, it did not work correctly anymore after the upgrade.


Therefore a final question to you, Jan:
Do you still have the old (renamed) User Profile folder (at: <your user name>/Library/Application Support/, as I wrote in step 1 and 2 of comment #2)?
It should be there parallel to the newly created "LibreOffice" folder which contains your new (and working) User Profile.

Can you please
* ZIP the complete old (renamed) User Profile folder (just select the complete folder and then choose "Compress ..." from the Finder's "File" menu)
* and then attach the ZIP file to this bug report (just click on "Add an attachment" on this page)?

It is possible that this ZIP archive will help our developers to find out what was going wrong with the user profile after the upgrade -- this may help them to prevent such annoying issues in future.

Thank you very much in advance!



> As you see I answer as you advised.

Thank you ;-) As you see, it helps to keep the bug report page short and clean.

*

I adjust the summary again to reflect our enlarged knowledge, and add this bug to our list of issues about "Incorrect behavior using existing User Profile for upgrade" (bug 43489).
Comment 6 Jan 2012-07-27 08:05:19 UTC
Created attachment 64765 [details]
LibreOffice-oud.zip

Hello Roman,
I tried to send you the map LibreOffice-oud where you have asked for.
I compressed this map to .zip but after a while I got this message in the attachment.

The contents of the map is too huge. What can I do to make it smaller?

Greetings

Jan
Comment 7 Roman Eisele 2012-07-27 17:21:34 UTC
Hello Jan,
> I tried to send you the map LibreOffice-oud where you have asked for.
> I compressed this map to .zip but after a while I got this message in the
> attachment.
> The contents of the map is too huge. What can I do to make it smaller?

Ah, sorry -- I forgot to mention that possibility (the size of the User Profile folder varies extremely, therefore in some cases ZIPing the whole folder will not work).

Well, the easiest solution is that you attach only one file (instead of the whole folder): the file "registrymodifications.xcu" from
  LibreOffice-oud/3/user/registrymodifications.xcu
should contain all the most important settings, and I hope it will be sufficient to track down this problem.

So please try to attach only this file -- it should be not that huge, so attaching it should work well. You can ZIP it before attaching it, but even that should not be necessary.

Sorry for the trouble and thank you again!
Comment 8 Jan 2012-07-29 07:43:17 UTC
Hello Roman,

I remembred that I have a Dropbox account. I used it in the past to prepare one file. As I launched Dropbox now it is possible to prepare a bunch of files. With trial and error I got this URL:

https://www.dropbox.com/sh/1gxr56qaqhc4xce/SWOxfEo4buhttps://www.dropbox.com/sh/1gxr56qaqhc4xce/SWOxfEo4bu

Use this URL and download the map LibreOffice-oud.

Please let me know what happens.

Greetings

Jan
Comment 9 Roman Eisele 2012-07-30 15:50:15 UTC
Hello Jan:

> I remembred that I have a Dropbox account. I used it in the past to prepare one
> file. As I launched Dropbox now it is possible to prepare a bunch of files.
> With trial and error I got this URL: [...]
> Use this URL and download the map LibreOffice-oud.

Thank you very much for adding the file to your Dropbox -- a very good idea! I have successully downloaded the file. Now I will inspect the data inside it and try to find the item which was responsible for the problems with the "Styles and Formatting" window. This may take some time. As soon as I get some results, I will let you know and add a comment here.

Thank you again for your continuous efforts!
Comment 10 Roman Eisele 2012-08-03 13:24:27 UTC
Created attachment 65091 [details]
The original reporter's registrymodifications.xcu file, which causes the problem

I can REPRODUCE the problem with the “registrymodifications.xcu” file from Jan’s User Profile folder: if I install it into my own LibO 3.5.x User Profile folder, no one of the usual ways (see comment #2) opens the “Styles and Formatting” window.

Therefore I attach Jan’s “registrymodifications.xcu” file to this bug report and set the status to NEW.
Comment 11 Roman Eisele 2012-08-06 09:54:45 UTC
(Forgot to change the Status field actually -- sorry!)
Comment 12 Julien Nabet 2012-10-26 21:56:48 UTC
Created attachment 69137 [details]
registrymodifications.xcu changed

On pc Debian x86-64 with master sources updated today, I reproduced the problem.
In fact, F11 works but the panel width has been reduced to almost 0.
If you observe the right side of the window typing F11 several times, you'll notice a slight difference
Then you can:
- retrieve the file I put in attachment
- try to increase manually the panel width
Comment 13 Julien Nabet 2012-10-26 21:57:44 UTC
Jan/Roman: could you give a try and tell me if it's ok or not for you?
Comment 14 Roman Eisele 2012-10-27 17:36:45 UTC
(In reply to comment #12)
> In fact, F11 works but the panel width has been reduced to almost 0.
> If you observe the right side of the window typing F11 several times, you'll
> notice a slight difference

Ah, I can confirm this! If I install Jan’s “registrymodifications.xcu” file (attachment 65091 [details]), the panel seems to be invisible/inaccessible (even if I press F11), but it is there -- at the utmost right margin of the document wind, with a minimum width. And I can actually manually increase the panel width. I must have completely missed this when reproducing this (comment #10), but I have to correct myself now. (Tested with LibreOffice 3.6.3.1 on Mac OS X 10.6.8.)

Thank you, Julien, for pointing this out! So, what would you say: is this not a bug at all, but just an unlucky setting?


Jan: can you confirm this, too?
Comment 15 Michael Meeks 2013-03-26 17:56:29 UTC
The issue is in this config item:

  <item oor:path="/org.openoffice.Office.Views/Windows/org.openoffice.Office.Views:WindowType['5539']/UserData">
    <prop oor:name="Data" oor:op="fuse" oor:type="xs:string">
      <value>V2,H,0,AL:(5,16,1/0/4/430,4;775)</value>
    </prop>
  </item>

The '4' in the 1/0/4/430... - is the width of the panel I believe; for me this is:

<prop oor:name="Data" oor:op="fuse" oor:type="xs:string">
  <value>V2,V,0,AL:(5,16,1/0/223/430,223;999)</value>
</prop>

Which seems more promising at 223 :-)

Presumably we should do some sanity checking on that size on interpreting the settings; no idea how it got that way though.
Comment 16 Michael Meeks 2013-03-26 18:16:12 UTC
Testing again adjusted with my registrymodifications.xcu matching yours on master it seems that the minimized / shrunk-to-something-very-small window is still visible on the right hand side of the screen.

As you press F11 it toggles the show/hide of that (admittedly already very thin - but visible) side-bar - which is surely notice-able: on Linux at least the grip is quite clear.

Having said that, looking at the code that implements this in:

unotools/source/config/viewoptions.cxx

It seems Stephan fixed something rather similar there:

commit 9db74c6133ede2a28af077fd563398176ff0d858
Author: Stephan Bergmann <sbergman@redhat.com>
Date:   Fri Oct 5 15:00:39 2012 +0200

    fdo#46071: Do not hide windows based on nil "Visible" property
    
    This appears to be messy:  The /org.openoffice.Office.Views/WindowType
    configuration group template has both a nilable bool "Visible" property and a
    UserData/Data string property that encodes various things like geometry---but
    also visibility---in a string.


in recent times.

Please do re-open if you can reproduce on Mac still; there could perhaps be a Mac specific reason why theming hides this on Mac (if there is no grip there perhaps).

Otherwise -> worksforme.
Comment 17 Xisco Faulí 2018-02-26 11:23:32 UTC
The content of attachment 65091 [details] has been deleted
Comment 18 Xisco Faulí 2018-02-26 11:23:55 UTC
The content of attachment 69137 [details] has been deleted