Bug 53095 - VIEWING: Scroll really laggy when open big xls file.
Summary: VIEWING: Scroll really laggy when open big xls file.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.5.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: haveBacktrace, perf
: 62087 (view as bug list)
Depends on:
Blocks: Scrolling-PageUpDown
  Show dependency treegraph
 
Reported: 2012-08-03 11:38 UTC by Pavel Chernyak
Modified: 2021-09-21 17:08 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
File that have this problem. (2.75 MB, application/vnd.ms-excel)
2012-08-03 11:38 UTC, Pavel Chernyak
Details
repro document multiple invisible graphic objects (991.50 KB, application/vnd.ms-excel)
2017-12-07 05:57 UTC, XTR
Details
Perf flamegraph (3.65 MB, image/svg+xml)
2019-04-18 19:17 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Chernyak 2012-08-03 11:38:15 UTC
Created attachment 65089 [details]
File that have this problem.

Problem description: 

Steps to reproduce:
1. Open attached file.
2. Try to scroll... 
3. View become very laggy. 

Current behavior:
Scrolling very laggy. 
Expected behavior:
All run smooth and fast. 
Platform (if different from the browser): 

ArchLinux x86_64.               
Browser: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/536.11 (KHTML, like Gecko) Chrome/20.0.1132.57 Safari/536.11
Comment 1 Daniil Bratashov 2012-08-03 11:51:11 UTC
Confirmed for sheets 1,3,4 on LOdev 3.6rc1 win32.
Comment 2 polter 2012-08-03 12:05:43 UTC
Confirmed on LibreOffice 3.5.4.2 build 350m1 on Ubuntu 12.04.
Comment 3 Valek Filippov 2012-08-03 13:31:35 UTC
Markus,
this file has 300+ MsoDrawings and huge sequence of TxO/Continue/Obj records.

Confirmed with 3.6.1.0+ (Build ID: 41306f2) on linux x86.
Comment 4 Valek Filippov 2012-08-03 13:42:08 UTC
On saving gnumeric converts Tx0/Continue/Obj to MsoDrawing records.
Performance of the LO Calc with resaved document is way better.
Comment 5 Eike Rathke 2012-08-03 14:13:38 UTC
On the first sheet in cells A7 and A127 there appear to be a gazillion of identical empty text boxes pasted one over the other. I assume that if you delete them all the sheet scrolls fine again.
Comment 6 Thomas Arnhold 2013-05-01 02:15:36 UTC
*** Bug 62087 has been marked as a duplicate of this bug. ***
Comment 7 QA Administrators 2015-03-04 02:23:48 UTC Comment hidden (obsolete)
Comment 8 Pavel Chernyak 2015-03-04 08:06:38 UTC
Problem still exists in 4.4.1.2
OS: Linux(Arch Linux)
Comment 9 tommy27 2016-04-16 07:25:47 UTC Comment hidden (obsolete)
Comment 10 Pavel Chernyak 2016-11-28 23:42:12 UTC
LibreOffice 5.2.3.3. 
Problem still exists, but i don't know how import it is.
Comment 11 XTR 2017-12-07 05:54:50 UTC
Did minimized version of repro file
There are mupliple (~5k) invisible graphic objects (text boxes), so may be this bug related to other bugs about multiple graphic objects processing

Still repro with
LO  6.0.0.0.beta1 (x64)  97471ab4eb4db4c487195658631696bb3238656c  windows 7
Comment 12 XTR 2017-12-07 05:57:02 UTC
Created attachment 138259 [details]
repro document  multiple invisible graphic objects
Comment 13 QA Administrators 2018-12-08 03:47:12 UTC Comment hidden (obsolete)
Comment 14 Buovjaga 2019-04-18 19:17:37 UTC
Created attachment 150859 [details]
Perf flamegraph

Taken from scrolling attachment 138259 [details]

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: 1fee3f1da6291bfbcd75455512726215d41b3e83
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 18 April 2019
Comment 15 QA Administrators 2021-04-18 03:48:33 UTC Comment hidden (obsolete)
Comment 16 Buovjaga 2021-05-03 12:36:01 UTC
Still a bit laggy

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 9c930c4f3109d123c0831d0fcecf9c8b32e5bbc7
CPU threads: 2; OS: Windows 10.0 Build 19042; UI render: default; VCL: win
Locale: fi-FI (fi_FI); UI: en-US
Calc: threaded
Comment 17 Roman Kuznetsov 2021-09-21 14:29:26 UTC
Looks fine in

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 47a8a65022e3fd7624c95d0341b4809aad11fddb
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: threaded

I suggest just close it now (and we know the root of the problem - unneeded empty shapes). Buovjaga?
Comment 18 Buovjaga 2021-09-21 17:08:29 UTC
Yeah, doesn't seem laggy at the moment

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: e7a40c0ded1ba26b6b8f3da5a0b894e9c7ee7a96
CPU threads: 8; OS: Linux 5.14; UI render: default; VCL: kf5 (cairo+xcb)
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded