Bug 53123 - FILEOPEN: DOC: import misses field contains several pages of references - see comment 5
Summary: FILEOPEN: DOC: import misses field contains several pages of references - see...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.5.2 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc
Depends on:
Blocks: DOC-Fields
  Show dependency treegraph
 
Reported: 2012-08-04 14:53 UTC by Ron Wolf
Modified: 2019-06-10 09:23 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
the offending document (1.38 MB, application/msword)
2012-08-04 14:53 UTC, Ron Wolf
Details
the original doc (1.32 MB, application/msword)
2012-08-12 08:31 UTC, Ron Wolf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ron Wolf 2012-08-04 14:53:59 UTC
Created attachment 65123 [details]
the offending document

I open a .doc sent to me from a MS Word user. Its 26 pages long and looks fine. I make some minor edits (word replacements mostly), the .doc still looks fine and is still 26 pages long. I save the .doc (using the MSWord ...2003 option) and then reload it. Now, the page count shows as 92 and starting midway thru page 8, beginning with "ADDIN EN.CITE ..." the document now displays what I assume is its underlying XML format. This has happened several times in editing this document. Yes, I've rebooted and reviewed, still a mess. Interestingly, viewing the document in Word, it looks fine.
Comment 1 Urmas 2012-08-06 00:54:55 UTC
This document appears corrupted. Could you attach the original one?
Comment 2 Ron Wolf 2012-08-12 08:31:22 UTC
Created attachment 65453 [details]
the original doc

the original doc as sent to me from the MS-Word using author before i made any changes to it using OpenOffice. at least for me, this doc opens and views just fine using OpenOffice.
Comment 3 A (Andy) 2012-12-25 23:40:42 UTC
The problems are only partly reproducible with LO 3.6.4.3. (Win7 Home, 64bit).  This issue has to be analysed more deeply.

I opened the original document and changed a word and afterwards have saved it as a .doc file.
It saves the file, but with an error message "Warning saving the document XYZ: Write Error. All changes to the Basic Code are lost.The original VBA Macro Code is saved instead."  If you reopen it, then it will be opened without an error message and has still 26 pages like before.
But there is in addition another bug.  If you open the original document in Excel 2007 then it has 35 pages, but if you open it in LO then it has only 26 pages, because the list of references is missing.
Comment 4 QA Administrators 2015-01-05 17:52:14 UTC Comment hidden (obsolete)
Comment 5 Buovjaga 2015-01-29 16:41:38 UTC
(In reply to A (Andy) from comment #3)
> But there is in addition another bug.  If you open the original document in
> Excel 2007 then it has 35 pages, but if you open it in LO then it has only
> 26 pages, because the list of references is missing.

Confirmed missing pages compared to Word 2013.

Win 8.1 32-bit
MSO 2013

LibreOffice Version: 4.5.0.0.alpha0+
Build ID: 784d069cc1d9f1d6e6a4e543a278376ab483d1eb
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-25_23:07:36
Comment 6 QA Administrators 2016-02-21 08:37:22 UTC Comment hidden (obsolete)
Comment 7 Justin L 2017-09-06 03:12:12 UTC
There is something really bizarre about those references. In MS Word, I right-click somewhere and can update field (a safe operation) or edit field.  If I edit field, and then hit OK, everything vanishes and it looks like LO's 26 page document.
Comment 8 QA Administrators 2018-10-18 02:50:11 UTC Comment hidden (obsolete)
Comment 9 Cor Nouws 2019-02-05 17:55:23 UTC
(In reply to Justin L from comment #7)
> There is something really bizarre about those references. In MS Word, I
> right-click somewhere and can update field (a safe operation) or edit field.
> If I edit field, and then hit OK, everything vanishes and it looks like LO's
> 26 page document.

So there is a corrupt document?
Let's close as NotOurBug then.
Comment 10 Cor Nouws 2019-06-10 09:23:43 UTC
(In reply to Cor Nouws from comment #9)
> So there is a corrupt document?
> Let's close as NotOurBug then.
Doing so now.