Bug Hunting Session
Bug 53228 - [Task]: FILEOPEN .ods / .ots spreadsheet from former LibO version or OOo shows graphic elements at wrong position
Summary: [Task]: FILEOPEN .ods / .ots spreadsheet from former LibO version or OOo show...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: Other All
: highest major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 37083 48272 53229
Blocks: mab4.2
  Show dependency treegraph
 
Reported: 2012-08-08 05:22 UTC by Rainer Bielefeld Retired
Modified: 2014-12-07 20:09 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file with issue (27.49 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-08-01 11:34 UTC, putt1ck
Details
Sample of sheet 1 with lines in place (249.46 KB, application/pdf)
2014-08-02 09:46 UTC, putt1ck
Details
Spreadsheet with graphics elements as shown with LibreOffice 4.3.1 (124.45 KB, image/png)
2014-09-23 08:13 UTC, Mau
Details
Spreadsheet with graphics elements as shown with OpenOffice.org 3.4.1 (153.89 KB, image/png)
2014-09-23 08:14 UTC, Mau
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-08-08 05:22:59 UTC
This is the Meta issue to track Spreadsheet (ODF?) compatibility issues of
LibreOffice 3.4 and later concerning position of graphic elements like form fields, Drawings, pictures, fontwork and similar objects in documents created with OOo or LibO 3.3.0

Additionally please add all regressions concerning graphic position issues.

This Meta Bug is not for 
- compatibility issues for import / export from/to other document formats 
  like .xls
- Wrong rendering of spreadsheets created with current LibO Versions with 
  other spreadsheet programs

If anyone wants to list Bug here, please add the Bug ID as
dependent Bug here to the Meta Bug in field "Depends on". Additionally please
cite the Subject line of the Bug. Please check carefully whether the problem
has already been reported with a separate Bug.

Add: "Bug 48272 - FILEOPEN documents created with OOo: VIEWING pictures and objects with wrong hight and at wrong vertical position"

Add (fixed): "Bug 37083 - Position and Size change for picture anchored to cell"
Comment 1 Rainer Bielefeld Retired 2012-08-08 05:38:20 UTC
Add "Bug 53229 - FILEOPEN particular .ods from LibO 3.0.0 shows grouped form fields at wrong horizontal position"
Comment 2 Rainer Bielefeld Retired 2012-08-08 05:52:14 UTC
Add "Bug 53230 - FILEOPEN particular .ods from LibO 3.0.0 shows all form fields at wrong horizontal position".
Comment 3 Jorendc 2013-12-29 13:49:29 UTC
Lets close this bug tracker. Not used in past +1 year. If bugs related to this issue shows up en-masse again, we can reopen this.
Comment 4 putt1ck 2014-08-01 11:34:40 UTC
Created attachment 103814 [details]
Sample file with issue

Attached a file which demonstrates this issue. As this is from a heritage organisation using OpenDocument *because as a standard it's good for long term data storage* the loss of information exhibited should be considered a critical bug.

This file was created in an earlier version of LO or OO (can confirm version if necessary). It opens fine in Calligra Sheets. In Calc 4.1.6 (Windows, openSUSE) & 4.3 (LO RPM) most of the lines drawn to indicate relationships between cell data appear all top left of the sheet they belong to.
Comment 5 putt1ck 2014-08-02 09:46:28 UTC
Created attachment 103858 [details]
Sample of sheet 1 with lines in place

This is a PDF export from Calligra Sheets 2.8.0 with the lines more or less as they were placed by the spreadsheet creator. NB due to the nature of the document you might have to zoom in quite a lot
Comment 6 Joel Madero 2014-08-04 20:47:02 UTC
REOPENED is reserved for a bug that:

1. a developer has marked as FIXED;
2. a developer is assigned to the bug that is marked as FIXED;

In this case the bug report was never independently confirmed so correct status is NEW as it was previously confirmed.
Comment 7 Mau 2014-09-23 08:13:27 UTC
Created attachment 106711 [details]
Spreadsheet with graphics elements as shown with LibreOffice 4.3.1
Comment 8 Mau 2014-09-23 08:14:18 UTC
Created attachment 106712 [details]
Spreadsheet with graphics elements as shown with OpenOffice.org 3.4.1
Comment 9 Mau 2014-09-23 08:15:11 UTC
LO 4.3.1-1 on Debian testing/sid here - just discovered that an old spreadsheet created with OOo 2.0 (last saved 05.20.2006) with graphics elements (mostly arrows) shows badly: all the arrows are in a bunch at upper left corner; please see attachments.

Thanks
Comment 10 tommy27 2014-12-07 20:09:49 UTC
@puttick @mau

this was a meta bug, which is a "collection" of links to other bug reports about a similar issue.

so don't upload files inside this one but rather open new separate bug reports.

anyway at the moment I think that there's no need yet for another metabug like this one, which eventually collected just 3 bugs and all of them are already in FIXED state (Bug 37083, Bug 48272, Bug 53229) 

so I'm closing this one and marking as RESOLVED FIXED

again, please open new reports about your issues and remember you don't have to upload again the files but you can just cite them with their attachment number (i.e. attachment 103814 [details] etc. etc.)