Bug Hunting Session
Bug 53241 - The extension is .man instead of .msi in the downloadable files for Windows
Summary: The extension is .man instead of .msi in the downloadable files for Windows
Status: RESOLVED MOVED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 49726 51426 88913 103505 112266 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-08-08 12:16 UTC by Zoltán Hegedüs
Modified: 2017-09-07 22:01 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
What I see on the display. (190.75 KB, image/pjpeg)
2012-08-09 18:55 UTC, Zoltán Hegedüs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zoltán Hegedüs 2012-08-08 12:16:57 UTC

    
Comment 1 Zoltán Hegedüs 2012-08-08 12:20:02 UTC
I tried both in libreoffice.hu and libreoffice.org.
I examined the Main Installer and the SDK.
Maybe the extension is .msi in the web server, but .man at me.
By the way, the Hungarian server is very-very slow: 17 KB/s: 3 hour at the Main Installer.
Comment 2 Andras Timar 2012-08-09 16:52:19 UTC
You failed to understand what I wrote you on libreoffice.hu. I try to explain once more. When you initiate a download, you are redirected to a mirror. It is neither libreoffice.hu, nor libreoffice.org. Please find out what mirror you use. Browsers usually display this information. E.g. in Firefox you can copy the source link, e.g. http://mirror.lnx.sk/tdf/libreoffice/stable/3.6.0/win/x86/LibO_3.6.0_Win_x86_install_multi.msi
Comment 3 Zoltán Hegedüs 2012-08-09 18:54:38 UTC
(In reply to comment #2)

mirror.arlug.ro
http://hu.libreoffice.org/letoeltes
Click to the text in the green boxes "Fő telepítőkészlet" or "LibreOffice Súgú" or "Software development kit (SDK)".
At me, the mirror is always mirror.arlug.ro, and the extension is always .man istead of .msi (at the Windows Installers).
I you use other than Windows, in the website
http://hu.libreoffice.org/letoeltes
first click to the text "Rendszer. verzió vagy nyelv váltása".
By the way, in this text, a comma is required instead of a point.

Or in the website
http://www.libreoffice.org/download/
If you use other than Winodws, click to "Change System, Version or Language"
Click to "Main Installer" in a green box.
The mirror is mirror.arlug.ro, and the extension is .man.

See the attachment.
Comment 4 Zoltán Hegedüs 2012-08-09 18:55:21 UTC
Created attachment 65353 [details]
What I see on the display.
Comment 5 Andras Timar 2012-08-10 08:43:26 UTC
mirror.arlug.ro contains msi files, see:
http://mirror.arlug.ro/pub/tdf/libreoffice/stable/3.6.0/win/x86/

It is a problem with Internet Exporer.
http://serverfault.com/questions/40971/stop-ie8-renaming-files-to-zip-when-downloading
http://answers.microsoft.com/en-us/ie/forum/ie9-windows_7/downloading-an-msi-file-renames-it-man-really/590868e5-d0a4-4815-99b9-667a097340a3?msgId=e4ec196b-9b41-49a4-999a-cf6d9e6fa5c3

So, you can deactivate this behavior in Internet Explorer 8:

    Internet Options -> Security Settings
       "Custom Level" -> Miscellaneous section: 
       Open files based on content, not file extension

Even better, all mirrors should set the correct mimetype for msi:

    AddType application/octet-stream .msi

@floeff: can you please notify mirror admins?
Comment 6 Florian Effenberger 2012-08-10 11:20:21 UTC
Just did so, thanks for notifying!
Comment 7 Florian Effenberger 2013-07-01 18:44:40 UTC
Closing as resolved. Please reopen if problem occurs again.
Comment 8 Aron Budea 2016-10-25 21:43:18 UTC
*** Bug 103505 has been marked as a duplicate of this bug. ***
Comment 9 Mike Kaganski 2017-05-22 06:13:47 UTC
The problem is not with IE. It's with out mirrors actually.

Testing the list of mirrors (http://download.documentfoundation.org/libreoffice/stable/5.3.3/win/x86/LibreOffice_5.3.3_Win_x86.msi.mirrorlist) with online header inspection tool (https://httpstatus.io/) that shows response headers (in balloon tooltips), I see that most mirrors report Content-Type: application/octet-stream or application/x-msdownload or application/x-msi. However, the following mirrors report other types:

text/plain (optionally with different charsets):
http://ftp.novell.hu/pub/mirrors/tdf/libreoffice/stable/5.3.3/win/x86/LibreOffice_5.3.3_Win_x86.msi
http://mirror.7he.at/pub/tdf/libreoffice/stable/5.3.3/win/x86/LibreOffice_5.3.3_Win_x86.msi
http://ftp.nluug.nl/office/libreoffice/libreoffice/stable/5.3.3/win/x86/LibreOffice_5.3.3_Win_x86.msi
http://ftp.ussg.indiana.edu/tdf/libreoffice/stable/5.3.3/win/x86/LibreOffice_5.3.3_Win_x86.msi

application/x-troff-man:
http://mirror.in2p3.fr/ftp/tdf/libreoffice/stable/5.3.3/win/x86/LibreOffice_5.3.3_Win_x86.msi
http://mirror.ibcp.fr/pub/tdf/libreoffice/stable/5.3.3/win/x86/LibreOffice_5.3.3_Win_x86.msi
http://speglar.simnet.is/tdf/libreoffice/stable/5.3.3/win/x86/LibreOffice_5.3.3_Win_x86.msi
http://mirror.library.ucy.ac.cy/tdf/libreoffice/stable/5.3.3/win/x86/LibreOffice_5.3.3_Win_x86.msi
http://mirror.rise.ph/tdf/libreoffice/stable/5.3.3/win/x86/LibreOffice_5.3.3_Win_x86.msi
http://mirror.nbtelecom.com.br/tdf/libreoffice/stable/5.3.3/win/x86/LibreOffice_5.3.3_Win_x86.msi
http://mirror.nexcess.net/tdf/libreoffice/stable/5.3.3/win/x86/LibreOffice_5.3.3_Win_x86.msi
http://ftp.wayne.edu/tdf/libreoffice/stable/5.3.3/win/x86/LibreOffice_5.3.3_Win_x86.msi

I don't know if there's a way to force mirrors to have proper Content-Type; at least, maybe we could filter our mirror list to exclude those with bad types. The problem continues to hit quite a number of users, as may be seen at ask.libreoffice.org site.
Comment 10 Mike Kaganski 2017-05-22 07:19:56 UTC
*** Bug 103505 has been marked as a duplicate of this bug. ***
Comment 11 Mike Kaganski 2017-05-22 07:23:10 UTC
*** Bug 88913 has been marked as a duplicate of this bug. ***
Comment 12 Mike Kaganski 2017-05-22 07:25:24 UTC
*** Bug 51426 has been marked as a duplicate of this bug. ***
Comment 13 Mike Kaganski 2017-05-22 07:25:48 UTC
*** Bug 49726 has been marked as a duplicate of this bug. ***
Comment 14 Mike Kaganski 2017-09-07 08:51:25 UTC
*** Bug 112266 has been marked as a duplicate of this bug. ***
Comment 15 Aron Budea 2017-09-07 22:01:41 UTC
Moved to redmine: https://redmine.documentfoundation.org/issues/2358