Download it now!
Bug 53253 - REPORTBUILDER: Automatic page break destroys details group
Summary: REPORTBUILDER: Automatic page break destroys details group
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.4.5 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Database-Reports-Builder
  Show dependency treegraph
 
Reported: 2012-08-08 15:32 UTC by Rainer Bielefeld Retired
Modified: 2019-06-26 14:20 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-08-08 15:32:50 UTC
Steps how to reproduce with Server Installation of  "LibreOffice 3.6.0.4  German UI/Locale [Build-ID:  932b512] on German WIN7 Home Premium (64bit):

1. Download Attachment 56260 [details] from "Bug 45338 - EDITING ReportBuilder: 
   'Details - General Keep Together' without visible effect"
2. Open Sample document from LibO Start Center
3. In Database pane click "Reports"
4. In Reports pane dobule click only available report
   > Report will be created.
   If you have A4 Page size with 20mm margin all around record 19 "Eike"
   will exceed page bottom
   Expected: Yellow record end bar willbe below all record data
  Actual:  Yellow record end bar is below Record ID, Name is below yellow bar
Comment 1 Rainer Bielefeld Retired 2012-08-08 15:37:56 UTC
Already [Reproducible] with "LibreOffice 3.4.5 German UI [Build ID: OOO340m1 (Build:502)]" parallel Server installation on German WIN7 Home Premium (64bit), see Record No 29 where all contents is below yellow bar.
Comment 2 Jochen 2012-08-30 11:13:43 UTC
I can confirm the behavior ("wrong layout")
OS: Windows 7 64 bit
LO: 3.5.5
Comment 3 Alex Thurgood 2015-01-03 17:41:15 UTC Comment hidden (no-value)
Comment 4 QA Administrators 2016-01-17 20:04:53 UTC Comment hidden (obsolete)
Comment 5 Robert Großkopf 2016-01-31 14:54:31 UTC
Bug still exists with LO 5.1.0.3, OpenSUSE 42.1 Leap, 64bit rpm Linux.

Would be the same reason as described in bug87430. The shape is anchored to the first paragraph of the Detail-section. The shape ignores the footer or any margin at the bottom of the page. It will be placed in the footer or in the margin, not on the next page together with the textfield of the Detail-section.
Comment 6 QA Administrators 2017-03-06 15:58:07 UTC Comment hidden (obsolete)
Comment 7 Robert Großkopf 2017-03-08 18:55:28 UTC
Bug still exists with LO 5.3.1.1, OpenSUSE 42.1 Leap, 64bit rpm Linux.
Comment 8 QA Administrators 2018-06-25 02:40:40 UTC Comment hidden (obsolete)
Comment 9 Robert Großkopf 2018-06-25 14:55:28 UTC
Bug still exists with LO 6.0.5.2, OpenSUSE 42.3 Leap, 64bit rpm Linux.
Comment 10 QA Administrators 2019-06-26 02:45:54 UTC Comment hidden (obsolete)
Comment 11 Robert Großkopf 2019-06-26 14:20:00 UTC
Bug still exists on LO 6.2.4.2, OpenSUSE 15 64bit rpm Linux