Download it now!
Bug 53301 - Bar Chart data series have reversed order as the legend items
Summary: Bar Chart data series have reversed order as the legend items
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 56655 111402 118051 (view as bug list)
Depends on:
Blocks: Chart-Legends
  Show dependency treegraph
 
Reported: 2012-08-09 14:56 UTC by bureautiquelibre
Modified: 2018-12-11 08:30 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
example of bar chart with legend in reverse order (13.79 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-08-09 15:01 UTC, bureautiquelibre
Details
Example compared before and after the fix (70.78 KB, image/jpeg)
2018-12-10 11:04 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bureautiquelibre 2012-08-09 14:56:06 UTC
The legend appears to be in the reverse order than the bars.
Comment 1 bureautiquelibre 2012-08-09 15:01:15 UTC
Created attachment 65348 [details]
example of bar chart with legend in reverse order
Comment 2 Adam 2012-11-02 20:07:03 UTC
*** Bug 56655 has been marked as a duplicate of this bug. ***
Comment 3 Xisco Faulí 2016-09-10 22:59:05 UTC
Issue still reproducible in

Version: 5.3.0.0.alpha0+
Build ID: dcc56d663059b3baced58e34bb8186a05ceadf53
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 4 Timur 2017-06-23 15:51:38 UTC Comment hidden (obsolete)
Comment 5 Timur 2017-06-23 16:03:11 UTC
Annoying default behavior as with this example: http://seabright.co.nz/2011/05/25/basic-gantt-charts-using-libreoffice-calc-charts/. 
Looks like inherited from OO. Both Writer and Calc.

Partial workaround (from Bug 75475): 
edit chart, open X-axis, tab Scale, reverse direction.
However, this puts the x-axis at the top of the chart.
Comment 6 Timur 2017-08-08 09:04:13 UTC
*** Bug 111402 has been marked as a duplicate of this bug. ***
Comment 7 Mark from Australia 2017-10-17 22:13:35 UTC
This bug is caused when the Legend position is changed. I can get the Legend order to reverse if I position it to left or right, but top seems to restore the correct order. This behaviour is noted by others here: https://ask.libreoffice.org/en/question/79350/chart-legend-suddenly-reversed/
Comment 8 Mark from Australia 2017-10-17 22:17:13 UTC Comment hidden (obsolete)
Comment 9 Buovjaga 2018-06-22 14:04:58 UTC
*** Bug 118051 has been marked as a duplicate of this bug. ***
Comment 10 Balázs Varga 2018-12-09 13:43:48 UTC
Probably could help here.

Balazs Varga committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/40144617ce05d7eff86eeb8a412c6991fe0b819e%5E%21

tdf#114163 Chart: fix order of legend names

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Timur 2018-12-10 11:04:17 UTC
Created attachment 147416 [details]
Example compared before and after the fix

It is consistent now.