Download it now!
Bug 53595 - FILEOPEN SVG: invalid code concerning "end tag for font-face"
Summary: FILEOPEN SVG: invalid code concerning "end tag for font-face"
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL: http://www.bielefeldundbuss.de/bilder...
Whiteboard: Confirmed:4.2.0.0.beta1:Ubuntu
Keywords:
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2012-08-16 15:33 UTC by Rainer Bielefeld Retired
Modified: 2020-03-24 07:33 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document (26.20 KB, image/svg+xml)
2012-08-16 15:33 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-08-16 15:33:42 UTC
Created attachment 65655 [details]
Sample document

Found that with Server Installation of  "LibreOffice 3.6.0.4  German UI/Locale [Build-ID:  932b512] on German WIN7 Home Premium (64bit), a particular .svg I created for use in a HMI application did not show Characters in the HMI editor, although the characters ("T" and "Y") are visible in Seamonkey browser, what seems more tolerant. 

Diagnosis of HMI Editor supplier IniNet: "Invalid Code concerning font", what seems to be underpinned by W3.org validator.

Directly from a.M. sample document source URL you can do your own validation at <http://www.bielefeldundbuss.de/bilder/HK_3x_c_selection.svg>
Comment 1 Robinson Tryon (qubit) 2013-11-24 23:24:46 UTC
CONFIRMED on LO Version: 4.2.0.0.beta1 + Ubuntu 12.04.3

Opening attached SVG in FF25 shows an image with text. Opening image in LO Version: 4.2.0.0.beta1 shows same image, but without text characters.

OS -> All
Status -> NEW
Comment 2 QA Administrators 2015-04-19 03:21:12 UTC Comment hidden (obsolete)
Comment 3 Buovjaga 2015-06-15 19:37:19 UTC
Yep, chars still missing.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 01a189abcd9a4ca472a74b3b2c000c9338fc2c91
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-14_07:46:28
Locale: fi-FI (fi_FI)
Comment 4 QA Administrators 2017-05-22 13:40:34 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2019-12-03 14:05:08 UTC Comment hidden (obsolete)
Comment 6 Aron Budea 2020-03-24 07:33:13 UTC
I can see the missing characters in 7.0.0.0.alpha0+ (9d7fdcd6b5c7b5a9fe781bb99b135fba7d04ddec), they're there since 6.1.0.3. Closing as WFM.