Bug 53682 - Merge Insert > Picture > From file... and Insert > Video and Audio...
Summary: Merge Insert > Picture > From file... and Insert > Video and Audio...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: All All
: low enhancement
Assignee: Samuel Mehrbrodt (CIB)
URL:
Whiteboard: target:4.4.0
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-18 17:46 UTC by Stefan Knorr (astron)
Modified: 2015-05-02 12:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Knorr (astron) 2012-08-18 17:46:28 UTC
Despite pictures and video/audio being very similar, there are currently two separate menu entries for these types of media in the insert menu. We could combine those two to Insert > Media... to simplify the menu.
Comment 1 Julien Nabet 2012-08-19 09:12:01 UTC
So it doesn't seem a bug but rather an enhancement proposal.
astron: you may post on the forum http://nabble.documentfoundation.org/UX-Advise-f3619688.html about this tracker
Comment 2 Joel Madero 2012-12-11 16:22:31 UTC
I'm going to mark this as NEW as it is a valid request, now if we implement it depends on the discussion by UX. 

@UX team - if you decide that we will not do this one, can you close this as WONTFIX?

Marking:
New (Confirmed)
Enhancement (as stated, not a bug)
Low(doesn't really add much, just makes the menu a little simpler)


ProposedEasyHack

@Devs - please don't implement this until UX team has said go ahead or if you do, before submitting please check in with UX team
Comment 3 Stefan Knorr (astron) 2012-12-11 16:45:52 UTC
(comment 2)
> @UX team - if you decide that we will not do this one, can you close this as
> WONTFIX?

Joel, I am one of the UX guys, and we brought this idea up during one of our weekly chats.
Comment 4 Joel Madero 2012-12-12 05:16:46 UTC
lol Astron, I know you are part of the UX team ;) I think I just was burned out going through bugs my mistake! I'm sure you all have it under control :) Doing this seems incredibly simple, maybe I'll tackle it in the coming weeks
Comment 5 Jorendc 2013-03-20 15:58:53 UTC
What about the "Scan" menu entry? (Insert > Picture > Scan ) ? I do agree with the point of view of a merged "Media..." menu entry.

Kind regards,
Joren
Comment 6 Joel Madero 2013-09-25 14:15:34 UTC
Okay, taking this one. Will also merge scan into it
Comment 7 Joel Madero 2014-02-27 22:55:20 UTC
In order to limit the confusion between ProposedEasyHack and EasyHack and to make queries much easier we are changing ProposedEasyHack to NeedsDevEval.

Thank you and apologies for the noise
Comment 8 Commit Notification 2014-09-27 14:43:28 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=18ec913e413b05a44bbe79768f538d93bffa9e5d

fdo#53682 Merge 'Insert Image' and 'Insert Audio/Video' in submenu



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.