Bug 53843 - FORMATTING: The line spacing inside table cells does not affect the last line (causing wrong cells' height)
Summary: FORMATTING: The line spacing inside table cells does not affect the last line...
Status: VERIFIED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 82112 (view as bug list)
Depends on:
Blocks: Writer-Tables
  Show dependency treegraph
 
Reported: 2012-08-20 12:47 UTC by Lekow
Modified: 2021-08-23 09:01 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Archive with example .DOC file with different line spacing in two tables and screenshots from MSO 2007 and LO 3.6 (30.16 KB, application/zip)
2012-08-20 12:47 UTC, Lekow
Details
line_spacing_example.doc (29.00 KB, application/vnd.ms-word)
2018-06-26 08:03 UTC, Timur
Details
line_spacing_compare.jpg (116.65 KB, image/jpeg)
2018-06-26 08:04 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lekow 2012-08-20 12:47:22 UTC
Created attachment 65834 [details]
Archive with example .DOC file with different line spacing in two tables and screenshots from MSO 2007 and LO 3.6

When changing the line spacing for text inside table cells in MS office, the height of cells is also always changed. Even in the case of 1 line per cell.
The LibreOffice 3.6.0 shows another behavior: line height (e.g. 1.5) is applied to the text but in the case of 1-line cell content this does not affect the cell height. If the cell contains several lines, then spacing between them is increasing properly, but last line does not have spacing after it.
In long documents with a lot of tables such behavior causes significant differences in text length in different editors.
Example and screenshots are in the attachment.
Comment 1 Buovjaga 2014-11-06 12:00:23 UTC
Confirmed.

Win 7 64-bit Version: 4.4.0.0.alpha1+
Build ID: 8b21b5cbe78945b27525b4ce78ae3d981f90590f
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-06_03:55:51
Comment 2 Cor Nouws 2015-03-02 21:32:35 UTC Comment hidden (obsolete)
Comment 3 Cor Nouws 2015-03-02 21:36:14 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2015-04-01 16:06:54 UTC
(In reply to Cor Nouws from comment #3)
> (In reply to Cor Nouws from comment #2)
> > Has this ever been handled correct by LibreOffice ??
> 
> And maybe it is correct - conform file specifications - and MsOffice opens
> it wrong?

I don't know, but the rendering is the same in MSO 2013 as with 2007.
The difference persists in 4.5 alpha.

Win 8 32-bit
MSO 2013
LibreOffice Version: 4.5.0.0.alpha0+
Build ID: 4dde5a623d563f9007dd3539b835489a27128d65
TinderBox: Win-x86@42, Branch:master, Time: 2015-04-01_11:40:51
Locale: fi_FI
Comment 5 tommy27 2016-04-16 07:26:06 UTC Comment hidden (obsolete)
Comment 6 Timur 2017-03-06 19:55:55 UTC
*** Bug 82112 has been marked as a duplicate of this bug. ***
Comment 7 QA Administrators 2018-06-26 02:42:51 UTC Comment hidden (obsolete)
Comment 8 Timur 2018-06-26 08:03:39 UTC
Created attachment 143125 [details]
line_spacing_example.doc
Comment 9 Timur 2018-06-26 08:04:21 UTC
Created attachment 143126 [details]
line_spacing_compare.jpg

Same behavior in 6.2+.
Comment 10 QA Administrators 2019-06-27 02:53:54 UTC Comment hidden (obsolete)
Comment 11 QA Administrators 2021-06-27 04:19:53 UTC Comment hidden (obsolete)
Comment 12 BogdanB 2021-08-23 07:40:56 UTC
Please retest. It is working for me in
Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 5b025285b3528910a4360899abb2bbbaadc72c97
CPU threads: 4; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded

Also in
Version: 7.2.0.4 / LibreOffice Community
Build ID: 9a9c6381e3f7a62afc1329bd359cc48accb6435b
CPU threads: 4; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded

All text has the same height, and if modified all rows will get the same height including the last row of text.
Comment 13 Buovjaga 2021-08-23 09:01:02 UTC
Yep, it's fine now!

Arch Linux 64-bit
Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: 58a5bd793a2ed57077fc598281cc74e16373b877
CPU threads: 8; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+xcb)
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 20 August 2021