Download it now!
Bug 53861 - TDF libreoffice rpm / deb packages missing glu and xinerama dependencies
Summary: TDF libreoffice rpm / deb packages missing glu and xinerama dependencies
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.6.2 release
Hardware: Other Linux (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard: target:4.5.0 target:4.4.2
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-20 22:59 UTC by Jason Powers
Modified: 2017-12-20 09:25 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Powers 2012-08-20 22:59:10 UTC
Attempting to run libre 3.5.6 headless on a server (ubuntu) with no X.

/opt/libreoffice3.5/program/soffice --headless
/opt/libreoffice3.5/program/oosplash: error while loading shared libraries: libXinerama.so.1: cannot open shared object file: No such file or directory

System:

uname -a
Linux localhost 2.6.32-24-server #42-Ubuntu SMP Fri Aug 20 15:38:55 UTC 2010 x86_64 GNU/Linux


After installing libxinerama1 it works.

It seems that either:
1.) It probably shouldn't be loading this headless.

2.) libxinerama1 should probably be a dependency on install if it needs it.
Comment 1 Joel Madero 2013-06-10 16:35:36 UTC
Jason - apologies for the delay, is this still an issue - when I run the command I get no error but also LibreOffice doesn't open...I never use headless so not sure exactly what to expect.

If it's still an issue just let me know and I'll try to find a dev to help confirm/fix the issue.


Thanks!
Comment 2 tommy27 2013-09-20 18:06:20 UTC
the expert of headless mode is Riccardo Magliocchetti.
adding him to CC list.
Comment 3 Riccardo Magliocchetti 2013-09-23 07:30:55 UTC
--headless is a runtime option so you should not make any assumption on which libraries your libo was linked against. Missing dependency could possibly have been a packaging issue so please give a try to a modern version to see if it has been fixed in the meantime.

If you don't want to link to X libraries you should give a try building 4.1 with --enable-headless. Am not aware of any distribution providing packages that don't link to X / cairo / toolkits.
Comment 4 A (Andy) 2014-08-01 22:59:30 UTC
Is this issue still open or is it resolved by the comment from Riccardo?
Comment 5 Jérôme Augé 2015-03-10 10:16:17 UTC
The latest .deb packages do not have a dependency on libGLU and libXinerama, so after installing the LibreOffice's .deb packages on a Ubuntu 14.04 (trusty) server you'll stumble on the missing `libGLU.so.1` and `libXinerama.so.1` messages:

    /opt/libreoffice4.4/program/soffice.bin: error while loading shared libraries: libGLU.so.1: cannot open shared object file: No such file or directory

    /opt/libreoffice4.4/program/oosplash: error while loading shared libraries: libXinerama.so.1: cannot open shared object file: No such file or directory

The first one is fixed by installing the `libglu1-mesa` package, and the last one is fixed by installing the `libxinerama1` package:

    apt-get install libglu1-mesa
    apt-get install libxinerama1

The RPMs packages seems to also lack the dependency on libGLU (and maybe libXineram), as I known someone who stumbled on the same problem (missing libGLU.so.1) after installing LibreOffice-4.4 from the RPM packages on a CentOS server.
Comment 6 Riccardo Magliocchetti 2015-03-10 10:39:36 UTC
(In reply to Jérôme Augé from comment #5)
> The latest .deb packages do not have a dependency on libGLU and libXinerama,
> so after installing the LibreOffice's .deb packages on a Ubuntu 14.04
> (trusty) server you'll stumble on the missing `libGLU.so.1` and
> `libXinerama.so.1` messages:
> 
>     /opt/libreoffice4.4/program/soffice.bin: error while loading shared
> libraries: libGLU.so.1: cannot open shared object file: No such file or
> directory
> 
>     /opt/libreoffice4.4/program/oosplash: error while loading shared
> libraries: libXinerama.so.1: cannot open shared object file: No such file or
> directory
> 
> The first one is fixed by installing the `libglu1-mesa` package, and the
> last one is fixed by installing the `libxinerama1` package:
> 
>     apt-get install libglu1-mesa
>     apt-get install libxinerama1
> 
> The RPMs packages seems to also lack the dependency on libGLU (and maybe
> libXineram), as I known someone who stumbled on the same problem (missing
> libGLU.so.1) after installing LibreOffice-4.4 from the RPM packages on a
> CentOS server.
Comment 7 Björn Michaelsen 2015-03-10 14:16:33 UTC
REmoving myself, adding Cloph as this is about TDF packages not distro-provided Ubuntu/Debian ones.

Also lowering severity/prio: As TDF packages are universal and not suited to specific distros, its unrealistic to expect it to provide (distro-specific) dependency information. Use proper distro packages if you want that.


@Cloph: Handle this as you see suitable, if there is no low-risk trivial/easy fix, its perfectly fine to close this as WONTFIX.
Comment 8 Commit Notification 2015-03-10 15:46:01 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=441523b0df8983fb34409a5f4e25dde571be1af7

tdf#53861 - add libGLU.so.1 and libXinerama.so.1 to rpm/deb requirements

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Matthew Francis 2015-03-23 10:44:21 UTC
At the point that patches have been committed, I think this can be at least -> NEW already
Comment 10 Christian Lohmaier 2015-03-23 12:49:14 UTC
as builds for 4.4.2 rc1 are already available, setting to fixed.
Comment 11 Jim Avera 2017-09-29 01:39:18 UTC
It looks like this problem came back in 5.4.3.0 dev. builds

$ /lotest/5.4.3.0.0/opt/libreofficedev5.4/program/soffice
/lotest/5.4.3.0.0/opt/libreofficedev5.4/program/oosplash: error while loading shared libraries: libXinerama.so.1: cannot open shared object file: No such file or directory

However, the library exists:
$ locate libXinerama.so.1
/usr/lib/x86_64-linux-gnu/libXinerama.so.1  (symlink to libXinerama.so.1.0.0)
/usr/lib/x86_64-linux-gnu/libXinerama.so.1.0.0

So maybe the startup wrapper script is setting LD_LIBRARY_PATH incorrectly (just a guess).  I did not have any LD* environment variables myself.


I downloaded
  http://dev-builds.libreoffice.org/daily/libreoffice-5-4/Linux-rpm_deb-x86@71-TDF/current/libreoffice-5-4~2017-09-28_23.26.05_LibreOfficeDev_5.4.3.0.0_Linux_x86_deb.tar.gz
and
  http://dev-builds.libreoffice.org/daily/libreoffice-5-4/Linux-rpm_deb-x86@71-TDF/current/libreoffice-5-4~2017-09-28_23.26.05_LibreOfficeDev_5.4.3.0.0_Linux_x86_deb_langpack_en-US.tar.gz
Comment 12 Jim Avera 2017-09-29 01:57:12 UTC
P.S. I wiped & re-installed only the main code, without help or lang packs, and the problem remains.  

BTW, the official 5.4.1 release does not have the problem.  On a VM I downloaded 
https://www.libreoffice.org/donate/dl/deb-x86_64/5.4.1/en-US/LibreOffice_5.4.1_Linux_x86-64_deb.tar.gz and installed the debs to their default location (/opt/libreoffice5.4) and the result started without error.
Comment 13 Xisco Faulí 2017-09-29 08:27:50 UTC
Dear Jim Avera,
This bug has been in RESOLVED FIXED status for more than 6 months.
If the issue is still reproducible with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/, please report a new issue in https://bugs.documentfoundation.org/enter_bug.cgi providing, if needed, the steps and documents to reproduce it.
Thanks for your understanding and collaboration.
Closing as RESOLVED FIXED