Bug 53864 - Export ignores layer options 'printable' and 'visible'
Summary: Export ignores layer options 'printable' and 'visible'
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 72117 (view as bug list)
Depends on:
Blocks: Layers
  Show dependency treegraph
 
Reported: 2012-08-21 05:37 UTC by Rainer Bielefeld Retired
Modified: 2019-08-07 08:39 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Test Kit (119.14 KB, application/x-7z-compressed)
2012-08-21 05:37 UTC, Rainer Bielefeld Retired
Details
Improved testkit showing how layer information is ignored during export. (592.33 KB, application/zip)
2013-12-21 06:31 UTC, Owen Genat (retired)
Details
Test case (356.70 KB, application/gzip)
2016-08-12 23:40 UTC, Luc Novales
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-08-21 05:37:36 UTC
Created attachment 65863 [details]
Test Kit

Steps how to reproduce  with "LibreOffice 3.6.1.1  German UI/Locale [Build-ID:  4db6344] on German WIN7 Home Premium (64bit):

1. download / unzip attached test kit
2. open "source.odg" from LibO Start Center file menu
3. Do some exports to svg for compete page and selection
   Expected: only contents of layer "Layout" (scheme) visible
   Actual: also comments on invisible / unprintable layers "BMK", "vorlagen",
           "Anmerkung" visible

In test kit you will also find some of my export results, also from Master and also for other file types.

Also a problem with AOOo 3.4 and LibO 3.3.3 (difficult to see because text suppression bug), so seems inherited from OOo

For me this bug causes some horrible chin ups to use .svg export for the job.
Comment 1 Hashem Masoud 2012-10-11 08:18:51 UTC
(In reply to comment #0)
Confirmed here:
Version 3.6.1.2 (Build ID: e29a214) Slackware Linux 13.37
Comments are visible after I export, although they should be invisible.
Comment 2 Owen Genat (retired) 2013-12-21 06:31:02 UTC
Created attachment 91073 [details]
Improved testkit showing how layer information is ignored during export.

The attached files were produced under Ubuntu 10.04 x86_64 using:

- v3.3.0.4 OOO330m19 Build: 6
- v4.1.3.2 Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a

In each ODG (one per version) there are four additional layers with these settings:

- V+P (visible and printable)
- V+nP (visible but NOT printable)
- nV+P (NOT visible but printable)
- nV+nP (NOT visible and NOT printable)

For each ODG export to these formats was made: BMP. EMF, EPS, GIF, JPG, PBM, PDF, PNG, SVG, TIF, WMF, and XPM. I loaded the EMF under Win7HP and took a screenshot to check visibility. For both versions and in all cases (except PDF) the object on each layer is exported to the format, regardless of the visible / printable setting. For PDF, only the V+P layer object is exported.

This would seem to be a more general problem with ignoring the status of these layer settings, than just an SVG-specific issue (the original test kit and description does indicate this).
Comment 3 Owen Genat (retired) 2013-12-21 06:34:59 UTC
As per comment #2, Platform set to All/All. "SVG" removed from summary for clarity.
Comment 4 Owen Genat (retired) 2013-12-21 06:35:37 UTC
*** Bug 72117 has been marked as a duplicate of this bug. ***
Comment 5 crxssi 2014-11-28 21:49:36 UTC
This issue has been annoying me for many years.  I have a complex diagram of our facility with dozens of layers and I often need to export only CERTAIN layers in to a file.  Every time I want to do this, I have to actually delete each layer I don't want included in the export.

Would be something great to fix in LO.  I am thinking the best way to handle it would be to suppress export of layers that are not visible, so what you see is what you get.  Although a case for using the print attribute is probably almost as compelling.
Comment 6 QA Administrators 2015-12-20 16:05:49 UTC Comment hidden (obsolete)
Comment 7 Luc Novales 2016-08-12 23:40:50 UTC
Created attachment 126777 [details]
Test case

bug is present in Version: 5.2.0.4
Build ID: 066b007f5ebcc236395c7d282ba488bca6720265
Threads CPU : 8; Version de l'OS :Linux 3.16; UI Render : par défaut; 
Locale : fr-FR (fr_FR.utf8)

Workaround seems to export only selection (invisible layers are not selectable).

Luc.
Comment 8 Luc Novales 2016-08-12 23:44:44 UTC
Bug was present in - v3.3.0.4 OOO330m19 Build: 6
as said by Owen Genat in comment 2 : https://bugs.documentfoundation.org//show_bug.cgi?id=53864#c2
Comment 9 Regina Henschel 2018-04-08 09:17:17 UTC
On Hackfest Hamburg, April 2018, we have decided to start a project for improving handling of layers and internal structure. In case you start to work on this issue get in contact with Regina (rb.henschel@t-online.de) or Armin (Armin.Le.Grand@me.com). It might be, that your solution touches that project.
Comment 10 Wolfgang Jäger 2019-03-27 11:47:55 UTC
Just tested with LibreOffice Draw V 6.2.2.2

3 shapes, each on a different one of the default layers

Unchecked 'Visible' for one after the other of the layers

Export as Pdf, No 'General' export option checked

Result: 
Exactly the layers set to 'Visible' were exported. 
'Printable' was ignored.

Conclusion:

RESOLVED FIXED
Comment 11 crxssi 2019-03-27 21:38:27 UTC
(In reply to Wolfgang Jäger from comment #10)
> Export as Pdf, No 'General' export option checked
> 
> Result: Exactly the layers set to 'Visible' were exported. 
> 'Printable' was ignored.
> 
> Conclusion: RESOLVED FIXED

Was it tested also with exporting to SVG, PNG or JPEG (the most common non-PDF exports)?  PDF is a very different type of export.  (I have no easy access to a current version right now)
Comment 12 Wolfgang Jäger 2019-03-28 01:10:07 UTC
Sorry. I must have been stoned.
Pdf is still the only export format regarding the visibility of layers. (This is now tested at least with one example for every type.)

Settinng the bug NEW again. 
(Also somehow strange for a bug reporterd in 2012 originally.)
Comment 13 furniturescam 2019-08-07 08:39:44 UTC Comment hidden (spam)