Bug 53970 - EDITING: avi file lost when save presentation to PPTX
Summary: EDITING: avi file lost when save presentation to PPTX
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: high major
Assignee: Tünde Tóth
URL:
Whiteboard: BSA target:7.4.0 target:7.3.3 target:...
Keywords: dataLoss, filter:pptx
: 127764 138548 141385 (view as bug list)
Depends on:
Blocks: PPTX Media-Insert PPT
  Show dependency treegraph
 
Reported: 2012-08-23 15:14 UTC by flyingvjlh
Modified: 2022-05-04 09:17 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
avi test file (18.80 KB, video/avi)
2014-08-11 08:47 UTC, retired
Details
PPTX with the attached avi in PP (81.33 KB, image/png)
2022-03-30 08:53 UTC, Gabor Kelemen (allotropia)
Details
ODP with AVI 2 slides (31.62 KB, application/vnd.oasis.opendocument.presentation)
2022-04-05 11:18 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description flyingvjlh 2012-08-23 15:14:58 UTC
Problem description:   avi file lost

Steps to reproduce:
1. put an avi file in a slide with the video insert tool
2. save
3. open  : no more video

Current behavior: video lost

Expected behavior:  video ok for showing in ppt with powerpoint in microsoft office

Platform (if different from the browser): same  and an xp machine same behavior
              
Browser: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; HPNTDF; .NET4.0C)
Comment 1 A (Andy) 2013-02-16 19:47:52 UTC
reproducible with LO 4.0.0.3 (Win7 Home, 64bit)

Reproduced with the following steps:
1. Inserted an avi file into an Impress presentation
2. Saved as odp, ppt and pptx file
3. Opened with LO, MS Office 2007

Result: 
With the odp file everything is fine and after reopening it with LO it plays the avi file correct.
But when saved as ppt or pptx, then the avi file got lost.  When opening the files with MS Office, then there is also no avi file.
Comment 2 Marcos Souza 2013-09-04 16:59:32 UTC
(In reply to comment #1)
> reproducible with LO 4.0.0.3 (Win7 Home, 64bit)
> 
> Reproduced with the following steps:
> 1. Inserted an avi file into an Impress presentation
> 2. Saved as odp, ppt and pptx file
> 3. Opened with LO, MS Office 2007
> 
> Result: 
> With the odp file everything is fine and after reopening it with LO it plays
> the avi file correct.
> But when saved as ppt or pptx, then the avi file got lost.  When opening the
> files with MS Office, then there is also no avi file.

This error still occurs in current master(version 4.2).

I can reproduce as described by you, but in Linux.
Comment 3 retired 2014-08-11 08:47:15 UTC
Well on OSX 10.9.4 LO 4.3.0.4 it seems avi files do not play at all.

Win8.1 LO 4.3.0.3 in a VM does not allow importing an avi file at all "not supported" says LO.

Hmm. Since this is in such a bad state, raising importance to "high". Would be great to support avi on OSX and windows.

Attaching the avi file I've used to test this.
Comment 4 retired 2014-08-11 08:47:47 UTC
Created attachment 104417 [details]
avi test file
Comment 5 Yousuf Philips (jay) (retired) 2014-08-11 13:11:19 UTC
Tested a wide range of video formats on Windows 7 and none of them worked, saying the format wasnt supported. It would be nice to know what setup the reporter and Andy have that permitted them to add the avi video file.

I did extensive linux testing in bug 79468 and alex did extensive testing in bug 79546 and alot of discussion of the issue happened in bug 56847.
Comment 6 QA Administrators 2015-09-04 02:47:43 UTC Comment hidden (obsolete)
Comment 7 Buovjaga 2015-11-18 10:38:02 UTC
Still repro the disappearance.

Let's put severity to major due to this being data loss. Avi is not found in the pptx container.

I could add the .avi just fine.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: b216cc1b8096eb60c27f67e8c27b7cd756c75e38
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-12_00:06:20
Locale: fi-FI (fi_FI)
Comment 8 QA Administrators 2017-01-03 19:35:13 UTC Comment hidden (obsolete)
Comment 9 Thomas Lendo 2017-12-04 21:51:18 UTC
Still repro in

Version: 6.1.0.0.alpha0+
Build ID: 2618e4a13d719122e6358d9d96864d1691e56a02
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: de-DE (de_DE.UTF-8); Calc: group threaded
Comment 10 Roman Kuznetsov 2018-09-24 19:49:21 UTC
When I saved presentation to ODP, then it doesn't lost avi for me,

but if I saved file to PPTX, then avi lost and I had some shape instead avi in slide

still repro

Version: 6.2.0.0.alpha0+
Build ID: 1aa37aa6bee19099b57555a6d839992b054aa405
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-09-23_10:17:54
Locale: ru-RU (ru_RU); Calc: threaded
Comment 11 Buovjaga 2019-09-23 13:22:54 UTC
Still disappears with PPTX

Arch Linux 64-bit
Version: 6.4.0.0.alpha0+
Build ID: b9a776837462eeb6d50d0decc42604c0c3008eb1
CPU threads: 8; OS: Linux 5.2; UI render: default; VCL: kf5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 11 August 2019
Comment 12 Timur 2021-05-04 13:55:29 UTC Comment hidden (obsolete)
Comment 13 Timur 2021-05-04 14:00:55 UTC
Lost repro with AVI video attachment 158818 [details] in Windows if saved as PPTX. 
PPT is saved but cannot be played in LO.

There are differences if video is inserted or drag&dropped and if saved as PPT or PPTX. Small test on this in bug I'll duplicate https://bugs.documentfoundation.org/show_bug.cgi?id=131414#c12
Comment 14 Timur 2021-05-04 14:02:35 UTC
*** Bug 131414 has been marked as a duplicate of this bug. ***
Comment 15 Timur 2021-05-04 14:08:01 UTC
*** Bug 138548 has been marked as a duplicate of this bug. ***
Comment 16 Timur 2021-05-04 17:00:38 UTC
*** Bug 141385 has been marked as a duplicate of this bug. ***
Comment 17 Commit Notification 2022-03-29 11:00:52 UTC
Tünde Tóth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/bc72514f90d90e1ab3fed8167663e835edf03508

tdf#53970 PPTX: fix export of embedded media files

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Gabor Kelemen (allotropia) 2022-03-30 08:53:14 UTC
Created attachment 179203 [details]
PPTX with the attached avi in PP

Saving an odp containing the attachment 104417 [details] avi file to PPTX still causes an unreadable content error in PP 2013.

Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: a3988b2d147a2442b348d58b79dbd6e71472b7af
CPU threads: 14; OS: Windows 10.0 Build 19044; UI render: default; VCL: win
Locale: en-US (hu_HU); UI: en-US
Calc: threaded Jumbo
Comment 19 Commit Notification 2022-03-30 14:18:10 UTC
Tünde Tóth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/96622aa772518926c4563a54238edc8e83e723c5

tdf#53970 PPTX: add unittest

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2022-03-30 18:47:45 UTC
Tünde Tóth committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/b64c55169d72bfde6aee00673a56d5c25acfd4d4

tdf#53970 PPTX: fix export of embedded media files

It will be available in 7.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2022-03-30 18:48:55 UTC
Tünde Tóth committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/a45cfefc284b2e468ca2847e47102964c67d12c4

tdf#53970 PPTX: add unittest

It will be available in 7.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2022-04-04 11:01:36 UTC
Tünde Tóth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c2e8a96a8107a37901e475c65a8e61211fc3b132

tdf#53970 PPTX: fix broken export of linked media files

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 Commit Notification 2022-04-04 15:06:04 UTC
Tünde Tóth committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/85adc43540f75f2e3ce51fb438e5efd777a5b8f7

tdf#53970 PPTX: fix broken export of linked media files

It will be available in 7.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Timur 2022-04-05 11:18:31 UTC
Created attachment 179322 [details]
ODP with AVI 2 slides

I guess this is WIP. I see in saved and reopened PPTX that 1st slide is OK (video) in LO and NOK still in MSO while 2nd is NOK still in both LO and MSO.
I attach ODP with this sample video.

Bug 138548 and bug 141385 didn't have a sample. 

PPT is unaffected and can be another bug. Bug 131414 was about PPT.
Comment 25 Timur 2022-04-05 11:32:24 UTC
*** Bug 127764 has been marked as a duplicate of this bug. ***
Comment 26 Commit Notification 2022-04-26 15:42:13 UTC
Tünde Tóth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9564747d2fd5d2c859a359dd7fa6242c6859c0d7

tdf#53970 PPTX: fix import of linked media files

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 27 NISZ LibreOffice Team 2022-04-27 08:42:38 UTC
Verified in:

Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 67d8c245daf7c6ee33e908255f2bbd0ea8d08206
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: hu-HU (hu_HU); UI: en-GB
Calc: CL
Comment 28 Commit Notification 2022-04-27 08:50:25 UTC
Tünde Tóth committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/4d26bb9e8fd25edb913ad5fb52bdbc56fad75291

tdf#53970 PPTX: fix import of linked media files

It will be available in 7.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 29 Timur 2022-04-27 12:14:17 UTC Comment hidden (me-too)
Comment 30 Timur 2022-04-27 12:15:38 UTC
(In reply to NISZ LibreOffice Team from comment #27)
> Verified

Please be precise when verifying bugs that have multiple samples or duplicates, also if you tested saved files both in LO and MSO. 
Did you verify for attachment 179322 [details] from this bug and from bug 127764?
Duplicate Bug 131414 was about PPT, if not resolved, it should be reopened.
Comment 31 Timur 2022-04-28 13:59:33 UTC
attachment 179322 [details] saves to PPTX that plays both in LO and MSO, so Fixed.
I reopen Bug 131414 for PPT.
Comment 32 NISZ LibreOffice Team 2022-04-29 06:55:18 UTC
Dear Timur,

I verified with this daily master both ppt and pptx, but it was good for me:
I saved in ppt and pptx too and the video stay in the files.
I could play in PowerPoint and LibreOffice in slideshow and editing mood too both of them (ppt/pptx).  

This was the previous checking settings:

Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 67d8c245daf7c6ee33e908255f2bbd0ea8d08206
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: hu-HU (hu_HU); UI: en-GB
Calc: CL

I checked it again if it something go wrong, but it is good for me with ppt and pptx too, this new daily master.

Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 3a05acb8f0d94728ea6cbfd7a69dac6ffa7ffc68
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL

Steps to reproduce:
1. Open a new Impress document.
2. Insert -> Audio or Video...
3. Attach the uploded avi test file
4. Save as ppt and pptx too
5. Open them in PowerPoint and LibreOffice

It works for me correctly with both daily master.
Comment 33 Buovjaga 2022-04-29 06:56:54 UTC Comment hidden (obsolete)
Comment 34 Timur 2022-04-29 10:57:25 UTC
Thanks for check. 
We agree that PPTX is fixed, so I set this bug for PPTX. 
We don't see the same for PPT so let's write that in Bug 131414.