Bug 54417 - SLIDESHOW: Work wrong on 2560 x 1440
Summary: SLIDESHOW: Work wrong on 2560 x 1440
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA target:3.7.0 target:3.6.3
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-03 06:47 UTC by urly
Modified: 2018-02-26 11:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
the original side in LO (458.90 KB, image/jpeg)
2012-09-16 11:07 UTC, urly
Details
Presentation in a little Window (401.38 KB, image/jpeg)
2012-09-16 11:08 UTC, urly
Details
Presentation in full-screen (28.73 KB, image/jpeg)
2012-09-16 11:09 UTC, urly
Details
Presentation in a big Window (resolution of the monitor) (53.10 KB, image/jpeg)
2012-09-16 11:12 UTC, urly
Details
The substitution of canvas.xcu (deleted)
2012-09-18 15:36 UTC, urly
Details

Note You need to log in before you can comment on or make changes to this bug.
Description urly 2012-09-03 06:47:19 UTC
Problem description: With monitor resolution 2560 x 1440 the show is damaged.

Steps to reproduce:
1. Make a new presentation or take an old one.
2. Press F5

Current behavior: You see something, but not the right things on the right place.

Expected behavior: The same PC with monitor a lower monitor resolution of 1920 x 1080 all works fine.

Platform (if different from the browser): Win 7 64 bit SP1
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0
Comment 1 Jean-Baptiste Faure 2012-09-16 08:08:48 UTC
Please attach a screen-copy showing the problem.

Best regards. JBF
Comment 2 urly 2012-09-16 11:07:48 UTC
Created attachment 67233 [details]
the original side in LO

3 screen-copies are attached: the original LO, slide-show in a little window, slide-show in fullscreen.
The slide-show in a big window fails too.

Thanks for your attention
urly
Comment 3 urly 2012-09-16 11:08:51 UTC
Created attachment 67234 [details]
Presentation in a little Window
Comment 4 urly 2012-09-16 11:09:26 UTC
Created attachment 67235 [details]
Presentation in full-screen
Comment 5 urly 2012-09-16 11:12:58 UTC
Created attachment 67236 [details]
Presentation in a big Window (resolution of the monitor)

LO istself works fine with this resolution
Comment 6 Jean-Baptiste Faure 2012-09-17 11:34:16 UTC
Indeed :-(

Hi Thorsten, are you aware of this kind of problem with slideshows on high resolution screens?

Best regards. JBF
Comment 7 Thorsten Behrens (allotropia) 2012-09-17 11:48:10 UTC
(In reply to comment #6)
> Hi Thorsten, are you aware of this kind of problem with slideshows on high
> resolution screens?
>
Yes, on windows, this is usually a buggy DirectX driver. Can you please try disabling Hardware acceleration under Tools->Options->View?

If that indeed turns out to be the problem, http://wiki.openoffice.org/wiki/CanvasBlacklist has a howto on how to blacklist your particular graphic card / driver. Updates here appreciated, such that we can maintain that list.
Comment 8 urly 2012-09-18 14:45:41 UTC
(In reply to comment #7)

Wow, you're right. After disabling, it works as expected, thank you.
Comment 9 Thorsten Behrens (allotropia) 2012-09-18 15:02:52 UTC
(In reply to comment #8)
> Wow, you're right. After disabling, it works as expected, thank you.
>
Ok, good to know. Still, to prevent other users from stumbling over your problem, would you be able to perform the steps outlined in comment #7? Thanks!
Comment 10 urly 2012-09-18 15:36:55 UTC
Created attachment 67331 [details]
The substitution of canvas.xcu

(In reply to comment #9)

In LO the file called main.xcd instead of canvas.xcs and registrymodifications.xcu instead of canvas.xcu.

I have a CPU-integrated HD4000 Graphic (in a i7-3770-CPU).
Driver: AN old one and the newest.
Comment 11 Thorsten Behrens (allotropia) 2012-09-21 11:33:57 UTC
Blacklisting that device/driver combo, thanks for the numbers!
Comment 12 Not Assigned 2012-09-21 11:35:11 UTC
Thorsten Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9d35d643039f49376504e9002a2c2b8a406d00d9

Fix fdo#54417 - blacklist buggy Intel driver for dxcanvas



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Not Assigned 2012-09-21 12:12:53 UTC
Thorsten Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e7de7acfb2d74afc3816b25494c0792f362e4a4b&g=libreoffice-3-6

Fix fdo#54417 - blacklist buggy Intel driver for dxcanvas


It will be available in LibreOffice 3.6.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 urly 2012-11-10 07:14:42 UTC
(In reply to comment #13)
> Thorsten Behrens committed a patch related to this issue.
> It has been pushed to "libreoffice-3-6":
> 
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=e7de7acfb2d74afc3816b25494c0792f362e4a4b&g=libreoffice-3-6
> 
> Fix fdo#54417 - blacklist buggy Intel driver for dxcanvas
> 
> 
> It will be available in LibreOffice 3.6.3.


It is not fixed! The problem still exist!

My way:
1. Delete the user-directory
2. Install LibreOffice 3.6.3

Best regards
Urly
Comment 15 Jean-Baptiste Faure 2012-11-10 07:24:22 UTC
@Urly: please don't touch the dashboard

best regards. JBF
Comment 16 Thorsten Behrens (allotropia) 2012-11-12 10:08:57 UTC
(In reply to comment #14)
> It is not fixed! The problem still exist!
> 
Sorry to hear - can you re-do the blacklisting as outlined before, and post the xcu file? Maybe the driver version changed?
Comment 17 peter.p.redl 2014-09-27 14:07:34 UTC
Also affected on:
LibreOffice Version: 4.2.5.2

windows 8.1 Pro
i7-4770 + Nvidia GTX 780
GeForce 344.11 driver
Comment 18 aatdark 2014-10-08 14:04:35 UTC
See also Bug 68579
Comment 19 Xisco Faulí 2018-02-26 11:22:15 UTC
The content of attachment 67331 [details] has been deleted