Bug 54465 - FORMATTING: Inserting footnote in section (with columns), make that sections size grow to the full page
Summary: FORMATTING: Inserting footnote in section (with columns), make that sections ...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Attila Szűcs
URL:
Whiteboard: BSA target:7.4.0 target:7.3.0.0.beta2
Keywords:
: 58794 99741 118636 145554 (view as bug list)
Depends on:
Blocks: Footnote-Endnote Page-Layout-Columns
  Show dependency treegraph
 
Reported: 2012-09-03 21:14 UTC by Chris
Modified: 2022-02-07 09:43 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
odt file to demonstrate the bug (9.09 KB, application/vnd.oasis.opendocument.text)
2012-09-03 21:14 UTC, Chris
Details
title bottom section (31.10 KB, application/vnd.oasis.opendocument.text)
2022-02-06 13:22 UTC, Lafricain
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris 2012-09-03 21:14:41 UTC
Created attachment 66579 [details]
odt file to demonstrate the bug

Problem description: When you use footnotes in sections with two or more columns, the size of the section changes - but it shouldn't.

Steps to reproduce:
1. Open new Writer-Document
2. Click on Insert > Section > Columns. Select 2 Columns. Click on Insert.
3. Put the cursor into the created section. Click on Insert > Footnote/Endnote. Click OK.

Current behavior:In the moment when you insert the footnote, the section grows to the size of one page instead of staying small.

Expected behavior: The footnote should be on the foot of the page (as ist happens), but the size of the section should not change.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0
Comment 1 A (Andy) 2012-12-26 23:26:12 UTC
reproducible with LO 3.6.4.3. (Win7 Home, 64bit)

After inserting a footnote the sections grows to one page and in addition, a further page is added.
Comment 2 manj_k 2013-01-25 18:54:31 UTC
Reproducible with LO 3.3.4, AOO 3.4.1, and OOo 3.3.0.
Inherited from OOo.
See also: 'OOo_Bug 20103 - Sections with columns containing footnotes grow to page size' https://issues.apache.org/ooo/show_bug.cgi?id=20103
Comment 3 Chris 2013-09-24 08:28:07 UTC
reproducible with LO 4.0.5.2
Comment 4 QA Administrators 2015-04-01 14:42:18 UTC Comment hidden (obsolete)
Comment 5 Owen Genat (retired) 2015-04-08 23:52:05 UTC
Re-tested instructions provided in comment 0 under GNU/Linux using:
- v3.3.4.1
- v3.4.6.2
- v3.5.7.2
- v3.6.7.2
- v4.0.6.2
- v4.1.6.2
- v4.2.8.2
- v4.3.5.2
- v4.4.1.2

All versions exhibit identical behaviour as originally reported.
Comment 6 Gordo 2015-04-29 14:56:34 UTC
*** Bug 58794 has been marked as a duplicate of this bug. ***
Comment 7 Gordo 2015-04-29 15:06:30 UTC
Rephrased:
Footnotes in sections with columns do not appear outside of the section at the bottom of the page when Format -> Sections -> Options -> Footnotes/Endnotes -> Collect at end of text is unchecked.

If Collect at end of text is checked, then the footnote will appear at the bottom of the corresponding column without changing the size of the section.

Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
Comment 8 Buovjaga 2016-03-17 12:05:42 UTC
*** Bug 98287 has been marked as a duplicate of this bug. ***
Comment 9 Buovjaga 2016-05-14 19:26:45 UTC
*** Bug 99741 has been marked as a duplicate of this bug. ***
Comment 10 QA Administrators 2018-07-05 02:49:33 UTC Comment hidden (obsolete)
Comment 11 Buovjaga 2018-07-17 14:12:11 UTC
*** Bug 118636 has been marked as a duplicate of this bug. ***
Comment 12 Dieter 2018-07-17 14:20:43 UTC
(In reply to Buovjaga from comment #11)
> *** Bug 118636 has been marked as a duplicate of this bug. ***

So still reproducible in

Version: 6.2.0.0.alpha0+ (x64)
Build ID: b0e291a7efcd3af2a72d0b622b1f1b84723f011f
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-06-30_23:43:40
Locale: en-US (de_DE); Calc: CL
Comment 13 Lafricain 2019-06-12 08:52:27 UTC
Still reproducible in 6.2.3.2
Comment 14 Dieter 2021-05-07 07:53:34 UTC
Still present in

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 15a9bee9ef26ce13ed1e26319306a88b6d886158
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL
Comment 15 Attila Szűcs 2021-11-08 13:17:02 UTC
This bug mainly fixed in Bug 139336 (that should be the duplicate of this ticket, but that is already merged.)

What left is that already made old odt files should not change their layout. (to avoid possible regressions)
That would be Bug 145554 ... but because that bug is a lot newer, i will make that bug to the duplicete of this bug.
Comment 16 Attila Szűcs 2021-11-08 13:18:53 UTC
*** Bug 145554 has been marked as a duplicate of this bug. ***
Comment 17 Commit Notification 2021-11-29 08:34:40 UTC
Attila Szűcs committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/41cc1d2c0c0c3bfa5ba341311f68df05375859fb

tdf#54465 tdf#139336 sw: add compat. flag for footnote in column

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Attila Szűcs 2021-11-29 12:29:33 UTC
*** Bug 145826 has been marked as a duplicate of this bug. ***
Comment 19 Commit Notification 2021-11-30 09:10:01 UTC
Attila Szűcs committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/8a82c6f3f1e85c941ac05b48416450cec813a04e

tdf#54465 tdf#139336 sw: add compat. flag for footnote in column

It will be available in 7.3.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 NISZ LibreOffice Team 2021-12-02 08:39:41 UTC
Verified in:
Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 4ac9032163cf55c160145373e7c41741c9c339ca
CPU threads: 8; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: CL
Comment 21 Lafricain 2022-02-06 13:22:09 UTC
Created attachment 178098 [details]
title bottom section
Comment 22 Lafricain 2022-02-06 13:24:06 UTC
A new problem appears now if we have a note in the bottom of the section. (in a title by instance. Look the file attached.
Comment 23 Dieter 2022-02-06 14:26:59 UTC
(In reply to Lafricain from comment #22)
> A new problem appears now if we have a note in the bottom of the section.
> (in a title by instance. Look the file attached.

Status of this report is VERIFIED Fixed. So please open a new report. Thank you.
Comment 24 Timur 2022-02-07 09:43:50 UTC
Both bug 139336 and bug 54465 introduce a change in behavior and should be added and explained in https://wiki.documentfoundation.org/ReleaseNotes/7.3.

What I see is that behavior is corrected for new documents, but old ones like attachment 66579 [details] keep page-sized column. 
I can't see how it can be changed and why removing and recreating columns is not the same as making new columns if all done in fixed LO version.  
And if that's the same cause as problem with attachment 178098 [details].