Bug 54479 - CONFIGURATION: Menu 'Tools - (open) Bibliography Database', although Base not installed
Summary: CONFIGURATION: Menu 'Tools - (open) Bibliography Database', although Base not...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 99911 (view as bug list)
Depends on:
Blocks: Bibliography
  Show dependency treegraph
 
Reported: 2012-09-04 05:25 UTC by Rainer Bielefeld Retired
Modified: 2018-07-22 17:59 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-09-04 05:25:17 UTC
I found with  LibO 3.5.5.2 Build ID 350m1 (Build:202) on Ubuntu 12.04 64 bit (VirtualBox).

Steps how to reproduce: 
1. Install LibO 3.5.2 with default settings on  Ubuntu 64
   In Linux "Applications" WRITER, CALC, ... are shown, but not Base
   (And in LibO start Center Base will be shown greyed out)
2. Start Writer
3. Menu 'Tools -> Bibliography Database' is available, but how should that
   be opened without Database module?
   Will crash (Bug 48775)

An other inconsistency of that installation is that all Database Help is available (and will show hits for lot of search) although module is not available
Comment 1 Rainer Bielefeld Retired 2012-09-04 05:28:10 UTC
Of course this one is "only for the records", we can't fix that.
Comment 2 Rainer Bielefeld Retired 2012-09-04 12:11:10 UTC
I was wrong this  IS our bug, [Reproducible] with parallel installation of Master "LOdev  3.7.0.0.alpha0+   -  ENGLISH UI / German Locale  [Build ID: 6cad15d]"  {tinderbox: @6, pull time 2012-09-03 23:08:07} on German WIN7 Home Premium (64bit) when I install without Base. 

As long as we offer to install without particular components (and without warning "Experimental" this is a serious bug) because of an other bug (I just can't remember the number), LibO crashes when this menu item is selected without installed Base.

I think the same mechanism disabling the Database Buton in the LibO Start Center should also disable this menu item.

No idea whether there have been versions where that worked correctly.

@Ivan:
Can you help?
Comment 3 Rainer Bielefeld Retired 2012-09-04 12:18:51 UTC
The other Bug is "Bug 48775 - CRASH when opening biblio.odb via tools menu without Base module installed"
Comment 4 Ivan Timofeev (retired) 2012-09-04 19:14:22 UTC
This can be easily done (I mean hiding menu 'Tools -> Bibliography Database', don't know about help). But maybe it would be helpful not to do this for now, to simplify verification of a fix for Bug 48775 ?..
Comment 5 Lionel Elie Mamane 2012-09-05 07:58:22 UTC
(In reply to comment #4)
> This can be easily done (I mean hiding menu 'Tools -> Bibliography Database',

I'd rather it is inactivated (greyed out) rather than hidden.
Comment 6 Samuel Mehrbrodt (CIB) 2013-01-09 20:08:24 UTC
This is something that should be done ASAP.
What about showing a message box that Base needs to be installed? Otherwise users will not know why this feature doesn't work
Comment 7 Samuel Mehrbrodt (CIB) 2013-01-09 20:12:34 UTC
Seems this has been fixed.

*** This bug has been marked as a duplicate of bug 33266 ***
Comment 8 Rainer Bielefeld Retired 2013-01-09 21:10:36 UTC
<http://wiki.documentfoundation.org/BugReport_Details#Version>

I wonder how the fix for Bug 33266 with target:3.5.2 can work for this bug, what I observed with 3.5.2. 
As long as I do not see this fixed in a current build I doubt that this one is a DUP of Bug 33266
That one was concerning a crash, this one for a menu item what can't work

@Samuel M.:
Can you explain?
Comment 9 Samuel Mehrbrodt (CIB) 2013-01-09 21:51:30 UTC
Well, the bug is the same as I understand it. Writer crashes when selecting the "Bibliography Database" and Base is not installed.
But now I'm also confused. I just tried with a Master build on Windows and it still crashes. I wonder what the bugfix did.

The other Bug 48775 is about the same problem. All I wanted to do, is have the discussion in one bug. So maybe all are duplicates of Bug 33266 and we need to reopen that one?
Comment 10 Rainer Bielefeld Retired 2013-01-10 05:28:18 UTC
Still [Reproducible] with parallel installation of  "LOdev  4.0.0.0.beta2   -  GERMAN UI / German Locale  [Build ID: 4104d660979c57e1160b5135634f732918460a0)]"  {tinderbox: @6, pull time 2012-12-20} on German WIN7 Home Premium (64bit) with subsequnetly removed Database modul and with separate /4 User Profile for Master Branch.

As written in original report,  in Start  Center Database is greyed out, but the menu Item Menu 'Tools -> Bibliography Database' Still is  visible (and Crashes, BTW, I will check that today, later). 
Other Places with useless active Database menu items:
* 'Tools -> Options - LibO Base'

@Samuel M.
Simply that there is no word "crash" in the summary should tell you that this bug is not about a crash, and so it is a foregone that that it is doubtful that this one is a DUP of bug 33266. Please be very precise with your observations and comments.
Comment 11 Rainer Bielefeld Retired 2013-01-10 05:29:00 UTC
ASSIGNED due to facts
Comment 12 Ivan Timofeev (retired) 2013-12-15 16:53:55 UTC
Set to NEW, because I don't contribute to LibreOffice anymore.
Comment 13 Alex Thurgood 2015-01-03 17:39:31 UTC Comment hidden (no-value)
Comment 14 QA Administrators 2016-01-17 20:05:05 UTC Comment hidden (obsolete)
Comment 15 Heiko Tietze 2016-08-02 14:50:53 UTC
*** Bug 99911 has been marked as a duplicate of this bug. ***
Comment 16 QA Administrators 2017-09-01 11:20:21 UTC Comment hidden (obsolete)
Comment 17 Muhammet Kara 2017-11-30 22:26:55 UTC
Couldn't reprıduce on Fedora 26 with:

Version: 5.3.7.2.0+
Build ID: 5.3.7.2-2.fc26
CPU Threads: 4; OS Version: Linux 4.13; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: tr-TR (tr_TR.UTF-8); Calc: group

When the menu item is clicked, the bibliography database is opened although Base is not installed.

Is this bug still valid?
Comment 18 Dmytro Kyrychuk 2017-12-03 11:39:02 UTC
Doesn't crash on Ubuntu. However, when the menu item is clicked the bibliography database is not shown. Libreoffice Base is not installed (there is no menu item for Base), but libreoffice-base-core is installed:

    $ apt-cache policy libreoffice* | grep -A 2 "libreoffice-base"
    libreoffice-base:
      Installed: (none)
      Candidate: 1:5.3.1-0ubuntu2
    --
    libreoffice-base-core:
      Installed: 1:5.3.1-0ubuntu2
      Candidate: 1:5.3.1-0ubuntu2
    --
    libreoffice-base-drivers:
      Installed: (none)
      Candidate: 1:5.3.1-0ubuntu2
 

Version: 5.3.1.2
Build ID: 1:5.3.1-0ubuntu2
CPU Threads: 4; OS Version: Linux 4.10; UI Render: default; VCL: gtk2; Layout Engine: new; 
Locale: uk-UA (en_US.UTF-8); Calc: CL
Comment 19 QA Administrators 2018-07-03 14:15:19 UTC Comment hidden (obsolete)
Comment 20 Dmytro Kyrychuk 2018-07-22 17:59:03 UTC
The "Tools - Bibliography Database" menu item prompts to install libreoffice-base package now.

Version: 6.0.3.2
Build ID: 1:6.0.3-0ubuntu1