Bug Hunting Session
Bug 54514 - PRINT PREVIEW: Old icon for page left
Summary: PRINT PREVIEW: Old icon for page left
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: All All
: low minor
Assignee: Andras Timar
URL:
Whiteboard: Confirmed:4.1.3.2:OSX10.9 target:4.3....
Keywords: difficultyBeginner, easyHack, topicUI
: 57911 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-09-04 22:19 UTC by Horst
Modified: 2016-02-18 16:37 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
ODT file with 2 screen shots (339.69 KB, application/vnd.oasis.opendocument.text)
2012-10-08 19:08 UTC, Horst
Details
Picture of my LibreOffice (225.11 KB, image/png)
2012-10-09 08:48 UTC, Michael Meeks
Details
Screenshot of LibO 3.6.2.2, Print Preview, on Mac OS X 10.6.8 (428.37 KB, image/png)
2012-10-09 09:20 UTC, Roman Eisele
Details
Screenshot of LibO 3.6.0.4, Print Preview, on Mac OS X 10.6.8 (453.25 KB, image/png)
2012-10-09 09:27 UTC, Roman Eisele
Details
Print Preview LO 4.1 RC2 (27.86 KB, image/png)
2013-07-08 10:53 UTC, Mikeyy - L10n HR
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Horst 2012-09-04 22:19:09 UTC
in the page navigation in Print preview the icon for "page left" is still the old one (open book with left arrow) insteed of the new hollow big arrow.
Just a booboo.
Comment 1 Horst 2012-09-17 22:14:29 UTC
Problem not resolved in 3.6.2rc
Comment 2 Horst 2012-10-07 19:31:00 UTC
More precise:
CALC: old, new, new, new icon in page navigation
WRITER: new, new, new, old icon
Base/Report = WRITER
Other modules N/A
Comment 3 Roman Eisele 2012-10-08 07:02:19 UTC
Nice catch! Thank you for noticing and reporting.

However, em, sorry, but you say yourself this was “Just a booboo.” Therefore IMHO this should not be on the “3.6 most annoying bugs” list. ;-) Or at least, I don’t understand why ... so more explanation would be necessary.

No offence! I just want the MAB list to be useful, and it will not be useful anymore if we add all somewhat annoying bugs to it (I can remember about 100 more bugs specific to 3.6 which could be added like this one, too ;-), therefore I want to express my doubts.
Comment 4 Horst 2012-10-08 16:59:25 UTC
(In reply to comment #3)
> Nice catch! Thank you for noticing and reporting.
> 
> However, em, sorry, but you say yourself this was “Just a booboo.” Therefore
> IMHO this should not be on the “3.6 most annoying bugs” list. ;-) Or at
> least, I don’t understand why ... so more explanation would be necessary.
> 
> No offence! I just want the MAB list to be useful, and it will not be useful
> anymore if we add all somewhat annoying bugs to it (I can remember about 100
> more bugs specific to 3.6 which could be added like this one, too ;-),
> therefore I want to express my doubts.

Yes Roman you are sort of right. BUT the bug is reported for over one month and nobody looked at it. So some time somehow some body has to take care of it. And you are right it is not a real bug it just how we say in german a "Schönheitsfehler".

How about this: can we open up a minor MAB list where we can dump this "booboos", which are not critical for the function of LO but need to be adressed too?
Comment 5 Michael Meeks 2012-10-08 18:28:23 UTC
I don't see this in 3.6.1.2 - is this a regression specific to 3.6.2rc ? I don't see it in master either FWIW.

What theme are you using ? and/or can you take a screenshot of the icons ? I'm looking at the print/page-preview toolbar is that what you're talking about ? file->page preview.

Thanks ! :-)
Comment 6 Horst 2012-10-08 19:08:58 UTC
Created attachment 68275 [details]
ODT file with 2 screen shots

Attached ODT file with 2 screen shots WRITER and CALC, the old icon is circled yellow.
It is in the Print-Preview window, File -> Print Preview or Print Preview icon from toolbar.

It is in since 3.6.0.
Comment 7 Michael Meeks 2012-10-09 08:48:48 UTC
Created attachment 68319 [details]
Picture of my LibreOffice

So - oddly, I simply don't see this issue at all; I attach a screenshot of my desktop. Is it possible that you have customized your toolbar in some way ? if so this could easily be the cause of the issue.
Comment 8 Michael Meeks 2012-10-09 08:49:31 UTC
Roman - can you reproduce this ? is it platform specific ?
Comment 9 Roman Eisele 2012-10-09 09:20:43 UTC
Created attachment 68320 [details]
Screenshot of LibO 3.6.2.2, Print Preview, on Mac OS X 10.6.8

(In reply to comment #8)
> Roman - can you reproduce this ? is it platform specific ?

Yes, I can reproduce it on MacOS X 10.6.8 (Intel) -- with
  * LibreOffice 3.6.2.2
  * LOdev 3.7.0.0.alpha0+ (build ID: dd11a1e; pull time: 2012-10-04)
I see the same wrong icon, cf. attached screenshot.

Before testing, I have reset my LibO/LOdev user profiles, so no customization is involved, only default settings. The icon set used on Mac OS X by default is “Automatic (Tango)”.
Comment 10 Roman Eisele 2012-10-09 09:23:03 UTC
Changed Platform to “All”, because reproducible both on Windows and Mac OS X.
Adapted Importance pickers according to current QA conventions.
Comment 11 Roman Eisele 2012-10-09 09:27:55 UTC
Created attachment 68321 [details]
Screenshot of LibO 3.6.0.4, Print Preview, on Mac OS X 10.6.8

(In reply to comment #5)
> I don't see this in 3.6.1.2 - is this a regression specific to 3.6.2rc ?

Not a regression in 3.6.2.x -- I can already reproduce it in 3.6.0.4, see attached screenshot.
Comment 12 Roman Eisele 2012-10-09 09:28:49 UTC
Adapted version number according to previous comment and conventions.
Comment 13 Andras Timar 2012-10-09 09:37:00 UTC
"c:\Program Files\LibreOffice 3.6\share\config\images_tango.zip\cmd\sc_gotoendofdoc.png" and "c:\Program Files\LibreOffice 3.6\share\config\images_tango.zip\cmd\sc_previouspage.png" are the wrong icons. Tango is the default icon theme on Windows. sc_previouspage.png seems to be missing from the source in libreoffice-3-6 branch, while sc_gotoendofdoc.png is there...
Comment 14 Andras Timar 2012-10-09 10:34:10 UTC
(In reply to comment #13)
I checked out the files again. Everything was there. Contents of libreoffice-3-6 and master branches match. Could this be a bug in git?
Comment 15 Horst 2012-10-09 15:54:51 UTC
Check out in writer and CALC:
Custumize -> Toolbars -> "Page Preview"; Modify > change Icon

The icon lists of Writer and Calc are different (Tango). Writer has no "End of File", calc has no "Page Left" and I could not find the displayed icon.

Looks to me like copying right icons in the right list (.zip).

Hope it helps a bit.
Comment 16 Horst 2012-10-10 17:02:47 UTC
(In reply to comment #13)
> "c:\Program Files\LibreOffice
> 3.6\share\config\images_tango.zip\cmd\sc_gotoendofdoc.png" and "c:\Program
> Files\LibreOffice 3.6\share\config\images_tango.zip\cmd\sc_previouspage.png"
> are the wrong icons. Tango is the default icon theme on Windows.
> sc_previouspage.png seems to be missing from the source in libreoffice-3-6
> branch, while sc_gotoendofdoc.png is there...

Andras, sc_previouspage.png is the old one and is there (CALC) and needs to be replaced with sc_pageup.png.
WRITER: sc_gotoendofdoc.png is old and needs to be replaced with sc_lastpage.png.

All of them are in images_tango.zip\cmd\.

The crystal theme has the same problem.
Comment 17 Petr Mladek 2012-10-22 11:53:17 UTC
Heh, the MAB metabug is intended for highlighting critical bugs that break users from their work. I am afraid that this rather cosmetic issue could does not fit there => removing the dependency.

Anyway, thanks a lot for tracking it down. It should be easy to prepare patch now => nice essy task => marking as it.
Comment 18 Horst 2012-10-22 20:11:37 UTC
(In reply to comment #17)
> Heh, the MAB metabug is intended for highlighting critical bugs that break
> users from their work. I am afraid that this rather cosmetic issue could
> does not fit there => removing the dependency.
> 
> Anyway, thanks a lot for tracking it down. It should be easy to prepare
> patch now => nice essy task => marking as it.

Please check out my comment #4, may be you can create something a MMAB (Minor Most annoying Bug) ;-).
Comment 19 Andras Timar 2012-11-05 09:11:28 UTC
(In reply to comment #16)
Horst, there are identical images with different names in icon themes, that's a different issue. What I saw:
1. We don't have the issue on Linux.
2. Needed icons are missing from Windows install kit.
3. Some icons were missing in my checked out git tree.
4. I checked out once more, and they appeared.
Therefore I think it is a mysterious bug with git + Cygwin + Windows combo. I CC Fridrich, maybe he has a clue.
Comment 20 Radu 2012-12-17 00:47:56 UTC
Still reproducible in Version 3.6.4.3 (Build ID: 2ef5aff)
Comment 21 Mikeyy - L10n HR 2013-07-08 10:53:35 UTC
Created attachment 82180 [details]
Print Preview LO 4.1 RC2

This is still an issue in LO 4.1 RC2, Windows 7. Picture attached.
Comment 22 Mikeyy - L10n HR 2013-07-08 12:00:55 UTC
*** Bug 57911 has been marked as a duplicate of this bug. ***
Comment 23 Winfried Donkers (retired) 2013-07-08 12:05:52 UTC
@Mickeyy.vip: can you tell me why you have added me to the cc-list? Are you expecting something from me?
Comment 24 Mikeyy - L10n HR 2013-07-08 12:10:06 UTC
No, you reported bug that was copy of this bug. Just to keep you informed.
Comment 25 Björn Michaelsen 2013-10-04 18:46:32 UTC
adding LibreOffice developer list as CC to unresolved EasyHacks for better visibility.

see e.g. http://nabble.documentfoundation.org/minutes-of-ESC-call-td4076214.html for details
Comment 26 Julien Nabet 2013-12-14 23:41:55 UTC
On pc Debian x86-64 with master sources updated today and brand new LO profile, I don't reproduce this (or perhaps miss it). (Tango theme by default).
Arrows seem ok in Print preview for Calc and Writer.

Any update?
Comment 27 retired 2013-12-15 12:34:54 UTC
Tested with OS X 10.9.

Open new writer document in LO 4.1.3.2 click print preview and still see that old icon.

Adding according whiteboard status.
Comment 28 Julien Nabet 2013-12-27 16:31:39 UTC
It seems MacOs only since I can reproduce this with MacOs 10.7 and LO 4.1.4
Does anyone reproduce this problem with 4.1.4 and other platform than MacOs?

A code pointer would be useful here.
Comment 29 Mikeyy - L10n HR 2013-12-27 19:44:51 UTC
Yes it's still here.
4.1.4.2 Windows 7
Open new calc document and click "Print Preview".
If you are using Tango theme, first icon from left, icon for "Previous page" will be different from "Next page" icon. You can find screenshot in comment 21.
Comment 30 tommy27 2013-12-28 08:06:20 UTC
it seems a GUI issue. I add Ivan Timofeev to CC list. He's done a lot of fixes and tweaks to other icon bugs
Comment 31 Julien Nabet 2013-12-28 17:44:56 UTC
With 4.2.0 RC1, I don't reproduce this with MacOs, Tango theme.

Could someone give a try to it and confirm?
Comment 32 Commit Notification 2013-12-28 18:53:13 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3f2bec473597a82b8344b0e7ee290a0f3be96752

fdo#54514 typos in icon themes' link.txt



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 33 Commit Notification 2013-12-28 18:57:35 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2fc5f921129d365107d10c4eb6cb13903d3dc6f2&h=libreoffice-4-2

fdo#54514 typos in icon themes' link.txt


It will be available in LibreOffice 4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 34 Commit Notification 2013-12-28 21:01:51 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3c5cae9b3c5dc3f6d3d03e07f17e71bd7eaa9aca&h=libreoffice-4-1

fdo#54514 fix Tango icon names


It will be available in LibreOffice 4.1.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 35 Robinson Tryon (qubit) 2015-12-16 05:25:10 UTC
Migrating Whiteboard tags to Keywords: (EasyHack DifficultyBeginner TopicUI )
[NinjaEdit]
Comment 36 Robinson Tryon (qubit) 2016-02-18 16:37:10 UTC
Remove LibreOffice Dev List from CC on EasyHacks
(curtailing excessive email to list)
[NinjaEdit]