Bug 54769 - Image attached to cell gets distorted when the cell height changes
Summary: Image attached to cell gets distorted when the cell height changes
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-Images
  Show dependency treegraph
 
Reported: 2012-09-11 10:58 UTC by sergio.callegari
Modified: 2018-03-06 14:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
File in which the problem occurs (18.55 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-12-28 20:14 UTC, Sören
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2012-09-11 10:58:08 UTC
Even if an image is attached to a cell, this does not mean that its height should change with the cell height.  Dynamically changing the height with the row height causes distortion in the images.
Comment 1 Sören 2012-12-28 20:14:29 UTC
Created attachment 72228 [details]
File in which the problem occurs
Comment 2 Sören 2012-12-28 20:15:47 UTC
I can confirm the problem in
Version 4.0.0.0.beta2 (Build ID: 4104d660979c57e1160b5135634f732918460a0)
on Ubuntu 12.04 (x86)

To reproduce in the attached file:
*Change height of row 6
*See that the image is disturbed
Comment 3 QA Administrators 2015-04-19 03:20:36 UTC Comment hidden (obsolete)
Comment 4 sergio.callegari 2015-04-25 10:04:35 UTC
Bug is still present in LibO 4.3.3 as shipped by the ubuntu distro.

Unfortunately, I will not be able to test 4.4 since I have moved back to distro provided packages after encountering problems with how TDF has started packaging LibO for debian derivatives starting at 4.4.

If this is not enough, feel free to close the bug. I will reopen when I upgrade to ubuntu versions providing 4.4 if the bug is still there.
Comment 5 sergio.callegari 2016-02-16 14:40:49 UTC
Still present as of 5.1.1 RC 1
Comment 6 Samuel Mehrbrodt (CIB) 2018-03-06 14:54:12 UTC
It's now possible to anchor images to cell without resizing them with the cell:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=acf0bad4e2b8c3c43aaaee8312c8a61d3552fcc2